Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

My computer was taken over by a bunch of pups I opened, and I removed them, but lost the search bar on my Mozilla start page, how do I retrieve it?

  • 2 replies
  • 1 has this problem
  • Last reply by cor-el

more options

Can't seem to retrieve the search bar that should be located beside the address bar. Tried for several hours, but can't seem to find the right information. I don't want to reset Firefox because I have too many customs set. I used options and put the find symbol, but it wouldn't open, so still need the search bar to fill in specific words for search feature. I also have a problem with the new tab- before I cleaned all the pups I used to go to mozilla home page and when I clicked on new tab, it always brought up the pages I had recently visited--now I just get a blank page, don't even get the FIrefox logo on the new tab. How do I restore this feature I use Mozilla firefox as my browser, and open that to my start page, something I do not want to lose,

All Replies (2)

more options

There is a feature to restore the toolbar layout to the default layout with the search bar/search box on the right. If you want to try that:

"3-bar" menu button > Customize > "Restore Defaults" button

There is a hidden setting for the new tab page:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box that appears above the list, type or paste newtab and pause while the list is filtered

(3) Double-click the browser.newtab.url preference and enter the desired value (or for the default, right-click > Reset on the preference):

  • Page thumbnails (default) => about:newtab
  • Blank tab => about:blank
  • Built-in Firefox home page => about:home
  • Any other page => full URL to the page

Press Ctrl+t to open a new tab and verify that it worked.


more options

You can try to click the "Restore Defaults" button in the Customize palette.

Make sure that toolbars like the "Bookmarks Toolbar" are visible.

  • "3-bar" Firefox menu button > Customize > Show/Hide Toolbars
  • View > Toolbars
    Tap the Alt key or press F10 to show the Menu Bar
  • Right-click empty toolbar area

Open the Customize window and set which toolbar items to display.

  • "3-bar" Firefox menu button > Customize
  • check that "Bookmarks Toolbar items" is on the Bookmarks Toolbar
  • if "Bookmarks Toolbar items" is not on the Bookmarks Toolbar then drag it back from the Customize palette into the Customize window to the Bookmarks Toolbar
  • if missing items are in the Customize palette then drag them back from the Customize window on the toolbar
  • if you do not see an item on a toolbar and in the Customize palette then click the "Restore Defaults" button to restore the default toolbar setup

Modified by cor-el