X
Tap here to go to the mobile version of the site.

Support Forum

Select and upload file to website stoped working on firefox 31

Posted

On a site using CKEditor and the RoxyFileman file manager to upload the files, I always used the "Browse" button to select a file from my computer, then pressed the Upload button and job done. Today upgraded to Firefox 31 and now when I press the upload button the "select file" window remains on screen and no upload. Yesterday night I had a report from another user of the same site for this problem. I used version 30 and he had upgrade to version 31... Checked and no problem with Windows 7 and Windows XP with IE 11, Chrome 36 and Firefox 30 and Linux Mint 17 with Firefox 30. On sites with the classic "Browse" button, there is no problem.

On a site using CKEditor and the RoxyFileman file manager to upload the files, I always used the "Browse" button to select a file from my computer, then pressed the Upload button and job done. Today upgraded to Firefox 31 and now when I press the upload button the "select file" window remains on screen and no upload. Yesterday night I had a report from another user of the same site for this problem. I used version 30 and he had upgrade to version 31... Checked and no problem with Windows 7 and Windows XP with IE 11, Chrome 36 and Firefox 30 and Linux Mint 17 with Firefox 30. On sites with the classic "Browse" button, there is no problem.

Chosen solution

Problem solved with Firefox 32! Now everything works again as before...

Thank you Mozilla team! I am very happy to see that you are taking in mind our problems and you always support our job. Thanks again!

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Next Generation Java Plug-in 10.65.2 for Mozilla browsers
  • Shockwave Flash 14.0 r0
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.07
  • Adobe Shockwave for Director Netscape plug-in, version 12.0.3.133
  • 4.0.60831.0
  • np-mswmp
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • Firefox 31.0
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:31.0) Gecko/20100101 Firefox/31.0
  • Support URL: https://support.mozilla.org/1/firefox/31.0/WINNT/en-US/

Extensions

  • Download videos and MP3s from YouTube 4.5.3.1206 ({B64D9B05-48E1-4CEB-BF58-E0643994E900})
  • Firebug 2.0.2 (firebug@software.joehewitt.com)
  • FireFontFamily 0.1.2 (firefontfamily@firebugextensions.org)
  • FirePHP 0.7.4 (FirePHPExtension-Build@firephp.org)
  • Google Translator for Firefox 2.1.0.3 (translator@zoli.bod)
  • Greek Spelling dictionary 0.8.5 (el-GR@dictionaries.addons.mozilla.org)
  • Locale Switcher 3 ({338e0b96-2285-4424-b4c8-e25560750fa3})
  • Magic Actions for YouTube™ 6.7.9.1 (jid0-UVAeBCfd34Kk5usS8A1CBiobvM8@jetpack)
  • Polski slownik poprawnej pisowni 1.0.20110621 (pl@dictionaries.addons.mozilla.org)
  • Print Edit 12.8 (printedit@DW-dev)
  • Search By Image (by Google) 1.1.2 ({ce7e73df-6a44-4028-8079-5927a588c948})
  • Tile Tabs 11.9 (tiletabs@DW-dev)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Windows Media Player Extension for Firefox 1.1 (jid0-nRwp7VvCqZcSRTppwWz2npqGEKw@jetpack)
  • avast! Online Security 9.0.2021.112 (wrc@avast.com) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce GTX 660
  • adapterDescription2:
  • adapterDeviceID: 0x11c0
  • adapterDeviceID2:
  • adapterDrivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterDrivers2:
  • adapterRAM: 2048
  • adapterRAM2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16571
  • driverDate: 3-4-2014
  • driverDate2:
  • driverVersion: 9.18.13.3523
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 2
  • numTotalWindows: 2
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce GTX 660 Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • accessibility.typeaheadfind: True
  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.cache.frecency_experiment: 3
  • browser.places.smartBookmarksVersion: 7
  • browser.search.update: False
  • browser.sessionstore.upgradeBackup.latestBuildID: 20140716183446
  • browser.startup.homepage: about:home
  • browser.startup.homepage_override.buildID: 20140716183446
  • browser.startup.homepage_override.mstone: 31.0
  • browser.tabs.loadInBackground: False
  • browser.tabs.warnOnClose: False
  • browser.tabs.warnOnOpen: False
  • dom.max_chrome_script_run_time: 0
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 31.0
  • font.internaluseonly.changed: False
  • general.autoScroll: False
  • gfx.direct3d.last_used_feature_level_idx: 0
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1406655458
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • plugin.state.java: 2
  • plugin.state.npctrl: 2
  • plugin.state.npdeployjava: 0
  • plugin.state.npgoogleupdate: 0
  • plugin.state.npintelwebapiipt: 0
  • plugin.state.npintelwebapiupdater: 0
  • plugin.state.npnv3dv: 0
  • plugin.state.npnv3dvstreaming: 0
  • privacy.clearOnShutdown.offlineApps: True
  • privacy.clearOnShutdown.sessions: False
  • privacy.sanitize.migrateFx3Prefs: True
  • security.tls.version.max: 1
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1404089684

Misc

  • User JS: No
  • Accessibility: No
FredMcD
  • Top 10 Contributor
4259 solutions 59636 answers

Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache

Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

and

  • Remove Cookies

Warning ! ! This will log you out of all sites you're logged in to. Press the Alt or F10 key to bring up the tool bar. Followed by;

Windows; Tools > Options Linux; Edit > Preferences Mac; application name > Preferences

Then Privacy. Under History, select Firefox will Use Custom Settings. There is a button on the right side called Show Cookies.

If there is still a problem, Start Firefox in Safe Mode {web link} While you are in safe mode; Press the Alt or F10 key to bring up the tool bar. Followed by;

Windows; Tools > Options Linux; Edit > Preferences Mac; application name > Preferences

Then Advanced > General. Look for and turn off Use Hardware Acceleration.

Poke around safe web sites. Are there any problems?. Then restart.

Many site issues can be caused by corrupt cookies or cache. * Clear the Cache Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now" and * Remove Cookies '''''Warning ! ! '' This will log you out of all sites you're logged in to.''' Press the '''Alt''' or '''F10''' key to bring up the tool bar. Followed by; Windows; '''Tools > Options''' Linux; '''Edit > Preferences''' Mac; ''application name'' '''> Preferences''' Then '''Privacy.''' Under '''History''', select Firefox will '''Use Custom Settings'''. There is a button on the right side called '''Show Cookies'''. If there is still a problem, '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode]''' {web link} While you are in safe mode; Press the '''Alt''' or '''F10''' key to bring up the tool bar. Followed by; Windows; '''Tools > Options''' Linux; '''Edit > Preferences''' Mac; ''application name'' '''> Preferences''' Then '''Advanced > General.''' Look for and turn off '''Use Hardware Acceleration'''. Poke around safe web sites. Are there any problems?. Then restart.

Question owner

Thanks for the response but... problem still exists! I did all the steps but no luck! I had never ever this problem untill Firefox 31. Everything was working OK untill this last update... Yesterday another three customers called to tell me that they cannot upload files to their web site. I asked them if they upgraded firefox and all three said... YES. First two have Win XP and the other Win 8. Also there is no problem with the site code. Chrome, IE and Opera, in Win XP, Win 7, Win 8, Ubuntu and Linux Mint, ALL WORKING! Only Firefox 31 has this problem...

Thanks for the response but... problem still exists! I did all the steps but no luck! I had never ever this problem untill Firefox 31. Everything was working OK untill this last update... Yesterday another three customers called to tell me that they cannot upload files to their web site. I asked them if they upgraded firefox and all three said... YES. First two have Win XP and the other Win 8. Also there is no problem with the site code. Chrome, IE and Opera, in Win XP, Win 7, Win 8, Ubuntu and Linux Mint, ALL WORKING! Only Firefox 31 has this problem...

Chosen Solution

Problem solved with Firefox 32! Now everything works again as before...

Thank you Mozilla team! I am very happy to see that you are taking in mind our problems and you always support our job. Thanks again!

Problem solved with Firefox 32! Now everything works again as before... Thank you Mozilla team! I am very happy to see that you are taking in mind our problems and you always support our job. Thanks again!
bigpighodges 0 solutions 3 answers

I've a similar problem with local file browse not working ... this user was having trouble with CKeditor - I am having problems with eXtend (a host supplied interface for file management and upload of changes to my website) I initially indicated "I have the same problem", but then raised a separate problem relating to eXtend. The "failure to open the browse window with eXtend" problem is NOT solved with the update to 32. Nor by running in safe mode. I'm having to use IE for my file uploads. Uploads work OK to DriveHQ from FF 32 but not to my host which uses the eXtend interface.

I've a similar problem with local file browse not working ... this user was having trouble with CKeditor - I am having problems with eXtend (a host supplied interface for file management and upload of changes to my website) I initially indicated "I have the same problem", but then raised a separate problem relating to eXtend. The "failure to open the browse window with eXtend" problem is NOT solved with the update to 32. Nor by running in safe mode. I'm having to use IE for my file uploads. Uploads work OK to DriveHQ from FF 32 but not to my host which uses the eXtend interface.
FredMcD
  • Top 10 Contributor
4259 solutions 59636 answers

bigpighodges

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Open the Add-ons Manager <Control><Shift> A and disable All of them.

Please go to the top of any Mozilla.org web page and use the Ask A Question link; https://support.mozilla.org/en-US/questions/new This will let us look at your system details. No Personal Information Is Collected.

'''bigpighodges''' Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Open the '''Add-ons Manager <Control><Shift> A''' and '''disable All of them.''' Please go to the top of any '''Mozilla.org''' web page and use the '''Ask A Question link; https://support.mozilla.org/en-US/questions/new''' This will let us look at your system details. '''No Personal Information Is Collected.'''
rbroberg 0 solutions 1 answers

Helpful Reply

Experienced the same issue in 31.1.0 and 31.3.0 on Red Hat 5 and Red Hat 6 with an all Flash website for server admin. Since the 31.x series is the ESR, this fix needs to be backported from v32 to v31.x.

Experienced the same issue in 31.1.0 and 31.3.0 on Red Hat 5 and Red Hat 6 with an all Flash website for server admin. Since the 31.x series is the ESR, this fix needs to be backported from v32 to v31.x.

Modified by rbroberg