Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Select and upload file to website stoped working on firefox 31

  • 6 replies
  • 52 have this problem
  • 11001 views
  • Last reply by rbroberg

more options

On a site using CKEditor and the RoxyFileman file manager to upload the files, I always used the "Browse" button to select a file from my computer, then pressed the Upload button and job done. Today upgraded to Firefox 31 and now when I press the upload button the "select file" window remains on screen and no upload. Yesterday night I had a report from another user of the same site for this problem. I used version 30 and he had upgrade to version 31... Checked and no problem with Windows 7 and Windows XP with IE 11, Chrome 36 and Firefox 30 and Linux Mint 17 with Firefox 30. On sites with the classic "Browse" button, there is no problem.

Chosen solution

Problem solved with Firefox 32! Now everything works again as before...

Thank you Mozilla team! I am very happy to see that you are taking in mind our problems and you always support our job. Thanks again!

Read this answer in context 👍 0

All Replies (6)

more options

Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache

Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

and

  • Remove Cookies

Warning ! ! This will log you out of all sites you're logged in to. Press the Alt or F10 key to bring up the tool bar. Followed by;

Windows; Tools > Options Linux; Edit > Preferences Mac; application name > Preferences

Then Privacy. Under History, select Firefox will Use Custom Settings. There is a button on the right side called Show Cookies.

If there is still a problem, Start Firefox in Safe Mode {web link} While you are in safe mode; Press the Alt or F10 key to bring up the tool bar. Followed by;

Windows; Tools > Options Linux; Edit > Preferences Mac; application name > Preferences

Then Advanced > General. Look for and turn off Use Hardware Acceleration.

Poke around safe web sites. Are there any problems?. Then restart.

more options

Thanks for the response but... problem still exists! I did all the steps but no luck! I had never ever this problem untill Firefox 31. Everything was working OK untill this last update... Yesterday another three customers called to tell me that they cannot upload files to their web site. I asked them if they upgraded firefox and all three said... YES. First two have Win XP and the other Win 8. Also there is no problem with the site code. Chrome, IE and Opera, in Win XP, Win 7, Win 8, Ubuntu and Linux Mint, ALL WORKING! Only Firefox 31 has this problem...

more options

Chosen Solution

Problem solved with Firefox 32! Now everything works again as before...

Thank you Mozilla team! I am very happy to see that you are taking in mind our problems and you always support our job. Thanks again!

more options

I've a similar problem with local file browse not working ... this user was having trouble with CKeditor - I am having problems with eXtend (a host supplied interface for file management and upload of changes to my website) I initially indicated "I have the same problem", but then raised a separate problem relating to eXtend. The "failure to open the browse window with eXtend" problem is NOT solved with the update to 32. Nor by running in safe mode. I'm having to use IE for my file uploads. Uploads work OK to DriveHQ from FF 32 but not to my host which uses the eXtend interface.

more options

bigpighodges

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Open the Add-ons Manager <Control><Shift> A and disable All of them.

Please go to the top of any Mozilla.org web page and use the Ask A Question link; https://support.mozilla.org/en-US/questions/new This will let us look at your system details. No Personal Information Is Collected.

more options

Experienced the same issue in 31.1.0 and 31.3.0 on Red Hat 5 and Red Hat 6 with an all Flash website for server admin. Since the 31.x series is the ESR, this fix needs to be backported from v32 to v31.x.

Modified by rbroberg