Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cannot print on firefox now blue arrow flashes and report in aspx?

  • 4 replies
  • 3 have this problem
  • 17 views
  • Last reply by dudiesmommy

more options

Until a couple of weeks ago I could open a report in ADP and print preview as well as print but now when I select print a blue arrow flashes and no preview appears. When I click on the blue arrow (which is black when not flashing) and a list of reports pop up. Then I would have to go into download file on hard drive to open the report. Until this week the download was in pdf now it is in aspx which I cannot open or print. I want it back that when I select the report it will preview it immediately and I can then print it. It works the way I want in Internet explorer and used to in Firefox. I like other aspects of Firefox but not the way it prints NOW. Can someone help me. Tired to follow the instruction of "Fix printing problems" but couldn't find all the step items like the "firefox button" Tried the menu button but next step isn't there. "Reset firefox printer setting" didn't help and could not figure out how to open the prefs.js i wordpad in the "Reset all firefox printer settings". I am on windows 7.

Until a couple of weeks ago I could open a report in ADP and print preview as well as print but now when I select print a blue arrow flashes and no preview appears. When I click on the blue arrow (which is black when not flashing) and a list of reports pop up. Then I would have to go into download file on hard drive to open the report. Until this week the download was in pdf now it is in aspx which I cannot open or print. I want it back that when I select the report it will preview it immediately and I can then print it. It works the way I want in Internet explorer and used to in Firefox. I like other aspects of Firefox but not the way it prints NOW. Can someone help me. Tired to follow the instruction of "Fix printing problems" but couldn't find all the step items like the "firefox button" Tried the menu button but next step isn't there. "Reset firefox printer setting" didn't help and could not figure out how to open the prefs.js i wordpad in the "Reset all firefox printer settings". I am on windows 7.

Chosen solution

To expand on that last suggestion:

"3-bar" menu button (or Tools menu) > Options > Applications panel

Once the list loads, in the search box above the list, type pdf and pause while the list is filtered. Then check the drop-down on the right side and if it is set to Save File, try changing it to one of the following:

  • Preview in Firefox
  • Use Adobe Acrobat (in Firefox)
Read this answer in context 👍 2

All Replies (4)

more options

Could you try something:

On your download list, use the file folder icon to "Open Containing Folder" for one of those ASPX files. Then try renaming it with a PDF file extension.

Windows can make it difficult to do this by hiding file extensions for standard file types. If you are not able to change aspx to pdf, check out the steps in these articles to stop hiding file extensions:

After renaming, does the file open as a PDF?

If so, one option would be to change your download setting so you can choose the file location AND file name for downloads. That is set in the Options dialog, General panel, as described in this article: Startup, home page, tabs, and download settings.

If it doesn't work as a PDF, hmmm, could you rename it to a .html file and drag and drop it onto an open Firefox tab to display it (this will replace the contents of the tab). What does it look like?

more options

One other thought: check your preference for how to handle PDF files to see whether it has changed. By default, Firefox will use its built-in viewer, but since it isn't as full-featured as Adobe's viewer, many users will switch back to Acrobat.

In case your preference is set to Save rather than view in either of those, check this article for steps to change this setting: View PDF files in Firefox or choose another viewer (but you can change it to whatever you like).

more options

Chosen Solution

To expand on that last suggestion:

"3-bar" menu button (or Tools menu) > Options > Applications panel

Once the list loads, in the search box above the list, type pdf and pause while the list is filtered. Then check the drop-down on the right side and if it is set to Save File, try changing it to one of the following:

  • Preview in Firefox
  • Use Adobe Acrobat (in Firefox)
more options

Thank you so good to have my firefox working properly again. Guess I need to get a Firefox for dummies book or something. Have an amazing day Laura