Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cannot play Flash Video

  • 5 replies
  • 5 have this problem
  • 1493 views
  • Last reply by Moses

more options

Since updating to Flash 13 Firefox will not play Flash video. Occasionally the video will appear for half a second then crash. But usually I get “The adobe Flash plugin has crashed …” I am on Windows 8.1 with Firefox version 29.01 I have the Shockwave Flash 13.0.0.214 Plugin I have tried clearing the cache an have reset firefox but the problem persists. The same sites display video normally when viewed with Internet Explorer 11

Chosen solution

If that doesn't work, you also might want to disable Protected Mode. Personally, I think Flash is sucky. Mozilla is working on a replacement called Shumway but unforunately it's still in the Nightly build and isn't even enabled by default.

Try to disable Protected Mode in Flash 11.3 and above by adding the line ProtectedMode=0 to the Flash "mms.cfg" file located in one of these locations: [46]

   (Windows 32bit) C:\Windows\System32\Macromed\Flash 
   (Windows 64bit) C:\Windows\SysWOW64\Macromed\Flash 

For example, on a Windows 7 64-bit system, open the C:\Windows\SysWOW64\Macromed\Flash folder, copy the file "mms.cfg" to the desktop, open it in Notepad, add a new line ProtectedMode=0 and then close Notepad, saving your changes. Next, go back to the C:\Windows\SysWOW64\Macromed\Flash folder, rename the original file to "mms.cfgBAK" (to save it as a backup) and then drag and drop in the modified "mms.cfg" file from the desktop. [47] [48] [49]

Note: To re-enable Flash Protected Mode, either restore a backup of the original mms.cfg file, if you saved one, or else re-edit the mms.cfg file to remove the ProtectedMode=0 l line you added. Updating Flash Player or installing a newer version does not automatically re-enable Protected Mode

Read this answer in context 👍 1

All Replies (5)

more options

Try disabling Hardware Acceleration.

  1. Go to this Adobe Flash Player Help page.
  2. Right-click on the Flash Player logo on that page.
  3. Click on Settings in the context menu. The Adobe Flash Player Settings screen will open.
  4. Click on the icon at the bottom-left of the Adobe Flash Player Settings window to open the Display panel.

    fpSettings1.PNG
  5. Remove the check mark from Enable hardware acceleration.
  6. Click Close to close the Adobe Flash Player Settings Window.
  7. Restart Firefox.

This Flash Player Help - Display Settings page has more information on Flash Player hardware acceleration, if you're interested.


more options

Chosen Solution

If that doesn't work, you also might want to disable Protected Mode. Personally, I think Flash is sucky. Mozilla is working on a replacement called Shumway but unforunately it's still in the Nightly build and isn't even enabled by default.

Try to disable Protected Mode in Flash 11.3 and above by adding the line ProtectedMode=0 to the Flash "mms.cfg" file located in one of these locations: [46]

   (Windows 32bit) C:\Windows\System32\Macromed\Flash 
   (Windows 64bit) C:\Windows\SysWOW64\Macromed\Flash 

For example, on a Windows 7 64-bit system, open the C:\Windows\SysWOW64\Macromed\Flash folder, copy the file "mms.cfg" to the desktop, open it in Notepad, add a new line ProtectedMode=0 and then close Notepad, saving your changes. Next, go back to the C:\Windows\SysWOW64\Macromed\Flash folder, rename the original file to "mms.cfgBAK" (to save it as a backup) and then drag and drop in the modified "mms.cfg" file from the desktop. [47] [48] [49]

Note: To re-enable Flash Protected Mode, either restore a backup of the original mms.cfg file, if you saved one, or else re-edit the mms.cfg file to remove the ProtectedMode=0 l line you added. Updating Flash Player or installing a newer version does not automatically re-enable Protected Mode

more options

Thanks for the reply I have tried to do as you suggest but When I use Firefox to access the site I ho not see the Flash Player logo I see the plugin crashed message and right clicking that does not show settings When I use Internet explorer I can get settings but it looks like attached image. Nothing about hardware acceleration.

more options

Thanks I have disabled Protected Mode and it seems to work!

more options

I have disabled Protected Mode and it seems to work!

Glad to hear it.