Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

My homepage default is set for Mozilla, but it automatically opens my g-mail instead of my mozilla home page.

  • 5 replies
  • 3 have this problem
  • 2041 views
  • Last reply by JanieZ

more options

My home page is set for Mozilla Firefox Start Page, but when I start Firefox, I am automatically redirected to: https://mail.google.com/mail/u/0/?shva=1#inbox, which takes me to my Gmail account instead of my home page. I have tried resetting the default, but nothing has changed. I even uninstalled and reinstalled Firefox, but that didn't work either. I have checked my computer for any suspicious programs, but I can't seem to find any. Is this a malware that i can't find? This has been occurring for about 3 weeks now and it is very frustrating. I don't want to automatically open my e-mail. Can you help me fix this problem. Thank you.

Chosen solution

You can check the target line in the Firefox desktop shortcut (right-click: Properties) to make sure that nothing is appended after the path to the Firefox program.


Your System Details list shows that you have a user.js file in the profile folder to initialize prefs each time Firefox starts.

The user.js file is only present if you or other software has created this file and normally it wouldn't be there. You can check its content with a plain text editor (right-click: Open with) if you didn't create this file yourself.

The user.js file is read each time Firefox is started and initializes preferences to the value specified in this file, so preferences set via user.js can only be changed temporarily for the current session.

You can delete a possible user.js file and numbered prefs-##.js files and rename (or delete) the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in the current Firefox release.

You can use this button to go to the currently used Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder)

See also:

Read this answer in context 👍 0

All Replies (5)

more options

I'm curious what you got in the user.js file. That's not a standard-issue file; either added by the user on purpose or by malware to "lock" as setting to a non-default value. That file is in your Profile folder, and can be opened to read it in a text program like WordPad or NotePad.

How do I find my profile?

    Click the menu button 3-bar Fx Menu button, click help Help (the question mark) and select Troubleshooting Information. The Troubleshooting Information tab will open.
    Under the Application Basics section, click on Show Folder. A window with your profile files will open.

Modified by the-edmeister

more options

Thanks!! There is a scroll icon. I noticed 3 of them in this folder. It says JScript Script File in each of these 3 files. Is this malware and should I delete these files?

more options

What are the files named? Some JScript (.js) files are normal, such as prefs.js and sessionstore.js.

more options

Chosen Solution

You can check the target line in the Firefox desktop shortcut (right-click: Properties) to make sure that nothing is appended after the path to the Firefox program.


Your System Details list shows that you have a user.js file in the profile folder to initialize prefs each time Firefox starts.

The user.js file is only present if you or other software has created this file and normally it wouldn't be there. You can check its content with a plain text editor (right-click: Open with) if you didn't create this file yourself.

The user.js file is read each time Firefox is started and initializes preferences to the value specified in this file, so preferences set via user.js can only be changed temporarily for the current session.

You can delete a possible user.js file and numbered prefs-##.js files and rename (or delete) the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in the current Firefox release.

You can use this button to go to the currently used Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder)

See also:

more options

I restored Firefox to its original default settings and this resolved my problem. Thank you!