X
Tap here to go to the mobile version of the site.
An updated version of Firefox is available to address the issues with Add-ons disabled or fail to install on Firefox. You can download the update for your OS here: https://www.mozilla.org/firefox/new/ For Known Issues and Workarounds, please check out the update at https://support.mozilla.org/kb/add-ons-disabled-or-fail-to-install-firefox

Support Forum

This thread was closed and archived. Please ask a new question if you need help.

Stop automatic updates.

Posted

I will not use Firefox 29 or newer until the crappy interface introduced in v29 it made user friendly, and bring back certain missing thing from v28 (they may be profile holdovers from a much older version), no the classic theme restorer does not bring them back. The above is here simply to try and stop suggestions about using v29

I have tried going into options menu Firefox>Options>Advanced>Never Check for Updates, but that does not prevent updates. I have had to uninstall Firefox 29 5 times today every time after telling it to "Never check for updates."

I will not use Firefox 29 or newer until the crappy interface introduced in v29 it made user friendly, and bring back certain missing thing from v28 (they may be profile holdovers from a much older version), no the classic theme restorer does not bring them back. The above is here simply to try and stop suggestions about using v29 I have tried going into options menu Firefox>Options>Advanced>Never Check for Updates, but that does not prevent updates. I have had to uninstall Firefox 29 5 times today every time after telling it to "Never check for updates."

Modified by Noah_SUMO

Chosen solution

Not to start a war here but Mozilla isn't going to revert the entire UI that they've spent 2 years working on. That would be a downgrade to them. Mozilla is all about pushing forward. Some users may not like it, but that's what there are other alternatives such as the Classic Theme Restorer for people that don't like the Australis design.

There is a way to disable updates by going through the Options menu but after disabling it through there, when you would go to Help > About Firefox, it would update regardless of that setting. 2 methods here, pick one. You can set these prefs in about:config to disable automatic updating:
app.update.auto - false
app.update.enabled - false
app.update.silent - false


Or you can use this method to do that for you: You can create a new file in a text editor (Defaults are: Notepad for Windows, TextEdit for Mac, and Text Editor on Linux) called user.js. When you save user.js, make sure it's file type is ALL FILES as leaving it like that will add the .txt extension (user.js.txt) and it won't work. Place this file in your Profile Folder. See the link below to learn how to access the folder

Once you're creating the folder simply add the following to your user.js file, save and close, restart Firefox

// turn off application updates:
user_pref("app.update.enabled", false); 
Read this answer in context 5

Additional System Details

Installed Plug-ins

  • Shockwave Flash 13.0 r0
  • Next Generation Java Plug-in 10.60.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:28.0) Gecko/20100101 Firefox/28.0

More Information

Moses
  • Moderator
459 solutions 3607 answers

Chosen Solution

Not to start a war here but Mozilla isn't going to revert the entire UI that they've spent 2 years working on. That would be a downgrade to them. Mozilla is all about pushing forward. Some users may not like it, but that's what there are other alternatives such as the Classic Theme Restorer for people that don't like the Australis design.

There is a way to disable updates by going through the Options menu but after disabling it through there, when you would go to Help > About Firefox, it would update regardless of that setting. 2 methods here, pick one. You can set these prefs in about:config to disable automatic updating:
app.update.auto - false
app.update.enabled - false
app.update.silent - false


Or you can use this method to do that for you: You can create a new file in a text editor (Defaults are: Notepad for Windows, TextEdit for Mac, and Text Editor on Linux) called user.js. When you save user.js, make sure it's file type is ALL FILES as leaving it like that will add the .txt extension (user.js.txt) and it won't work. Place this file in your Profile Folder. See the link below to learn how to access the folder

Once you're creating the folder simply add the following to your user.js file, save and close, restart Firefox

// turn off application updates:
user_pref("app.update.enabled", false); 
Not to start a war here but Mozilla isn't going to revert the entire UI that they've spent 2 years working on. That would be a downgrade to them. Mozilla is all about pushing forward. Some users may not like it, but that's what there are other alternatives such as the Classic Theme Restorer for people that don't like the Australis design. There is a way to disable updates by going through the Options menu but after disabling it through there, when you would go to Help > About Firefox, it would update regardless of that setting. 2 methods here, pick one. You can set these prefs in <code>about:config</code> to disable automatic updating:<br> app.update.auto - false<br> app.update.enabled - false<br> app.update.silent - false<br> ---- Or you can use this method to do that for you: You can create a new file in a text editor (Defaults are: Notepad for Windows, TextEdit for Mac, and Text Editor on Linux) called <code>user.js</code>. When you save user.js, make <b>sure</b> it's file type is ALL FILES as leaving it like that will add the .txt extension (user.js.txt) and it won't work. Place this file in your Profile Folder. See the link below to learn how to access the folder *[https://support.mozilla.org/en-US/kb/profiles-where-firefox-stores-user-data#w_finding-your-profile-without-opening-firefox How to find my profile Folder] Once you're creating the folder simply add the following to your user.js file, save and close, restart Firefox <pre><nowiki> // turn off application updates: user_pref("app.update.enabled", false); </nowiki></pre>

Question owner

That did work. I can see I used a few wrong words in the original question. The issues that break the user experience for me are not the kind of issue it seems people expect.

I also don't see not getting severe insults from mods and users this time when trying to find a solution to them as it has happened before. Yes on this site.

That did work. I can see I used a few wrong words in the original question. The issues that break the user experience for me are not the kind of issue it seems people expect. I also don't see not getting severe insults from mods and users this time when trying to find a solution to them as it has happened before. Yes on this site.

Modified by chevyowner

Ahmad Maher 0 solutions 8 answers

i had the same issue today with FF 27.0.1 when it was forced to update to 31 and i went through all what other said in about:config .. but that did not work, even un-install and installed an old backup did not work, ... the user.js also failed, and i even found something that work with local group policy named FirefoxADM_0.5.9.4 .. but that too did not work for me and firefox keep download the updates.

so here is what i did, when you get that message that there is an update and it ask you to re-start so it can be updated, just go to the program files where firefox is installed you will find a folder named updated ... delete it .... and the you can close firefox and open it again and you will get an error message that the update failed ....

then i uninstalled the maintenance service, and deleted files maintenanceservice and maintenanceservice_installer from firefox mozilla folder ... also renamed updater.exe to updater.exe.old .... and now firefox never forced to update anymore

hope this can help.

i had the same issue today with FF 27.0.1 when it was forced to update to 31 and i went through all what other said in about:config .. but that did not work, even un-install and installed an old backup did not work, ... the user.js also failed, and i even found something that work with local group policy named FirefoxADM_0.5.9.4 .. but that too did not work for me and firefox keep download the updates. so here is what i did, when you get that message that there is an update and it ask you to re-start so it can be updated, just go to the program files where firefox is installed you will find a folder named updated ... delete it .... and the you can close firefox and open it again and you will get an error message that the update failed .... then i uninstalled the maintenance service, and deleted files maintenanceservice and maintenanceservice_installer from firefox mozilla folder ... also renamed updater.exe to updater.exe.old .... and now firefox never forced to update anymore hope this can help.