Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Username and password not automatically filled in

more options

The problem I have with Firefox is that when I log in to one of my email services (I use two different ones). In the past when I opened the log-in page my login and password (saved in FF) were already filled in so I just had to click "log in" button - it still is that way on the other email service. I had it set up this way for years, since many FF versions back (I have automatic updates on in FF so it is always up to date). Recently I was changing my passwords and I got confused when updating saved password so I decided to delete saved passwords for one of the email services and just logged in typing the password in manually and clicked 'save password' when FF password manager asked me. From that point on when I open the log in page from my bookmarks, the details are not there anymore, so I have to click on 'username' field to get the autocomplete list, choose my login name (there is only one) and then the password gets filled in and I can log in, so it's not the issue of password not being saved or filled in for my login but the fact that these details are not filled in from the point I open the login page from bookmarks, like it used to be and like it still is with the other service (for which I didn't delete and re-save password).. Now this might not be a big deal you might think but it is really annoying that I have to do extra step just to log in to my email especially that I log in to it frequently during the day and that I like things to work the way they are supposed to. I have tried removing cookies for that website, deleting and re-saving the bookmark (with fields already filled with details), deleting all saved password for that website and saving it again and nothing seemed to help. I will appreciate any help if anyone has the solution. Please do not suggest alternatives like using add-ons or using email client etc.

Not sure links are allowed but this is the link to the screenshot showing and describing the problem:

http://screencast.com/t/TKWVVogzmqI

I'm on win 7 pro 64, latest Mozilla 29.0.1

Chosen solution

hmm.. I don't know what to say now :)

Looks like you nailed it cor-el. I changed the url to https://profil.wp.pl/login.html as you suggested and re-saved login details with Password Manager and it worked but it logged me in to a profile page of the email. Then I tried it with https://poczta.wp.pl (rather than http://poczta.wp.pl) and now it works perfectly! The question remains, why did the whole thing happen? Could it be due to the fact I had this password saved long time ago with a different url and wp.pl changed their website code in the meantime? And still I don't really understand why it works with secure https url and not with normal http url but that's beyond this thread I guess and also beyond the scope of my understanding probably:)

Noah, thank you a lot for filling in the bug. It seems now that there was no issue with the Password Manager at all

In the hindsight you were both sniffing around very close to the solution few posts back :)

Big thanks to everyone who tried to help and contributed to this issue.

Should I mark this as solved now?

Regards

Read this answer in context 👍 0

All Replies (20)

more options

Some web sites have a way to turn off browser password settings. But you say this just started?

Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache

Press the <Alt> or <F10> key to bring up the tool bar. Then; Tools > Options > Advanced > Network > Cached Web Content: Clear Now

and

  • Remove Cookies

Press the <Alt> or <F10> key to bring up the tool bar. Then Tools > Options > Privacy.

Under History, select Firefox will Use Custom Settings. There is a button on the right side called Show Cookies.

If there is still a problem, Start Firefox in Safe Mode {web link} While you are in safe mode; Press the <Alt> or <F10> key to bring up the tool bar.. Then Tools > Options > Advanced > General. Look for and turn off Use Hardware Acceleration.

Poke around safe web sites and see if there is still a problem. Then restart.

more options

Hi FredMcD Thanks for a quick reply. Unfortunately none of suggestions helped. Interestingly I have created an account here today to ask this question, and when I tried to log in to type this reply just now, on Mozilla support forum login page my details were filled in already (I have saved the password for it).. but on the other email website from the original question - still no luck.. but as I mentioned it worked few days ago before I changed the password. In case this is site specific issue is there anything I can do to fix that?

more options

Did you make sure that you do not run Firefox in permanent Private Browsing mode (Never remember history)?

  • Tools > Options > Privacy > Firefox will: "Use custom settings for history"
  • Deselect: [ ] "Always use private browsing mode"
more options

Hi cor-el, Thank you for your help and the suggestion. No it's not the permanent private browsing mode. I wish it was one of those simple solutions :) Besides IF it was because of that, then I wouldn't get my login autofil when I click on the 'username' field I guess?

for everyone: Maybe there are any setting in about:config that could potentially help with the issue?

more options

I have just noticed something interesting: When I restart FF and once it starts and while it's still loading other tabs if I quickly open the login page of the website in question before master password window shows up, then once I type in the master password and confirm it, login and password on the website appear filled in.. However if I open the login page beforehand and then restart FF, once it opens and I type in the master password, these details are not filled in.. I recorded a screen capture to illustrate the issue:

http://screencast.com/t/7vt2EdR8yH

Not sure if that gives any clue?

more options

Thanks for the screencast! That does indeed look bad. Looks like the master password dialog interferes somehow.

Might be a bug. I'll look to see if this has already been filed.

more options

Noah SUMO, Thanks for looking into that. If any additional information is needed, let me know.

Regards

more options

No problem. :) I actually got to speak to a developer today that works on the password manager which auto fills the username and password fields.

He asked if you could try to get a debug log for this problem by following these steps: https://wiki.mozilla.org/Firefox:Password_Manager_Debugging

Once you see the log in the Browser Console, please copy and paste it to your next post on this site.

He also said you could rule out if the Master Password dialog was causing this problem by either temporarily turning it off and then try to reproduce the problem again. Or load some other page 1st to trigger it and then load the problem page.

more options

The website might be using autocomplete=off to prevent Firefox from saving form data like name and password. You can toggle the signon.overrideAutocomplete pref to true on the about:config page.

Note that Firefox won't auto-fill saved form data automatically when autocomplete=off is used, so double-click the empty name field to get a drop-down list.


You can right-click the name input field and open the built-in Inspector via Inspect Element. You can see if there is an autocomplete=off attribute and click the "off" text to edit this value and change it "off" to "on", so you get autocomplete="on". Repeat this for the password input field, so both fields have an autocomplete="on" attribute. Note that autocomplete="off" can be an attribute of the form tag that contains the log in input fields.

more options

Noah SUMO, I have run the debugger today and posting the results below. First log is of opening the login website in question (with no master password entered) first, then to separate the actions I open a invalid url "www.consolelogspacer.com" and after that I double click the username filed and choose my username. Please note another interesting issue: when I double click the username box and select my username, password is not filled in with it (master password is not entered yet) and FF DOESN'T even ask for master password.

Log 1 below: GET http://profil.wp.pl/login.html [HTTP/1.1 200 OK 180ms] Use of getUserData() or setUserData() is deprecated. Use WeakMap or element.dataset instead. requestNotifier.js:64 GET http://a.wpimg.pl/a/i/stg/500/3323,984.css [HTTP/1.1 200 OK 100ms] GET http://i.wp.pl/a/i/stg/270,wpjslib_103.js [HTTP/1.1 200 OK 410ms] GET http://rek.www.wp.pl/pliki/10275_20140602100.js [HTTP/1.1 200 OK 160ms] GET http://profil.wp.pl/css/s.css [HTTP/1.1 200 OK 230ms] GET http://profil.wp.pl/js/serwis.js [HTTP/1.1 200 OK 340ms] GET http://i.wp.pl/a/i/profil2/i-p2010/login/poczta/reklama_right.jpg [HTTP/1.1 200 OK 640ms] GET http://i.wp.pl/a/i/stg/460/favicon.ico [HTTP/1.1 200 OK 170ms] Unknown property '-moz-border-radius'. Declaration dropped. 3323,984.css:196 Unknown pseudo-class or pseudo-element '-webkit-input-placeholder'. Ruleset ignored due to bad selector. s.css:88 Unknown pseudo-class or pseudo-element '-webkit-input-placeholder'. Ruleset ignored due to bad selector. s.css:91 Error in parsing value for 'background'. Declaration dropped. s.css:139 Error in parsing value for 'background'. Declaration dropped. s.css:140 Error in parsing value for 'background'. Declaration dropped. s.css:141 Error in parsing value for 'background'. Declaration dropped. s.css:142 Expected 'none' or URL but found 'progid'. Error in parsing value for 'filter'. Declaration dropped. s.css:144 Expected declaration but found '*'. Skipped to next declaration. s.css:173 Error in parsing value for 'background'. Declaration dropped. s.css:179 Error in parsing value for 'background'. Declaration dropped. s.css:180 Error in parsing value for 'background'. Declaration dropped. s.css:181 Error in parsing value for 'background'. Declaration dropped. s.css:182 Expected 'none' or URL but found 'progid'. Error in parsing value for 'filter'. Declaration dropped. s.css:184 Error in parsing value for 'background'. Declaration dropped. s.css:190 Error in parsing value for 'background'. Declaration dropped. s.css:191 Error in parsing value for 'background'. Declaration dropped. s.css:192 Error in parsing value for 'background'. Declaration dropped. s.css:193 Expected 'none' or URL but found 'progid'. Error in parsing value for 'filter'. Declaration dropped. s.css:195 Error in parsing value for 'background'. Declaration dropped. s.css:206 Error in parsing value for 'background'. Declaration dropped. s.css:207 Error in parsing value for 'background'. Declaration dropped. s.css:208 Error in parsing value for 'background'. Declaration dropped. s.css:209 Expected 'none' or URL but found 'progid'. Error in parsing value for 'filter'. Declaration dropped. s.css:211 Error in parsing value for 'background'. Declaration dropped. s.css:231 Error in parsing value for 'background'. Declaration dropped. s.css:232 Error in parsing value for 'background'. Declaration dropped. s.css:233 Error in parsing value for 'background'. Declaration dropped. s.css:234 Expected 'none' or URL but found 'progid'. Error in parsing value for 'filter'. Declaration dropped. s.css:236 Unknown property 'zoom'. Declaration dropped. s.css:241 Expected declaration but found '*'. Skipped to next declaration. s.css:242 Expected declaration but found '*'. Skipped to next declaration. s.css:900 Expected declaration but found '*'. Skipped to next declaration. s.css:1010 Error in parsing value for 'background'. Declaration dropped. s.css:1439 Error in parsing value for 'background'. Declaration dropped. s.css:1440 Error in parsing value for 'background'. Declaration dropped. s.css:1441 Error in parsing value for 'background'. Declaration dropped. s.css:1442 Expected 'none' or URL but found 'progid'. Error in parsing value for 'filter'. Declaration dropped. s.css:1444 Expected declaration but found '*'. Skipped to next declaration. s.css:1660 Unknown property '-moz-border-radius'. Declaration dropped. s.css:1693 GET http://wp.hit.gemius.pl/_1401701273370/rexdot.gif [HTTP/1.1 301 Moved Permanently 80ms] GET http://dot.wp.pl/r4070107172/dot.gif [HTTP/1.1 200 OK 60ms] GET http://rek.www.wp.pl/rgr.html [HTTP/1.1 200 OK 70ms] GET http://rek.www.wp.pl/ [HTTP/1.1 200 OK 160ms] GET http://wp.hit.gemius.pl/__/_1401701273370/rexdot.gif [HTTP/1.1 200 OK 70ms] An unbalanced tree was written using document.write() causing data from the network to be reparsed. For more information https://developer.mozilla.org/en/Optimizing_Your_Pages_for_Speculative_Parsing login.html:40 Password fields present on an insecure (http://) page. This is a security risk that allows user login credentials to be stolen.[Learn More] Password fields present in a form with an insecure (http://) form action. This is a security risk that allows user login credentials to be stolen.[Learn More] Login Manager (content): onFormPassword for http://profil.wp.pl/login.html?url=http%3A%2F%2Fpoczta.wp.pl%2Findexgwt.html%3Fflg%3D1&serwis=nowa_poczta_wp Login Manager: Counting logins matching host: http://profil.wp.pl formSubmitURL: httpRealm: null PwMgr mozStorage: _countLogins: counted logins: 1 Login Manager: Searching for logins matching host: http://profil.wp.pl formSubmitURL: http://profil.wp.pl httpRealm: null PwMgr mozStorage: _searchLogins: returning 0 logins PwMgr mozStorage: _findLogins: returning 0 logins Login Manager (content): found 0 matching logins. Expected ':' but found '='. Declaration dropped. login.html GET http://profil.wp.pl/obrazek.html [HTTP/1.1 200 OK 80ms] GET http://wp.hit.gemius.pl/_1320830129/redot.gif [HTTP/1.1 301 Moved Permanently 60ms] GET http://rek.www.wp.pl/fsc.gif [HTTP/1.1 200 OK 60ms] GET http://wp.hit.gemius.pl/__/_1320830129/redot.gif [HTTP/1.1 200 OK 60ms] Use of getPreventDefault() is deprecated. Use defaultPrevented instead. 270,wpjslib_103.js:178 GET http://www.consolelogspacer.com/ [0ms] Login Manager (content): onUsernameInput from DOMAutoComplete PwMgr cryptoSDR: SDR slot status is 3

End of Log 1.

more options

The second log is login website opened with master password previously entered. Then spacer (www.consolelogspacer.com) and then I double click username field and pick my username.

Log 2 below: GET http://poczta.wp.pl/ [HTTP/1.1 302 Found 430ms] GET http://profil.wp.pl/login.html [HTTP/1.1 200 OK 200ms] Use of getUserData() or setUserData() is deprecated. Use WeakMap or element.dataset instead. requestNotifier.js:64 GET http://a.wpimg.pl/a/i/stg/500/3323,984.css [HTTP/1.1 200 OK 110ms] GET http://i.wp.pl/a/i/stg/270,wpjslib_103.js [HTTP/1.1 200 OK 440ms] GET http://rek.www.wp.pl/pliki/10275_20140602103.js [HTTP/1.1 200 OK 250ms] GET http://profil.wp.pl/css/s.css [HTTP/1.1 200 OK 250ms] GET http://profil.wp.pl/js/serwis.js [HTTP/1.1 200 OK 320ms] GET http://i.wp.pl/a/i/profil2/i-p2010/login/poczta/reklama_right.jpg [HTTP/1.1 200 OK 641ms] GET http://i.wp.pl/a/i/stg/460/favicon.ico [HTTP/1.1 200 OK 190ms] Unknown property '-moz-border-radius'. Declaration dropped. 3323,984.css:196 Unknown pseudo-class or pseudo-element '-webkit-input-placeholder'. Ruleset ignored due to bad selector. s.css:88 Unknown pseudo-class or pseudo-element '-webkit-input-placeholder'. Ruleset ignored due to bad selector. s.css:91 Error in parsing value for 'background'. Declaration dropped. s.css:139 Error in parsing value for 'background'. Declaration dropped. s.css:140 Error in parsing value for 'background'. Declaration dropped. s.css:141 Error in parsing value for 'background'. Declaration dropped. s.css:142 Expected 'none' or URL but found 'progid'. Error in parsing value for 'filter'. Declaration dropped. s.css:144 Expected declaration but found '*'. Skipped to next declaration. s.css:173 Error in parsing value for 'background'. Declaration dropped. s.css:179 Error in parsing value for 'background'. Declaration dropped. s.css:180 Error in parsing value for 'background'. Declaration dropped. s.css:181 Error in parsing value for 'background'. Declaration dropped. s.css:182 Expected 'none' or URL but found 'progid'. Error in parsing value for 'filter'. Declaration dropped. s.css:184 Error in parsing value for 'background'. Declaration dropped. s.css:190 Error in parsing value for 'background'. Declaration dropped. s.css:191 Error in parsing value for 'background'. Declaration dropped. s.css:192 Error in parsing value for 'background'. Declaration dropped. s.css:193 Expected 'none' or URL but found 'progid'. Error in parsing value for 'filter'. Declaration dropped. s.css:195 Error in parsing value for 'background'. Declaration dropped. s.css:206 Error in parsing value for 'background'. Declaration dropped. s.css:207 Error in parsing value for 'background'. Declaration dropped. s.css:208 Error in parsing value for 'background'. Declaration dropped. s.css:209 Expected 'none' or URL but found 'progid'. Error in parsing value for 'filter'. Declaration dropped. s.css:211 Error in parsing value for 'background'. Declaration dropped. s.css:231 Error in parsing value for 'background'. Declaration dropped. s.css:232 Error in parsing value for 'background'. Declaration dropped. s.css:233 Error in parsing value for 'background'. Declaration dropped. s.css:234 Expected 'none' or URL but found 'progid'. Error in parsing value for 'filter'. Declaration dropped. s.css:236 Unknown property 'zoom'. Declaration dropped. s.css:241 Expected declaration but found '*'. Skipped to next declaration. s.css:242 Expected declaration but found '*'. Skipped to next declaration. s.css:900 Expected declaration but found '*'. Skipped to next declaration. s.css:1010 Error in parsing value for 'background'. Declaration dropped. s.css:1439 Error in parsing value for 'background'. Declaration dropped. s.css:1440 Error in parsing value for 'background'. Declaration dropped. s.css:1441 Error in parsing value for 'background'. Declaration dropped. s.css:1442 Expected 'none' or URL but found 'progid'. Error in parsing value for 'filter'. Declaration dropped. s.css:1444 Expected declaration but found '*'. Skipped to next declaration. s.css:1660 Unknown property '-moz-border-radius'. Declaration dropped. s.css:1693 GET http://wp.hit.gemius.pl/_1401702113658/rexdot.gif [HTTP/1.1 301 Moved Permanently 111ms] GET http://dot.wp.pl/r8032494693/dot.gif [HTTP/1.1 200 OK 91ms] GET http://rek.www.wp.pl/rgr.html [HTTP/1.1 200 OK 71ms] GET http://rek.www.wp.pl/ [HTTP/1.1 200 OK 141ms] GET http://wp.hit.gemius.pl/__/_1401702113658/rexdot.gif [HTTP/1.1 200 OK 70ms] An unbalanced tree was written using document.write() causing data from the network to be reparsed. For more information https://developer.mozilla.org/en/Optimizing_Your_Pages_for_Speculative_Parsing login.html:40 Password fields present on an insecure (http://) page. This is a security risk that allows user login credentials to be stolen.[Learn More] Password fields present in a form with an insecure (http://) form action. This is a security risk that allows user login credentials to be stolen.[Learn More] Login Manager (content): onFormPassword for http://profil.wp.pl/login.html?url=http%3A%2F%2Fpoczta.wp.pl%2Findexgwt.html%3Fflg%3D1&serwis=nowa_poczta_wp Login Manager: Counting logins matching host: http://profil.wp.pl formSubmitURL: httpRealm: null PwMgr mozStorage: _countLogins: counted logins: 1 Login Manager: Searching for logins matching host: http://profil.wp.pl formSubmitURL: http://profil.wp.pl httpRealm: null PwMgr mozStorage: _searchLogins: returning 0 logins PwMgr mozStorage: _findLogins: returning 0 logins Login Manager (content): found 0 matching logins. Expected ':' but found '='. Declaration dropped. login.html GET http://profil.wp.pl/obrazek.html [HTTP/1.1 200 OK 70ms] GET http://wp.hit.gemius.pl/_1563134714/redot.gif [HTTP/1.1 301 Moved Permanently 50ms] GET http://rek.www.wp.pl/fsc.gif [HTTP/1.1 200 OK 70ms] GET http://wp.hit.gemius.pl/__/_1563134714/redot.gif [HTTP/1.1 200 OK 60ms] Use of getPreventDefault() is deprecated. Use defaultPrevented instead. 270,wpjslib_103.js:178 GET http://i.wp.pl/a/i/stg/460/favicon.ico#-moz-resolution=16,16 [HTTP/1.1 200 OK 70ms] GET http://www.consolelogspacer.com/ [0ms] Login Manager (content): onUsernameInput from DOMAutoComplete PwMgr cryptoSDR: SDR slot status is 4 Login Manager: Searching for logins matching host: http://profil.wp.pl formSubmitURL: https://profil.wp.pl httpRealm: null PwMgr mozStorage: _searchLogins: returning 1 logins PwMgr cryptoSDR: SDR slot status is 4 PwMgr mozStorage: _findLogins: returning 1 logins Login Manager (content): found 1 matching logins.

End of Log 2.

Hope this helps. If I did anything wrong, please let me know and I will try to re-do it.

Also I tried your other suggestion from the developer and situation was similar. When I disabled master password, other websites had usernames and passwords pre-filled in upon opening, but the website in question hadn't - I had to double click username field and choose my username. Also with master password enabled, triggering master password with another website first didn't change anything, on the website in question password was still not filled in. Another note: when I recorded my previous screencast (http://screencast.com/t/7vt2EdR8yH) that was after I followed Fred's suggestion and cleared all cookies, thus locked tab with twitter was triggering FF to ask for master password upon starting FF. I found now, that the website in question doesn't trigger FF to ask for master password at all, while other website login pages do.

Best regards!

more options

cor-el,

Thanks for more help. I have set signon.overrideAutocomplete to true (it was false before) but this didn't change anything unfortunately. After using the Inspector, I found that the website in question is not using autocomplete=off, unless I did something wrong :) This is the login page again:

http://screencast.com/t/dErpCtNM

this is the username field:

http://screencast.com/t/ARC1CJBA843S

..and this is the password field:

http://screencast.com/t/8ovtYqwSQW

more options

I have an idea that will hopefully work. :D

Let's try changing the url of the FastDial tab for Wp.pl to a clean url minus all the extra junk at the end of it.

Right now, it always loads this url: http://profil.wp.pl/login.html?url=http%3A%2F%2Fpoczta.wp.pl%2Findexgwt.html%3Fflg%3D1&serwis=nowa_poczta_wp

How about if we shorten it to: http://profil.wp.pl/login.html

By comparison, the O2.pl FastDial tab loads this url: http://poczta.o2.pl

That's a very clean url. So I believe that might be the problem. Find a way to edit the url saved for the Wp.pl FastDial tab to the short url I suggested then retry the password autofill and see if it stays working.

I also noticed in the screencast, the "Segregator" image (http://a.wpimg.pl/a/i/profil2/poczta/segregator.jpg) at the bottom of the page keeps disappearing quickly. It looks like something is blocking the image. Maybe by a addon like Adblock Plus. That could be causing a conflict with the password manager autofill.

So please copy your list of addons from the Troubleshooting Information page by typing about:support in the address bar then press enter. Click the Copy all to clipboard button and paste the copied text here.

Modified by NoahSUMO

more options

Hi Noah!

It was so quiet here for a while I thought everyone gave up:)

I have looked up at url solution as you suggested. My current url for that website in FastDial is (and was for a long time): http://poczta.wp.pl/ (http://screencast.com/t/8CWg6Hio4Gb). I tried http://profil.wp.pl/login.html and same issue, but instead of logging into main email window it was opening my profile window. Whether I open poczta.wp.pl from FastDial or type it in in address bar, it always redirects/changes to that long junky url when the login website loads - and it has been like that since I remember. Yes, I use Adblock Plus, please see requested Troubleshooting info below. I tried disabling it and also tried FF safe mode and still the same issue :/ Maybe it is something to do with autofill and not just password manager itself? Since it's the login in the username field that doesn't appear filled in when I open the website, but password gets autofilled ONCE I type in or choose my login from drop down autofill list. Most other website with login I use has my username (and password) filled in upon opening (like with poczta.o2.pl) - if master password is entered already, or it requests the master password - if it's not and then fills it it automatically once master password is entered. With exception to Facebook, where I have two separate logins saved, one for myself and one for my girlfriend - when I open the login page, nothing is filled in and logically (as there are two different logins saved) I have to click on username box to get drop down list and choose my login - similarly to the problematic page in question (poczta.wp.pl), the only difference is that opening Facebook login page triggers master password dialog, and poczta.wp.pl doesn't :/

Thanks for your continuing help Noah!


Please note, I have used all of the add-ons for a while now - even before the problem occurred. I have removed some printer settings as I think this info is irrelevant and I had to limit the post length. Troubleshooting information:

Application Basics


Name: Firefox Version: 29.0.1 User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0

Crash Reports for the Last 3 Days


All Crash Reports

Extensions


Name: Adblock Plus Version: 2.6.3 Enabled: true ID: {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}

Name: Auto Refresh Version: 1.0.2 Enabled: true ID: autorefresh@plugin

Name: Classic Theme Restorer Version: 1.1.8 Enabled: true ID: ClassicThemeRestorer@ArisT2Noia4dev

Name: Dark Backgrounds Switcher Version: 0.3.2 Enabled: true ID: jid1-AGzBN6dsbJWp3A@jetpack

Name: Dictionary Extension Version: 3.0.12.1 Enabled: true ID: jid0-raWjElI57dRa4jx9CCiYm5qZUQU@jetpack

Name: Fast Dial Version: 4.11 Enabled: true ID: fastdial@telega.phpnet.us

Name: FireGestures Version: 1.8.6 Enabled: true ID: firegestures@xuldev.org

Name: YouTube High Definition Version: 9.0 Enabled: true ID: {7b1bf0b6-a1b9-42b0-b75d-252036438bdc}

Name: CleanTube Version: 0.1.0 Enabled: false ID: jid0-Oh6YfHwkh8Cb1Y4efKhBukwKfB0@jetpack

Important Modified Preferences


accessibility.typeaheadfind.flashBar: 0 browser.cache.disk.capacity: 1048576 browser.cache.disk.enable: false browser.cache.disk.smart_size_cached_value: 1048576 browser.cache.disk.smart_size.first_run: false browser.cache.memory.capacity: 327680 browser.history_expire_days.mirror: 180 browser.link.open_newwindow.restriction: 0 browser.places.importBookmarksHTML: false browser.places.smartBookmarksVersion: 6 browser.privatebrowsing.dont_prompt_on_enter: true browser.sessionstore.upgradeBackup.latestBuildID: 20140506152807 browser.startup.homepage: google.co.uk browser.startup.homepage_override.buildID: 20140506152807 browser.startup.homepage_override.mstone: 29.0.1 browser.tabs.loadInBackground: false browser.tabs.onTop: true dom.mozApps.used: true dom.w3c_touch_events.expose: false extensions.lastAppVersion: 29.0.1 font.internaluseonly.changed: true general.useragent.extra.ubiquity: gfx.direct3d.last_used_feature_level_idx: 0 gfx.direct3d.prefer_10_1: true network.cookie.cookieBehavior: 1 network.cookie.prefsMigrated: true places.database.lastMaintenance: 1402245413 places.history.expiration.transient_current_max_pages: 104858 places.history.expiration.transient_optimal_database_size: 167772160 places.last_vacuum: 1294015304 plugin.disable_full_page_plugin_for_types: application/pdf plugin.importedState: true plugin.state.java: 0 plugin.state.npitunes: 0 plugin.state.npnv3dv: 0 plugin.state.npnv3dvstreaming: 0 privacy.clearOnShutdown.cookies: false privacy.clearOnShutdown.downloads: false privacy.clearOnShutdown.formdata: false privacy.clearOnShutdown.history: false privacy.clearOnShutdown.offlineApps: true privacy.clearOnShutdown.sessions: false privacy.cpd.cookies: false privacy.cpd.downloads: false privacy.cpd.formdata: false privacy.cpd.history: false privacy.cpd.offlineApps: true privacy.cpd.sessions: false privacy.donottrackheader.enabled: true privacy.sanitize.migrateFx3Prefs: true privacy.sanitize.sanitizeOnShutdown: true privacy.sanitize.timeSpan: 0 security.warn_viewing_mixed: false storage.vacuum.last.index: 1 storage.vacuum.last.places.sqlite: 1401563806

Graphics


Adapter Description: NVIDIA GeForce 210 Adapter Drivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um Adapter RAM: 512 Device ID: 0x0a65 Direct2D Enabled: true DirectWrite Enabled: true (6.2.9200.16571) Driver Date: 3-4-2014 Driver Version: 9.18.13.3523 GPU #2 Active: false GPU Accelerated Windows: 1/1 Direct3D 10 Vendor ID: 0x10de WebGL Renderer: Google Inc. -- ANGLE (NVIDIA GeForce 210 Direct3D9Ex vs_3_0 ps_3_0) windowLayerManagerRemote: false AzureCanvasBackend: direct2d AzureContentBackend: direct2d AzureFallbackCanvasBackend: cairo AzureSkiaAccelerated: 0

JavaScript


Incremental GC: true

Accessibility


Activated: false Prevent Accessibility: 0

Modified by NoahSUMO

more options

No problem friend! :)

I'm going to file a bug about your problem so I can get advanced help from a firefox developer who works on the autofill and password manager area. Hopefully he will be able to locate the problem. I will post a link to the bug here once I finish it. :)

Thanks for the troubleshooting information as well! And yes, very smart move removing the printer settings. They're not helpful for this problem and I forgot about the post length limit. Sorry about that.

more options

Noah,

That's brilliant. Thank you, and all other contributors, for this great support. Hope the developer will be able to localize the bug and fix it - one little step more to making FF even better :) Looking forward to hearing from you about this and I'm open for any suggestions on this issue if anyone has any (in case I missed something and problem is on my side).

Regards

more options

Hey sorry for the wait. I filed the bug: Bug 1026941 - Password manager unable to fill username and pass consistently at poczta.wp.pl

You're welcome. Hopefully we can get some kind of answer to this. :)

more options

OK. I tested it with the name and password in the bug report. This looks like a problem with the submit URL. The form uses a submit URL action="/login.html"

<form action="/login.html" method="post" name="login" id="loginForm">

There runs a script that changes this to a secure version

loginForm = $('#loginForm').attr('action', 'https://profil.wp.pl/login.html'),

That makes the Password Manager not working properly. It should work if you open the login page via a secure connection https://profil.wp.pl/login.html

You can also use the Saved Password Editor extension to edit the form and modify the submit URL to use http://profil.wp.pl to make the Password Manager work.

Modified by cor-el

more options

Chosen Solution

hmm.. I don't know what to say now :)

Looks like you nailed it cor-el. I changed the url to https://profil.wp.pl/login.html as you suggested and re-saved login details with Password Manager and it worked but it logged me in to a profile page of the email. Then I tried it with https://poczta.wp.pl (rather than http://poczta.wp.pl) and now it works perfectly! The question remains, why did the whole thing happen? Could it be due to the fact I had this password saved long time ago with a different url and wp.pl changed their website code in the meantime? And still I don't really understand why it works with secure https url and not with normal http url but that's beyond this thread I guess and also beyond the scope of my understanding probably:)

Noah, thank you a lot for filling in the bug. It seems now that there was no issue with the Password Manager at all

In the hindsight you were both sniffing around very close to the solution few posts back :)

Big thanks to everyone who tried to help and contributed to this issue.

Should I mark this as solved now?

Regards

more options

You're welcome. :)

Yes, I was very close. I was focusing on the end of the url instead of the http/https part. I thought I mentioned something about that but it looks like I forgot to.

"Could it be due to the fact I had this password saved long time ago with a different url and wp.pl changed their website code in the meantime?" I believe this is what happened. Also another way could have been you were visiting the site with the https login url before then when you were updating your passwords, saved the new password using the http login url.

I don't know why websites like to make things like this confusing. :P It could be unintentional or that the person designing the website made a mistake when coding the login page.

In the bug, a Firefox developer made some suggestions that the website can do to fix the problem. If you could translate that into polish and send it to the webmasters of that site along with a link to the bug, hopefully that will help them fix it. Link: https://bugzilla.mozilla.org/show_bug.cgi?id=1026941#c2

I'll go ahead and mark your post as solving this since you posted what works. :)

Modified by NoahSUMO

  1. 1
  2. 2