Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I get a lot of untrusted connection messages on my work PC (behind firewall) and they don't always give the option of bypassing (the I know the risks option).

  • 7 replies
  • 18 have this problem
  • 272 views
  • Last reply by cor-el

more options

Since upgrading to FF29 I get a lot of untrusted connection errors on my work PC which is behind a firewall. These error messages sometimes show the technical details (e.g. plus.google.com uses an invalid security certificate.) but there is no "I know the risks" option provided to bypass and add an exception. I've seen the response about framed windows, but for sites like plus.google.com there isn't a framed window; right clicking doesn't give a "This Frame" menu item. I've deleted the cert8.db file as well, and that didn't resolve the issue.

I can't access much of google. I can't play YouTube HTML5 videos, though I was able to work through the HTML source to at least get the CSS file to load as even that was failing initially. I cannot load the accuweather site, though that doesn't seem to use https and so may be unrelated. I had no problems with any of these sites before upgrading to 29.

All Replies (7)

more options
more options

Yes, I know about that article. I know how to handle the untrusted connection in normal circumstances. I know it has something to do with being behind a proxy. (I have no problems hitting the same sites from my home PC.) My question is how to handle it when the "I understand the risks" option isn't presented and I thus can't add an exception and continue on to the site.

more options

and the problem continues with FF 30.

more options

Hi drsaaron,

Right to the left of the text there is a triangle, if you click on this the drop down for the option should appear.

more options

No, that just tells me "appengine.google.com uses an invalid security certificate."

more options

It looks like for this example you are accessing google apps engine. If you are an admin the app can be set to these three:

"Open to all Google Accounts users (default)

Restricted to the following Google Apps domain: (Experimental) Open to all users with an OpenID Provider"

However depending if you are using verisign or another certificate provider for the service the certificate may not have all the required chain for intermediate certificates.

Please check here: Options > Advanced > Certificates mini-tab > "View Certificates" button

You can also try [ Options > Advanced > Network mini-tab > "Settings" button] and selecting no proxy.

You can also try to install Fiddler try to debug sessions or check for Troubleshoot Firefox issues caused by malware

Also you can try http://stackoverflow.com/questions/27.../firefox-and-ssl-sec-error-unknown-issuer Does your Symantec Vulnerability Protection 12.2.0.5 - 1 or Firewall block these sites?

more options

Do a malware check with several malware scanning programs on the Windows computer. Please scan with all programs because each program detects different malware. All these programs have free versions.

Make sure that you update each program to get the latest version of their databases before doing a scan.

You can also do a check for a rootkit infection with TDSSKiller.

See also: