X
Tap here to go to the mobile version of the site.

Support Forum

Stop connection timeouts from happening - want the page to wait

Posted

I run multiple tab that monitor various tools. These pages refresh themselves. The pages have to wait for each other to finish before they can start.

In version 28 this was fine. The page would just wait indefinitely and kick in when a previous page finished doing its thing.

Now in version 29 it returns with a "The connection has timed out" message after some minutes.

I have adjusted

network.http.connection-timeout network.http.pipelining.read-timeout

to high values but problem is still occurring. Any thoughts on how I can return the behavior to FF28?

I run multiple tab that monitor various tools. These pages refresh themselves. The pages have to wait for each other to finish before they can start. In version 28 this was fine. The page would just wait indefinitely and kick in when a previous page finished doing its thing. Now in version 29 it returns with a "The connection has timed out" message after some minutes. I have adjusted network.http.connection-timeout network.http.pipelining.read-timeout to high values but problem is still occurring. Any thoughts on how I can return the behavior to FF28?

Chosen solution

Try adjusting the http.response.timeout setting. In version 28 this was not set. In version 29 it is set to 300 (5 minutes). Increasing it to something much larger should help.

See this blog entry:

http://morgb.blogspot.com/2014/05/firefox-29-and-http-response-timeout.html

Read this answer in context 16

Additional System Details

Installed Plug-ins

  • Google Update
  • 5.1.20913.0
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.03
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.1.629
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0

More Information

jim99 1 solutions 1 answers

Chosen Solution

Try adjusting the http.response.timeout setting. In version 28 this was not set. In version 29 it is set to 300 (5 minutes). Increasing it to something much larger should help.

See this blog entry:

http://morgb.blogspot.com/2014/05/firefox-29-and-http-response-timeout.html

Try adjusting the http.response.timeout setting. In version 28 this was not set. In version 29 it is set to 300 (5 minutes). Increasing it to something much larger should help. See this blog entry: http://morgb.blogspot.com/2014/05/firefox-29-and-http-response-timeout.html

Helpful Reply

I can confirm that this setting works.

Either setting it to 0 or a very large number returns the behavior to previous.

http.response.timeout = 0 or http.response.timeout = 300000

My scripts now do no time out when waiting.

Thanks.

I can confirm that this setting works. Either setting it to 0 or a very large number returns the behavior to previous. http.response.timeout = 0 or http.response.timeout = 300000 My scripts now do no time out when waiting. Thanks.