X
Tap here to go to the mobile version of the site.
IMPORTANT ANNOUNCEMENT: We’re going through some system changes, that may have slowed responses to your questions. If you had asked a question in the last couple of months, please re-post it and the community will help you as soon as we can. If you’ve registered after February 7th, please register again, the accounts on the previous site were not migrated to this temporary site. If you joined us before February 7, please reset your password if you have trouble logging into this temporary site.

Support Forum

My add-ons disabled themselves and I can't enable them.

Posted

Out of suddenly, all of my add-ons expect Adblock Plus disabled and I can't enable them, and I didn't change nothing on my laptop at that time. I tried to do Troubleshooting Information, restart my laptop, uninstall and install Mozilla twice, by deleting even all files about Mozilla, but nothing worked. I even tried to do a system restore, but it don't worked because it has a problem in a file! Useful info: When I install again the Mozilla and I install again the add-ons, they are enable and they are working fine, but when I close the browser and open it again, the add-ons are disabled again... And I don't know if that means something, but I have also problem to do the Windows Updates the last week, it can't complete. I have Windows 7 x64 and the lasted edition of Mozilla Firefox. Any ideas?

P.S. English isn't my first language, so sorry if I did any mistakes.

Out of suddenly, all of my add-ons expect Adblock Plus disabled and I can't enable them, and I didn't change nothing on my laptop at that time. I tried to do Troubleshooting Information, restart my laptop, uninstall and install Mozilla twice, by deleting even all files about Mozilla, but nothing worked. I even tried to do a system restore, but it don't worked because it has a problem in a file! Useful info: When I install again the Mozilla and I install again the add-ons, they are enable and they are working fine, but when I close the browser and open it again, the add-ons are disabled again... And I don't know if that means something, but I have also problem to do the Windows Updates the last week, it can't complete. I have Windows 7 x64 and the lasted edition of Mozilla Firefox. Any ideas? P.S. English isn't my first language, so sorry if I did any mistakes.

Chosen solution

Do a malware check with several malware scanning programs on the Windows computer.
Please scan with all programs because each program detects different malware.
All these programs have free versions.

Make sure that you update each program to get the latest version of their databases before doing a scan.

You can also do a check for a rootkit infection with TDSSKiller.

See also:

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Shockwave Flash 13.0 r0
  • Google Update
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.06
  • GEPlugin
  • Adobe Shockwave for Director Netscape plug-in, version 11.5.9.620

Application

  • Firefox 28.0
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:28.0) Gecko/20100101 Firefox/28.0
  • Support URL: https://support.mozilla.org/1/firefox/28.0/WINNT/en-US/

Extensions

  • Adblock Plus 2.6 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • AtuZi 1.0.1 ({9e891144-6b11-4b15-831d-1fc05f439ef4}) (Inactive)
  • DownloadHelper 4.9.22 ({b9db16a4-6edc-47ec-a1f4-b86292ed211d}) (Inactive)
  • X-notifier 3.3.16 ({37fa1426-b82d-11db-8314-0800200c9a66}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics Family
  • adapterDescription2:
  • adapterDeviceID: 0x0106
  • adapterDeviceID2:
  • adapterDrivers: igdumd64 igd10umd64 igd10umd64 igdumdx32 igd10umd32 igd10umd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'blockedDriver']
  • directWriteEnabled: False
  • directWriteVersion: 6.2.9200.16492
  • driverDate: 5-7-2011
  • driverDate2:
  • driverVersion: 8.830.6.3000
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics Family Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Direct3D 9

Modified Preferences

  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 6
  • browser.sessionstore.upgradeBackup.latestBuildID: 20140314220517
  • browser.startup.homepage_override.buildID: 20140314220517
  • browser.startup.homepage_override.mstone: 28.0
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 28.0
  • network.cookie.prefsMigrated: True
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.sanitize.migrateFx3Prefs: True

Misc

  • User JS: Yes
  • Accessibility: No
Moses
  • Moderator
382 solutions 3171 answers

I see that user.js is active on Firefox

The user.js file is only present if you or other software has created this file and normally it wouldn't be there.

You can delete a possible user.js file and numbered prefs-##.js files and rename (or delete) the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in the current Firefox release. You can get to the profile folder below:

  • Help > Troubleshooting Information > Profile Directory > Show Folder

or

  • Go to about:support and click Show Folder next to Profile Directory.

I see that user.js is active on Firefox The user.js file is only present if you or other software has created this file and normally it wouldn't be there. You can delete a possible user.js file and numbered prefs-##.js files and rename (or delete) the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in the current Firefox release. You can get to the profile folder below: *Help > Troubleshooting Information > Profile Directory > Show Folder or *Go to '''about:support''' and click Show Folder next to Profile Directory. ----
cor-el
  • Top 10 Contributor
  • Moderator
14852 solutions 134637 answers

It is possible that there is a problem with the file(s) that store the extensions registry.

Delete the extensions.* files (e.g. extensions.json, extensions.sqlite, extensions.ini) and compatibility.ini in the Firefox profile folder to reset the extensions registry.

New files will be created when required.

See "Corrupt extension files":

If you see disabled or not compatible extensions in "Firefox/Tools > Add-ons > Extensions" then click the Tools button at the left end of the Search bar to check if there is a compatibility update available.

It is possible that there is a problem with the file(s) that store the extensions registry. Delete the extensions.* files (e.g. extensions.json, extensions.sqlite, extensions.ini) and compatibility.ini in the Firefox profile folder to reset the extensions registry. *https://support.mozilla.org/kb/Profiles New files will be created when required. See "Corrupt extension files": *http://kb.mozillazine.org/Unable_to_install_themes_or_extensions *https://support.mozilla.org/kb/Unable+to+install+add-ons If you see disabled or not compatible extensions in "Firefox/Tools > Add-ons > Extensions" then click the Tools button at the left end of the Search bar to check if there is a compatibility update available.

Question owner

Hello again. I did all the things you told to do, I deleted those files, but nothing worked, I updated Mozilla also and my add-ons were deleted and I installed them again, but when I close the browser, they disabled themselves again and I can't enable them again! :( And there are not any updates at my add-ons. What else I can do?

Hello again. I did all the things you told to do, I deleted those files, but nothing worked, I updated Mozilla also and my add-ons were deleted and I installed them again, but when I close the browser, they disabled themselves again and I can't enable them again! :( And there are not any updates at my add-ons. What else I can do?
cor-el
  • Top 10 Contributor
  • Moderator
14852 solutions 134637 answers

Try to Delete a possible user.js file and numbered prefs-##.js files and rename (or delete) the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in the current Firefox release.

You can use this button to go to the currently used Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder)
Try to Delete a possible user.js file and numbered prefs-##.js files and rename (or delete) the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in the current Firefox release. You can use this button to go to the currently used Firefox profile folder: *Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder) *http://kb.mozillazine.org/Preferences_not_saved
FredMcD
  • Top 10 Contributor
2700 solutions 36342 answers

Here is a thought. After the upgrade to v29, I discovered that many of my add-ons, and Firefox itself, had their options changed or reset. Check your Use Hardware Acceleration option. I found that mine had been turned on, but it was off before the upgrade.

LAST RESORT ! ! Reset Firefox

After the reset, put your add-ons back only a few at a time.

Here is a thought. After the upgrade to v29, I discovered that many of my add-ons, and Firefox itself, had their options changed or reset. Check your '''Use Hardware Acceleration''' option. I found that mine had been turned on, but it was off before the upgrade.<BR><BR> '''''LAST RESORT ! ! ''''' '''''[https://support.mozilla.org/en-US/kb/reset-firefox-easily-fix-most-problems Reset Firefox]'''''<BR><BR> After the reset, put your add-ons back only a few at a time.

Question owner

Nothing of that did not worked! :( I renamed the prefs.js file, nothing, I checked off the Use Hardware Acceleration, nothing, I rested Firefox, nothing! I'm driving crazy right now! And I installed a new theme and it goes back to default when I close and open Mozilla!

Nothing of that did not worked! :( I renamed the prefs.js file, nothing, I checked off the Use Hardware Acceleration, nothing, I rested Firefox, nothing! I'm driving crazy right now! And I installed a new theme and it goes back to default when I close and open Mozilla!

Question owner

Any help? I'm really desperate! :( I have only one add-on that is still enable and that is because it not needs a reset of Mozilla after the install, the others that I have they need reset Mozilla after I install them, and they are working after the reset but when I close and open again the Mozilla, they disabled themselves.Maybe is there a problem of stability with the add-ons that need to reset the Mozilla after you install them?

Any help? I'm really desperate! :( I have only one add-on that is still enable and that is because it not needs a reset of Mozilla after the install, the others that I have they need reset Mozilla after I install them, and they are working after the reset but when I close and open again the Mozilla, they disabled themselves.Maybe is there a problem of stability with the add-ons that need to reset the Mozilla after you install them?
cor-el
  • Top 10 Contributor
  • Moderator
14852 solutions 134637 answers

Create a new profile as a test to check if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over the problem

Create a new profile as a test to check if your current profile is causing the problem. See "Creating a profile": *https://support.mozilla.org/kb/profile-manager-create-and-remove-firefox-profiles *http://kb.mozillazine.org/Standard_diagnostic_-_Firefox#Profile_issues If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over the problem *http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox

Question owner

I have tried for two days now, but I can't create a new profile, I can't open the Profile Manager, I completely closed the Mozilla and I tried the two ways, but it always opens the Mozilla, not the Profile Manager! :(

I have tried for two days now, but I can't create a new profile, I can't open the Profile Manager, I completely closed the Mozilla and I tried the two ways, but it always opens the Mozilla, not the Profile Manager! :(
cor-el
  • Top 10 Contributor
  • Moderator
14852 solutions 134637 answers

Try to do this immediately after booting the computer or boot the computer in Windows Safe Mode with network support (press F8 on the boot screen).

Try to do this immediately after booting the computer or boot the computer in Windows Safe Mode with network support (press F8 on the boot screen). *http://www.bleepingcomputer.com/tutorials/how-to-start-windows-in-safe-mode/
FredMcD
  • Top 10 Contributor
2700 solutions 36342 answers

Start Firefox in Safe Mode. Don't do anything, just let it be for a bit. Does it seem to work okay? Have you turned off Use Hardware Acceleration? Look thru your add-ons. Is there anything there that you don't know?

Windows > Start > Control Panel > Uninstall Programs. Go thru the list and use a web search to check any that you don't know what they are.

The hard way; Go to your add-ons page while in safe mode. Disable a bunch of them. Then restart. Repeat until the trouble stops.

'''''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode]'''''. Don't do anything, just let it be for a bit. Does it seem to work okay? Have you turned off '''Use Hardware Acceleration'''? Look thru your add-ons. Is there anything there that you don't know?<BR><BR> '''''Windows > Start > Control Panel > Uninstall Programs. ''''' Go thru the list and use a web search to check any that you don't know what they are.<BR><BR> The hard way; Go to your add-ons page '''while in safe mode'''. Disable a bunch of them. Then restart. Repeat until the trouble stops.

Question owner

@cor-el: I have tried to do this immediately after the booting, but it not worked. I tried to open the Profile Manager in Windows Safe Mode with the both ways, but nothing, it opens the Mozilla, not the window of the Profile Manager! :( @FredMcD: I have tried to turn off the Use Hardware Acceleration before, but it keeps turn on! I don't know why. Even in Firefox Safe Mode and Windows Safe Mode it turns on when I go to check if I turn it off! And I have checked if I have a program that I don't know, but I don't have any. Also, how I can disable the add-ons in safe mode (both Windows and Firefox), if they are disabled already?! Also, I tried to delete those files that you told me in first place in Windows Safe Mode and I installed the add-ons again, but it keeps disabling themselves after I close and open again the Mozilla! :/

@cor-el: I have tried to do this immediately after the booting, but it not worked. I tried to open the Profile Manager in Windows Safe Mode with the both ways, but nothing, it opens the Mozilla, not the window of the Profile Manager! :( @FredMcD: I have tried to turn off the Use Hardware Acceleration before, but it keeps turn on! I don't know why. Even in Firefox Safe Mode and Windows Safe Mode it turns on when I go to check if I turn it off! And I have checked if I have a program that I don't know, but I don't have any. Also, how I can disable the add-ons in safe mode (both Windows and Firefox), if they are disabled already?! Also, I tried to delete those files that you told me in first place in Windows Safe Mode and I installed the add-ons again, but it keeps disabling themselves after I close and open again the Mozilla! :/

Modified by AthinaSmile

Kam 2 solutions 42 answers

Helpful Reply

1. Move Mozilla Firefox folder' to Temp folder > Rename firefox.exe to test.exe > create a Test.cmd by using Notepad (same location with test.exe):

start test.exe -profile test -no-remote

File Name : test.cmd | Save as type: All file

2. Run test.cmd then reinstall ABP

1. Move '''Mozilla Firefox folder''' to '''Temp folder''' > Rename firefox.exe to test.exe > create a '''Test.cmd'' by using Notepad (same location with test.exe): '''start test.exe -profile test -no-remote''' File Name : test.cmd | Save as type: All file 2. Run test.cmd then reinstall ABP

Modified by Kam

FredMcD
  • Top 10 Contributor
2700 solutions 36342 answers

It is true that while you are in safe mode, the add-ons are disabled. But you can still make changes that should be acted on when Firefox is restarted, Start Firefox in Safe Mode. Go to the add-ons and select Disable on all of them. Then restart and tell us if there is any change.

It is true that while you are in safe mode, the add-ons are disabled. But you can still make changes that should be acted on when Firefox is restarted, '''''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode]'''''. Go to the add-ons and select '''Disable''' on '''all of them'''. Then restart and tell us if there is any change.

Question owner

@Kam, it worked, sort of! When I run the test.cmd file, I can install the add-ons and they don't disabled themselves anymore, but what do I do now with the test.exe, test.cmd and the whole Mozilla file? Leave it and don't move it back in Programs? 'Cause when I run the test.cmd, it opens a new window and when I try open the window of Mozilla that is pin, it goes back with add-ons disabled and I can't pin the window that test.cmd opens.

@Kam, it worked, sort of! When I run the test.cmd file, I can install the add-ons and they don't disabled themselves anymore, but what do I do now with the test.exe, test.cmd and the whole Mozilla file? Leave it and don't move it back in Programs? 'Cause when I run the test.cmd, it opens a new window and when I try open the window of Mozilla that is pin, it goes back with add-ons disabled and I can't pin the window that test.cmd opens.
Kam 2 solutions 42 answers

Now , your Firefox is portable , just move it to anywhere you want. To run FF, just Run test.cmd

How to pin test.cmd :

  1. Rename test.cmd to PortableFF.exe > Right click > Pin to Taskbar
  2. Right click on pinned icon > Right click PortableFF > Properties > Shortcut > Target > change PortableFF.exe to Portable.cmd
  3. Rename again: PortableFF.exe (in Temp folder) to Portable.cmd

Limitation:

  1. Because it's portable mode , you will see 2 icons (1 for cmd, 1 for FF)
  2. You cant set FF to Default Browser
Now , your Firefox is '''portable''' , just move it to anywhere you want. To run FF, just Run test.cmd How to pin test.cmd : # Rename test.cmd to PortableFF.exe > Right click > Pin to Taskbar # Right click on pinned icon > Right click PortableFF > Properties > Shortcut > Target > change PortableFF.exe to Portable.cmd # Rename again: PortableFF.exe (in Temp folder) to Portable.cmd Limitation: # Because it's portable mode , you will see 2 icons (1 for cmd, 1 for FF) # You cant set FF to Default Browser

Modified by Kam

Question owner

@Kam, Thanks for the help, but it's not working at all, because I want open links from RSS and from my Twitter program and they open at the Mozilla that has disabled add-ons, so I'll try to find a way to enable the add-ons in that Mozilla. :) @FredMcD I have only one add-on that has no problem and I disabled that in Mozilla Safe Mode and when I restart, that add-on stayed disabled. I can't disable the other add-ons that disabled themselves at Mozilla Safe Mode, because they are already disabled! And the only choice is to click at the Enable button, but after the restart, they are disabled again.

@Kam, Thanks for the help, but it's not working at all, because I want open links from RSS and from my Twitter program and they open at the Mozilla that has disabled add-ons, so I'll try to find a way to enable the add-ons in that Mozilla. :) @FredMcD I have only one add-on that has no problem and I disabled that in Mozilla Safe Mode and when I restart, that add-on stayed disabled. I can't disable the other add-ons that disabled themselves at Mozilla Safe Mode, because they are already disabled! And the only choice is to click at the Enable button, but after the restart, they are disabled again.
Kam 2 solutions 42 answers

1. FF > Help > Trouble > Show Folder > Close FF > wait for 3 seconds > move (Cut/paste) all files & folders to Temp > Run FF

2. Try Tete Firefox Version : http://www1.plala.or.jp/tete009/en-US/software.html#FX290_VC12 extract it to Tete Folder

Create tmemutil.ini by using Notepad: http://paste2.org/eXDdBX6A (same place as tete's firefox.exe)

Now , your FF is portable and can be set to Default Browser. Then run Tete (firefox.exe)

1. FF > Help > Trouble > Show Folder > Close FF > wait for 3 seconds > move (Cut/paste) all files & folders to Temp > Run FF 2. Try Tete Firefox Version : http://www1.plala.or.jp/tete009/en-US/software.html#FX290_VC12 extract it to Tete Folder Create '''tmemutil.ini''' by using Notepad: http://paste2.org/eXDdBX6A (same place as tete's firefox.exe) Now , your FF is portable and can be set to Default Browser. Then run Tete (firefox.exe)

Modified by Kam

Question owner

It's not working. :( Maybe I do something wrong, what I do with the Temp folder that I coped/pasted the files and the folders from the Show Folder? Because I created another new folder and I put there the Tete with the tmemnutil.ini, and my add-ons was still disabled and I had the felling that I did something wrong and I put the whole Tete Folder in the Temp folder that has the files and folders from the Show Folder and again nothing.

It's not working. :( Maybe I do something wrong, what I do with the Temp folder that I coped/pasted the files and the folders from the Show Folder? Because I created another new folder and I put there the Tete with the tmemnutil.ini, and my add-ons was still disabled and I had the felling that I did something wrong and I put the whole Tete Folder in the Temp folder that has the files and folders from the Show Folder and again nothing.

Modified by AthinaSmile

cor-el
  • Top 10 Contributor
  • Moderator
14852 solutions 134637 answers

Chosen Solution

Do a malware check with several malware scanning programs on the Windows computer.
Please scan with all programs because each program detects different malware.
All these programs have free versions.

Make sure that you update each program to get the latest version of their databases before doing a scan.

You can also do a check for a rootkit infection with TDSSKiller.

See also:

Do a malware check with several malware scanning programs on the Windows computer.<br> Please scan with all programs because each program detects different malware.<br> All these programs have free versions. Make sure that you update each program to get the latest version of their databases before doing a scan. *Malwarebytes' Anti-Malware:<br>http://www.malwarebytes.org/mbam.php *AdwCleaner:<br>http://www.bleepingcomputer.com/download/adwcleaner/<br>http://www.softpedia.com/get/Antivirus/Removal-Tools/AdwCleaner.shtml *SuperAntispyware:<br>http://www.superantispyware.com/ *Microsoft Safety Scanner:<br>http://www.microsoft.com/security/scanner/en-us/default.aspx *Windows Defender:<br>http://windows.microsoft.com/en-us/windows/using-defender *Spybot Search & Destroy:<br>http://www.safer-networking.org/en/index.html *Kasperky Free Security Scan:<br>http://www.kaspersky.com/security-scan You can also do a check for a rootkit infection with TDSSKiller. *Anti-rootkit utility TDSSKiller:<br>http://support.kaspersky.com/5350?el=88446 See also: *"Spyware on Windows": http://kb.mozillazine.org/Popups_not_blocked