Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

With Firefox 29 on Ubuntu (32 bit) the rendering is wrong on my website. It's fine in Windows Firefox though.

  • 27 replies
  • 9 have this problem
  • Last reply by billyray520

more options

I am using Ubuntu 12.04 LTS and Windows 7 Pro, Firefox 29. The problem only affects my home page, no other pages. It never rendered like this before Firefox 29 for Linux. My website is

If anyone can see what the problem is, I would be very grateful, as I don't want my Linux Firefox users to see an unprofessional looking page.

Chosen solution

Finally got the answer to this problem! Javierrivera over on the Ubuntu Forum figured it out in a minute. I had the size of the Input Text box in the search form at the bottom of the page too large. Once I corrected that, Even Ubuntu Firefox works perfectly. Thanks to everyone for giving it some thought!

Read this answer in context 👍 0

All Replies (20)

more options

I checked with the Firefox inspector and I've narrowed down the culprit to the <td.c_l> element on the index page. But in Windows it performs exactly as it is supposed to, but in Linux it doesn't?? Even in the active inspection mode, I can't change the behavior of this element when in Linux. I think the rendering in Linux might have a bug.

more options

Oh, one more thing. This was happening before Firefox 29 on Linux, I just noticed it after upgrading though. Sorry....

more options

The website looks OK to me on Linux if I compare with Google Chrome.

Can you attach a screenshot?

Use a compressed image type like PNG or JPG to save the screenshot.

You may have zoomed the page(s) by accident.
Reset the page zoom on pages that cause problems.

  • View > Zoom > Reset (Ctrl+0 (zero); Command+0 on Mac)
more options

Thanks for your reply! I have attached a screen shot of the problem. This is on my 32 bit Ubuntu 12 notebook with Firefox 29. I also just checked my old desktop with Ubuntu 10 and Firefox 20 and there is no problem there. I have also tried this on my Ubuntu 12 64 bit desktop with Firefox 29, and the problem is there too. You can see the screen shot how the column is not being correctly set. When in active edit mode of the Firefox web console I am unable to make any effective changes either. But another thing I tried, is a website which renders your webpage on all sorts of browsers and OS's. Unfortunately there was no Ubuntu 12/Firefox 29 combo. But NONE of the other browser/OS combos produced this problem.

The second picture show Ubuntu 10 with Firefox 20.

I'm thinking it's probably an Ubuntu 12/Firefox 29 issue only. Any ideas?

I really appreciate your attention!

Modified by billyray520

more options

Oops, forgot to mention, I did try zoom/reset but that didn't help.

more options

If you have made changes to Advanced font settings in Edit > Preferences like increasing the minimum/default font size then try the default minimum setting "none" and the default font size 16 in case the current setting is causing problems.

  • Tools > Options > Content : Fonts & Colors > Advanced > Minimum Font Size (none)

Make sure that you allow pages to choose their own fonts.

  • Tools > Options > Content : Fonts & Colors > Advanced: [X] "Allow pages to choose their own fonts, instead of my selections above"

It is better not to increase the minimum font size, but to use an extension to set the default page zoom to prevent issues with text not being displayed properly.

more options

THank you for your reply cor-el! I may have given you the wrong impression. I tried to reset the zoom even though I NEVER use the zoom or change the fonts. I only tried it at your suggestion. If you remember from my first page, this only occurs on my home page with Ubuntu 12 and Firefox 29. None of my other web pages are affected. The Home page DOES use a different CSS codepage in its layout however. But I can't make any changes to it, because it already renders correctly in every other browser (including Firefox) on every other OS. So to change it just for this one combo: Ubuntu 12/Firefox 29 would be a mistake. I am pretty certain there is a bug, maybe in the Ubuntu 12 Firefox 29 rendering engine that was not there, say for example in Ubuntu 10 with Firefox 20. I didn't see this occur either in Ubuntu 12 BEFORE the Firefox 29 update. Let me know if I can provide any additional info.

Modified by billyray520

more options

Works fine on Ubuntu with Firefox 29 here.

more options

Which Ubuntu? 32 bit or 64 bit?

I'm seeing the problem in Ubuntu 12.04 LTS, both 32 bit and 64 bit versions on two different PC. (one is a Dell laptop the other is an Asus desktop) Using Firefox 29.

Did you look at my pics? The one on the left is the bad one (Ubuntu 12/Firefox 29) The one on the right is how it should look. It does look right in every browser and OS I've tried except the combo I'm talking about.

Modified by billyray520

more options

64 bit

more options

I was only able to reproduce the Linux screenshot on Linux by Zooming in a bit with "Ctrl+scroll wheel" while the "Zoom Text Only" was selected in View -> Zoom. It looked fine after zoom reset or Ctrl+O

Modified by James

more options

James, which Linux. I have already confirmed the problem is ONLY on Ubuntu 12/Firefox 29 (no other Linux has the issue)

@ witheld: You still haven't stated WHICH Ubuntu, only that it is the 64 bit one.

As of this post, NO ONE has confirmed that my website is definitely working fine (see pics above) in Ubuntu 12/Firefox 29.

I have two different machines running Ubuntu 12 Firefox 29. One is 64 bit and one is 32 bit. They both exhibit the problem.

There is NO zoom activated on either, and Zoom has been reset anyway, and still I have the problem.

more options

I use the Mozilla builds of Firefox on 32-bit openSUSE.

more options

I can get issues if I select zoom text and only zoom the text of the page.
I also see issues if I increase the minimum font size and you might possibly also get issues if a wider font would be used if the specified font isn't available.

With the defaults it looks fine.

You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History > Show All History" or "View > Sidebar > History") or via the about:permissions page.

Using "Forget About This Site" will remove all data stored in Firefox from that domain like bookmarks, cookies, passwords, cache, history, and exceptions, so be cautious and if you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of the involved files.

It doesn't have any lasting effect, so if you revisit such a 'forgotten' website then data from that website will be saved once again.

Create a new profile as a test to check if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over the problem

more options

@ cor-el: you said: I can get issues if I select zoom text and only zoom the text of the page. I also see issues if I increase the minimum font size and you might possibly also get issues if a wider font would be used if the specified font isn't available. With the defaults it looks fine. "

Are you testing with Ubuntu 12 / Firefox 29? I know that it looks fine in everything else. Furthermore, the issue is only on the home page, none of the other pages even in Ubuntu 12 / Firefox 29. Did you test the other pages to see if they were fine when you zoomed the fonts or text?

I need someone with access to Ubuntu 12 (32 bit or 64 bit) that has Firefox 29 to respond. I haven't been able to check all versions of Ubuntu 12 (meaning 12.10) or more recent versions of Ubuntu, but I would be very glad to hear from people that have Ubuntu 12 or newer with Firefox 29 regarding this problem.

Modified by billyray520

more options

I'm having this problem on Windows XP service pack 3. I have to set the zoom to 80% to get it to render correctly. Everything renders perfectly on my Windows 7 box.

Modified by 9pad

more options

You can set the layout.css.devPixelsPerPx pref on the about:config page to 1.0 or on Windows 8 to 1.25 and if necessary adjust layout.css.devPixelsPerPx starting from 1.0 in 0.1 or 0.05 steps (1.1 or 0.9) to make icons show correctly.

See also:

Use an extension to adjust the text size in the user interface and the page zoom in the browser window.

You can look at this extension to adjust the font size for the user interface.

You can look at the Default FullZoom Level or NoScript extension if web pages need to be adjusted after changing layout.css.devPixelsPerPx.

more options

cor-el you said: "You can set the layout.css.devPixelsPerPx pref on the about:config page to 1.0 or on Windows 8 to 1.25 and if necessary adjust layout.css.devPixelsPerPx starting from 1.0 in 0.1 or 0.05 steps (1.1 or 0.9) to make icons show correctly."

The problem with this solution is that the rendering problem does NOT occur in ANY Windows version of Firefox, nor with Chrome, nor with IE, nor with MOST Linux versions of Firefox 29. The problem ONLY occurs (to my knowledge so far) with Ubuntu 12/Firefox 29 combination. That means I have NO REASON to adjust anything, either in my own Firefox, or in my website. The problem is NOT MINE, except that my website will render incorrectly for my customers that use Ubuntu 12/Firefox 29. (If there are any, as this thread hasn't seemed to shake out any other users of that combo.)

But thanks for your continued efforts!

more options

I can see this problem.

I have tried and seen this on on Mozilla Fx32, 29 & 24 Also Canonical Fx31

Of course you see the issue yourself and have posted screenshots. Why not refer the matter to your website designer ?

I am using 64 bit Ubuntu12.04

If no one here is giving you answers why not try on Mozillazine

more options

John99: Thanks for verifying that the issue does occur for you as well in the versions you mentioned. I am the designer of my website. Since the website works perfectly in every other configuration of Linux and Windows, and whatever browser you can imagine, and since this problem only affects the home page (none of the other pages) which oddly enough uses the same CSS and design structure, but only differ in that they are contained (referenced back to) different CSS files. But I've ruled out actual differences in the CSS, as that would be rendered differently across all other browsers and OSs. In fact, at this point, I am fairly certain the issue is not with Firefox, but with Ubuntu 12 (and maybe later.) But it would be nice to know for certain what is going on!

John, if you want to try something, and you have time, you can try opening the web developer console. The problem appears to be with the table cell that sets the margin for the menu and other stuff to the right. (It's "td class=c_l", within Table class="content") When in that console, I was unable to make any changes that would change the rendering while in responsive design mode. (Just a slight change that didn't help.) That is while in Ubuntu 12 of course. Just curious about that too. I wonder if that's some sort of clue? In Windows, the changes DO change the rendering while in responsive design mode.

Modified by billyray520

  1. 1
  2. 2