X
Tap here to go to the mobile version of the site.

Support Forum

Error with Addons page

Posted

I am getting "error while downloading" while trying to install add ons, after having reinstalled, the add ons page now appears very basic with broken images but the navigation bar(ADD-Ons, Extensions, Plugins etc.) is'nt affected. What should I do?(And what is wrong?)

Thanks,

Ray

I am getting "error while downloading" while trying to install add ons, after having reinstalled, the add ons page now appears very basic with broken images but the navigation bar(ADD-Ons, Extensions, Plugins etc.) is'nt affected. What should I do?(And what is wrong?) Thanks, Ray

Chosen solution

please check that your system's date, time & timezone are set correctly!

Read this answer in context 8

Additional System Details

Installed Plug-ins

  • Google Update
  • Shockwave Flash 12.0 r0
  • VLC media player Web Plugin 2.1.0
  • 2.1.7
  • 5.1.20513.0
  • Pando Web Plugin
  • 0.70.4
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:28.0) Gecko/20100101 Firefox/28.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
16467 solutions 148547 answers

You can try these steps in case of issues with web pages:

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • Hold down the Shift key and left-click the Reload button
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Command + Shift + R" (Mac)

Clear the cache and cookies only from websites that cause problems.

"Clear the Cache":

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox/Tools > Options > Privacy > Cookies: "Show Cookies"

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window.
You can try these steps in case of issues with web pages: You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files. *Hold down the Shift key and left-click the Reload button *Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux) *Press "Command + Shift + R" (Mac) Clear the cache and cookies only from websites that cause problems. "Clear the Cache": *Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now" "Remove Cookies" from sites causing problems: *Firefox/Tools > Options > Privacy > Cookies: "Show Cookies" Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance). *Do NOT click the Reset button on the Safe Mode start window. *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes

Question owner

None of this works, is there any more info I can provide that will help resolve the problem? I have reinstalled Firefox several times to no success. So i imagine ( it something to do with the script?? Also any add ons I try to download ends up downloading for a few seconds (Progress bar shows 1-2millimeters of progress) and then gives me the following error: There was an error downloading '*add on*'.

Thanks, Ray

None of this works, is there any more info I can provide that will help resolve the problem? I have reinstalled Firefox several times to no success. So i imagine ( it something to do with the script?? Also any add ons I try to download ends up downloading for a few seconds (Progress bar shows 1-2millimeters of progress) and then gives me the following error: ''There was an error downloading '*add on*'''. Thanks, Ray
cor-el
  • Top 10 Contributor
  • Moderator
16467 solutions 148547 answers

Can you attach a screenshot?

Use a compressed image type like PNG or JPG to save the screenshot.

Can you attach a screenshot? *http://en.wikipedia.org/wiki/Screenshot *https://support.mozilla.org/kb/how-do-i-create-screenshot-my-problem Use a compressed image type like PNG or JPG to save the screenshot.

Question owner

Are these sufficient?

Are these sufficient?
Moses
  • Moderator
459 solutions 3602 answers

Helpful Reply

Rzay,

There is currently maintenance going on with the Addons page and the Firefox OS Marketplace page as of 15:00 PDT and is expected to last about 5 hours. Until then, AMO and the Marketplace will be in a read-only state. There was a bug report filed under Bug 985473 but I cant' view it since I don't have the permissions to. You can see the report on https://status.mozilla.org/en-US/detail/78/

You can see the status of addons.mozilla.org on http://status.mozilla.com/ showing Service Disruptions at the bottom for today (Apr 2)

EDIT: It seems to be working now as I can download extensions. Try it then report back to us

Rzay, There is currently maintenance going on with the Addons page and the Firefox OS Marketplace page as of 15:00 PDT and is expected to last about 5 hours. Until then, AMO and the Marketplace will be in a read-only state. There was a bug report filed under [https://bugzilla.mozilla.org/show_bug.cgi?id=985473 Bug 985473] but I cant' view it since I don't have the permissions to. You can see the report on https://status.mozilla.org/en-US/detail/78/ You can see the status of addons.mozilla.org on http://status.mozilla.com/ showing Service Disruptions at the bottom for today (Apr 2) '''EDIT: It seems to be working now as I can download extensions. Try it then report back to us'''

Modified by Moses

Question owner

No, unfortunately I'm having the same issues

No, unfortunately I'm having the same issues
Moses
  • Moderator
459 solutions 3602 answers

Ray,

You noted in your initial post that the Add-ons page appears basic with no CSS stylings. Does it still appear like that?

Clarification: What problems are you having?

Ray, You noted in your initial post that the Add-ons page appears basic with no CSS stylings. Does it still appear like that? Clarification: What problems are you having?

Question owner

So my Get Add ons page still looks like this and i still get the errors while downloading. However the other tabs appear to be normal.

So my Get Add ons page still looks like this and i still get the errors while downloading. However the other tabs appear to be normal.
Moses
  • Moderator
459 solutions 3602 answers

What's the EXACT error you get when installing an addon? Are you installing it from the site or through the Addons window?

Let me know if you are seeing one of these messages or if this fits your situation when you try to download:

  • Add-on is not compatible
  • Add-on is blocked
  • Software installation disabled
  • Firefox prevented the site from asking you to install software
  • Invalid file hash (possible download corruption) -261
  • Download Error -228
What's the '''EXACT''' error you get when installing an addon? Are you installing it from the site or through the Addons window? Let me know if you are seeing one of these messages or if this fits your situation when you try to download: *Add-on is not compatible *Add-on is blocked *Software installation disabled *Firefox prevented the site from asking you to install software *Invalid file hash (possible download corruption) -261 *Download Error -228

Question owner

On the following image you can see the error which occured for any add on install i clicked. I am installing them through the add ons window. I am not seeing any of the messages you have listed.

On the following image you can see the error which occured for any add on install i clicked. I am installing them through the add ons window. I am not seeing any of the messages you have listed.
Moses
  • Moderator
459 solutions 3602 answers

Can you try to reset Firefox to see if that helps?

You can also try to create a new profile if Resetting doesn't work.

Can you try to reset Firefox to see if that helps? *[https://support.mozilla.org/en-US/kb/reset-firefox-easily-fix-most-problems?esab=a&s=reset&r=2&as=s Reset Firefox] You can also try to create a new profile if Resetting doesn't work. *[https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles#w_creating-a-profile Create a new profile]

Question owner

Resetting didnt work nor did changing profile. Attached you'll see a pic of the Welcome screen which is also affected by the same issue. Error while downloading still occurs.

Resetting didnt work nor did changing profile. Attached you'll see a pic of the Welcome screen which is also affected by the same issue. Error while downloading still occurs.
Moses
  • Moderator
459 solutions 3602 answers

Err...Welcome screen isn't supposed to do that. You might have malware. You can try these free programs to scan for malware, which work with your existing antivirus software:

Microsoft Security Essentials is a good permanent antivirus for Windows 7/Vista/XP if you don't already have one.

Further information can be found in the Troubleshoot Firefox issues caused by malware article.

Err...Welcome screen isn't supposed to do that. You might have malware. You can try these free programs to scan for malware, which work with your existing antivirus software: * [http://www.microsoft.com/security/scanner/default.aspx Microsoft Safety Scanner] * [http://www.malwarebytes.org/products/malwarebytes_free/ MalwareBytes' Anti-Malware] * [http://support.kaspersky.com/faq/?qid=208283363 TDSSKiller - AntiRootkit Utility] * [http://www.surfright.nl/en/hitmanpro/ Hitman Pro] * [http://www.eset.com/us/online-scanner/ ESET Online Scanner] [http://windows.microsoft.com/MSE Microsoft Security Essentials] is a good permanent antivirus for Windows 7/Vista/XP if you don't already have one. Further information can be found in the [[Troubleshoot Firefox issues caused by malware]] article.

Question owner

Thanks a lot, a really appreciate the help. I ll try to figure it out and ill get back to you if i stay stuck.

Thanks again!

Thanks a lot, a really appreciate the help. I ll try to figure it out and ill get back to you if i stay stuck. Thanks again!
cor-el
  • Top 10 Contributor
  • Moderator
16467 solutions 148547 answers

Try to remove all data stored in Firefox from that domain via "Forget About This Site" in the right-click context menu of an history entry ("History > Show All History" or "View > Sidebar > History") or via the about:permissions page.
You can visit a page on the Add-ons website if you do not find an history entry.

Using "Forget About This Site" will remove all data stored in Firefox from that domain like bookmarks, cookies, passwords, cache, history, and exceptions, so be cautious and if you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of the involved files.

It doesn't have any lasting effect, so if you revisit such a 'forgotten' website then data from that website will be saved once again.

Try to remove all data stored in Firefox from that domain via "Forget About This Site" in the right-click context menu of an history entry ("History > Show All History" or "View > Sidebar > History") or via the about:permissions page.<br /> You can visit a page on the Add-ons website if you do not find an history entry. * https://addons.mozilla.org/firefox Using "Forget About This Site" will remove all data stored in Firefox from that domain like bookmarks, cookies, passwords, cache, history, and exceptions, so be cautious and if you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note. You can't recover from this 'forget' unless you have a backup of the involved files. It doesn't have any lasting effect, so if you revisit such a 'forgotten' website then data from that website will be saved once again.

Question owner

The problem persist after the "forget". The addons page continues to reload as is no matter which link i click. The different links do appear on the history list however they have broken icons.

The problem persist after the "forget". The addons page continues to reload as is no matter which link i click. The different links do appear on the history list however they have broken icons.
cor-el
  • Top 10 Contributor
  • Moderator
16467 solutions 148547 answers

Do you see any evidence of blocked content if you check that in the Web Console (Firefox/Tools > Web Developer) on the Network tab.
You need to reload the page to build the network log.

Do you see any evidence of blocked content if you check that in the Web Console (Firefox/Tools > Web Developer) on the Network tab.<br /> You need to reload the page to build the network log. *https://developer.mozilla.org/Tools/Web_Console

Question owner

This is what i get:

This is what i get:
cor-el
  • Top 10 Contributor
  • Moderator
16467 solutions 148547 answers

It appears that no content from addons.cdn.mozilla.net is downloaded, so make sure that you aren't blocking content, either in Firefox or by security software.

Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) as a test to see if this helps.

It appears that no content from addons.cdn.mozilla.net is downloaded, so make sure that you aren't blocking content, either in Firefox or by security software. Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) as a test to see if this helps. *http://www.bleepingcomputer.com/tutorials/how-to-start-windows-in-safe-mode/
Visions123 2 solutions 13 answers

Ray, have you found the solution yet? I installed Firefox on a new machine yesterday and I'm experiencing the same exact problem. I'd been using the browser for years on the old machine (Windows XP) with complete success. Had to get a new machine because of the end-of-support issue, so I don't know if this is a Windows 7 problem.

Ray, have you found the solution yet? I installed Firefox on a new machine yesterday and I'm experiencing the '''same exact problem'''. I'd been using the browser for years on the old machine (Windows XP) with complete success. Had to get a new machine because of the end-of-support issue, so I don't know if this is a Windows 7 problem.