Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Unable to play Sky News videos with Firefox

more options

Can play BBC news videos. I have removed Ad block plus to no avail I have un checked block pop ups I have deleted all history and cache from Firefox. Sky News videos play on Internet Explorer. I have all the latest updates. I unchecked Hardware acceleration but to no avail. My Flash player is version 12.

All Replies (17)

more options

Is this the site in question? Videos on this site should play in Flash Player if it's enabled, or the HTML5 player if it's not.

According to your system details, Adblock Plus is still installed. There's no need to remove it though. Just click the Adblock Plus icon on the toolbar and choose Disable Everywhere, then reload the page. If the video then plays, troubleshoot Adblock Plus issues as described below.

If the video still won't play with Adblock Plus disabled, does it play when you start Firefox with add-ons disabled?

more options

Your System Details List shows that you have a user.js file in the profile folder to initialize prefs each time Firefox starts.

The user.js file is only present if you or other software has created this file and normally it wouldn't be there. You can check its content with a plain text editor (right-click: Open with) if you didn't create this file yourself.

The user.js file is read each time Firefox is started and initializes preferences to the value specified in this file, so preferences set via user.js can only be changed temporarily for the current session.

You can delete a possible user.js file and numbered prefs-##.js files and rename (or delete) the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in the current Firefox release.

You can use this button to go to the currently used Firefox profile folder:

  • Help > Troubleshooting Information > Profile Director: Show Folder (Linux: Open Director; Mac: Show in Finder)
more options

Thanks for that. No luck. I had disabled Adblock to no avail and all add ons but still couldn`t play Sky News videos

more options

I also reset all preferences as you instructed but still no luck.

more options

In addition to clearing the cache, also try deleting cookies from the site in question, and all Flash cookies.

  1. How to clear the Firefox cache.
  2. How to delete cookies from specific sites.
  3. Open the Windows Control Panel.
  4. In the search box, type Flash Player
  5. In the search results, click the Flash Player (32-bit) icon.
  6. In the Flash Player Settings Manager window that opens, click the Storage tab.
  7. Click the Delete All button.
  8. Check "Delete All Site Data and Settings", then click the Delete Data button.

Exactly what happens when you try to play the aforementioned video? Is there an error message, an empty space where the video should be, or something else? Maybe attach a screenshot that illustrates the problem.

Is the behavior different from when you load the page while Flash Player is set to Always Activate versus when it's set to Never Activate? You can control the plug-in status in the Add-ons Manager, Plugins section. It's listed as "Shockwave Flash". You need to reload any open pages for the change to take effect.
(more fine-grained control is possible, but it's not worth getting into just for the sake of testing)

more options

Thank you. Firstly I cleared all the Flash info as you asked me to. The Sky News videos still did not play.

I then changed the always activate to never activate of the Flash Player in Firefox and the Sky News videos now play.

Maybe you could explain how could that be ?

Thank you so much for your help.

Regards Rod

more options

If you disable the Flash player then web pages can send code to use the HTML5 media player instead.
You should see the context menu of the HTML5 media player if you right-click the player area.

It could be possible that you have a content blocking extension active or are otherwise blocking this Flash content if it isn't working with the Shockwave Flash plugin enabled.

You can inspect and manage the permissions for the domain in the currently selected tab via these steps:

  • Click the "Site Identity Button" (globe/padlock) on the location bar
  • Click "More Information" to open "Tools > Page Info" with the Security tab selected
  • Go to the Permissions tab (Tools > Page Info > Permissions) to check the permissions for the domain in the currently selected tab
more options

I can not find the globe/padlock there for can not check permissions, could you lead me in the right direction ? Thanks.

more options

You can also look in "Tools > Page Info > Permissions" as posted above.


See:

more options

Found the permissions but what must I do there?

Can`t play Sky News videos with Flash Player on or off.

Can you use Team Viewer ?

more options

RodSeed wrote:

I then changed the always activate to never activate of the Flash Player in Firefox and the Sky News videos now play. […]
Can`t play Sky News videos with Flash Player on or off.

So it worked without Flash Player once, but then even that stopped working?

cor-el wrote:

It could be possible that you have a content blocking extension active or are otherwise blocking this Flash content if it isn't working with the Shockwave Flash plugin enabled.

RodSeed wrote:

I had disabled Adblock to no avail and all add ons but still couldn`t play Sky News videos
more options

So what do I do next ?

more options

I can play BBC videos but not Sky News or CNN, I am at a loss now having done everything. Cor-el could we do Team Veiwer ?

Rod

more options

Hi Gingerbread man, I am still stuck with the above problem, could we do Team Viewer?

more options

It seems you've mistakingly marked one of my earlier replies as the solution. You should undo that; people who try to help will avoid this thread otherwise.

There's a new version of Flash Player available. Try a clean install as follows, then perform the tests at the end and post back the results.

  1. From the following page, save the uninstaller somewhere handy, like the desktop.
  2. From the following page, save the installer for other browsers. If you also use Flash Player in Internet Explorer, also save the ActiveX version.
  3. Exit all applications.
  4. Run the uninstaller.
  5. In Windows Explorer, try to open the following folders. If they still exist, delete them manually.
    • C:\Windows\system32\Macromed\Flash\
    • C:\Windows\SysWOW64\Macromed\Flash\
    • %AppData%\Adobe\Flash Player\
    • %AppData%\Macromedia\Flash Player\
  6. Restart your computer.
  7. Run the installer for other browsers.
  8. Run the ActiveX installer if you downloaded it.

  1. Open the Add-ons Manager (Ctrl+Shift+A), then the Plugins category. Set every plug-in EXCEPT Shockwave Flash to "Never Activate". This is a troubleshooting step and you should remember you may need to undo it later on.
  2. Do you see the bouncing Flash logo on the following page?
  3. Does the following YouTube video play? If yes, right-click it. Do you see "About Adobe Flash Player…" in the menu?
  4. Does the following Sky News video play? If not, how about when you click this direct link?
more options

Hi Gingerbread.

I did all you asked above. Answers to your question below.

Yes I do see the bouncing Flash logo.

Yes the Youtube video does play.

No the Sky News video does not play, when I click on the play the video logo the video screes goes black.

I can play Sky News videos from IE 11 I can play BBC news videos from Firefox.

Can you go onto Team Viewer so you can look ?

Thanks Rod

more options

Hello,

RodSeed wrote:

No the Sky News video does not play, when I click on the play the video logo the video screes goes black.

Neither one? Not the one on the web page, and not the direct link to the video either?

Please start Firefox in a brand new profile as described below. Don't install any add-ons and don't modify any preferences. Just load the aforementioned test video and check if it plays.

If the video does play in the new profile, return to your regular profile. The simplest thing to do at that stage is to Reset Firefox to discard all your add-ons and preferences, while retaining essential data like bookmarks and passwords.

RodSeed wrote:
Can you go onto Team Viewer so you can look ? 

Sorry, I don't think that's an option for me. And if the above doesn't help, I don't think I'll have any further suggestions either.