X
Tap here to go to the mobile version of the site.

Support Forum

How can I get Firefox to default to Unicode rather that Western ?

Posted

Firefox always loads in Western and all punctuation is gobbledygook. If I go to View and choose Unicode it straightens out. How can I select Unicode as a default?

Firefox always loads in Western and all punctuation is gobbledygook. If I go to View and choose Unicode it straightens out. How can I select Unicode as a default?

Additional System Details

Installed Plug-ins

  • thinkorswim loader
  • thinkDesktop configuration loader
  • Shockwave Flash 12.0 r0
  • Google Update
  • Next Generation Java Plug-in 10.51.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • 5.1.20913.0
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.8
  • Citrix Online App Detector Plugin
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • AlternaTIFF v2.0.4
  • ActiveTouch General Plugin Container Version 105
  • CANON iMAGE GATEWAY Album Plugin Utility Module for IJ

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0

More Information

Gingerbread Man 403 solutions 1537 answers

Can you post an example link?

It's usually websites that tell Firefox which encoding to use to display the page. There are two ways to do this, the first of which takes precedence over the other:

  1. The Content-Type header. You can use the Web Console to examine the response header for the page request (e.g. GET support.mozilla.org…).
  2. A meta tag in the page source. You can right-click the page, choose View Page Info, then General. The text box in the middle of the window will list any relevant information.

The issue is that if the site specifies an incorrect encoding, then Firefox will use it, resulting in garbled text. The character encoding setting under Options - Content - Advanced only affects sites that don't specify any sort of encoding at all.
When no encoding is specified, you can usually get better results by having Firefox guess the encoding. To do that, click the orange Firefox button, open the Web Developer submenu, then the Character Encoding submenu, then the Auto-Detect submenu, and lastly choose Universal.

Can you post an example link? It's usually websites that tell Firefox which encoding to use to display the page. There are two ways to do this, the first of which takes precedence over the other: # The ''Content-Type'' header. You can use '''[https://developer.mozilla.org/en-US/docs/Tools/Web_Console the Web Console]''' to examine the response header for the page request (e.g. GET support.mozilla.org…). # A ''meta'' tag in the page source. You can right-click the page, choose View Page Info, then General. The text box in the middle of the window will list any relevant information. The issue is that if the site specifies an incorrect encoding, then Firefox will use it, resulting in garbled text. The character encoding setting under '''[[Settings for fonts, languages, pop-ups, images and JavaScript|Options - Content - Advanced]]''' only affects sites that don't specify any sort of encoding at all.<br> When no encoding is specified, you can usually get better results by having Firefox guess the encoding. To do that, click the orange '''Firefox button''', open the '''Web Developer''' submenu, then the '''Character Encoding''' submenu, then the '''Auto-Detect''' submenu, and lastly choose '''Universal'''.
cor-el
  • Top 10 Contributor
  • Moderator
17466 solutions 157836 answers

Can you attach a screenshot?

Use a compressed image type like PNG or JPG to save the screenshot.


If you use extensions (Firefox/Tools > Add-ons > Extensions) that can block content (e.g. Adblock Plus, NoScript, Flash Block, Ghostery) then make sure that such extensions aren't blocking content.

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window.

What font is used for this text if you check that in the built-in Inspector (right-click: "Inspect Element") and go to the Font tab in the right pane?


Try to set the gfx.content.azure.enabled pref to false or if this didn't help disable Direct2D by setting the gfx.direct2d.disabled pref to true on the about:config page and leave hardware acceleration otherwise enabled.

That way you still have the benefit from hardware acceleration, but may not suffer from rendering issues.

Can you attach a screenshot? *http://en.wikipedia.org/wiki/Screenshot *https://support.mozilla.org/kb/how-do-i-create-screenshot-my-problem Use a compressed image type like PNG or JPG to save the screenshot. ---- If you use extensions (Firefox/Tools > Add-ons > Extensions) that can block content (e.g. Adblock Plus, NoScript, Flash Block, Ghostery) then make sure that such extensions aren't blocking content. Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance). *Do NOT click the Reset button on the Safe Mode start window. *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes ---- What font is used for this text if you check that in the built-in Inspector (right-click: "Inspect Element") and go to the Font tab in the right pane? ---- Try to set the gfx.content.azure.enabled pref to false or if this didn't help disable Direct2D by setting the gfx.direct2d.disabled pref to true on the about:config page and leave hardware acceleration otherwise enabled. That way you still have the benefit from hardware acceleration, but may not suffer from rendering issues. *https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration
user801695 1 solutions 3 answers

When no encoding is specified, you can usually get better results by having Firefox guess the encoding. To do that, click the orange Firefox button, open the Web Developer submenu, then the Character Encoding submenu, then the Auto-Detect submenu, and lastly choose Universal.

And what do you do when the Auto-Detect submenu only has the options: off, Japanese, Russian, Ukrainian?

In fact, when using the preferences menu, and its submenu contents--fonts, under the tab "character encoding for legacy content" -- "fallback character encoding" Unicode is not even present on that list. Which is a problem.

''When no encoding is specified, you can usually get better results by having Firefox guess the encoding. To do that, click the orange Firefox button, open the Web Developer submenu, then the Character Encoding submenu, then the Auto-Detect submenu, and lastly choose Universal. '' And what do you do when the Auto-Detect submenu only has the options: off, Japanese, Russian, Ukrainian? In fact, when using the preferences menu, and its submenu contents--fonts, under the tab "character encoding for legacy content" -- "fallback character encoding" Unicode is not even present on that list. Which is a problem.
Gingerbread Man 403 solutions 1537 answers

Auto-detect: Universal has been removed in Firefox 28, which was released after my previous post (bug report 805374 was responsible, I think).

Please provide an example of a problematic web page. As I said, the server or web page should specify the correct encoding. So you don't normally need to worry about the character encoding at all. You can override it with the following add-on.

Auto-detect: Universal has been removed in Firefox 28, which was released after my previous post (bug report 805374 was responsible, I think). Please provide an example of a problematic web page. As I said, the server or web page should specify the correct encoding. So you don't normally need to worry about the character encoding at all. You can override it with the following add-on. * https://addons.mozilla.org/firefox/addon/charset-switcher/