Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

browser.cache.check_doc_frequency=1 doesn't work

  • 10 replies
  • 5 have this problem
  • 295 views
  • Last reply by jscher2000

more options

Hi guys, running FF27.01 on W7SP1.

I have a lot of tabs open and I set FF to reopen them at every launch, my problem is that FF hardly ever checks whether those webpages were updated when I reopen it....Opera, Chrome & IE do it, why not FF? Who could possibly want to read an outdated webpage?

So I did set "browser.cache.check_doc_frequency" to "1"(I tried all possibilities actually), now FF is kind enough to check whether the webpage was updated on some sites....very few sites actually.

This is a known issue from what I found running a google search and the solution was either to clear the cache when FF closes or to use Chrome...I don't like either of those two options.

This is my problem: https://support.mozilla.org/en-US/questions/754829

Is this a bug? Am I missing something here?

Hope you can help, I'm getting tired of being forced to manually refresh every tab :(

All Replies (10)

more options

Hmm, this is a guess: Have you tried clearing the cache just once to see whether that helps? I think it's possible that the change to "browser.cache.check_doc_frequency" might not take full effect until after you do that.

more options

Thanks for the swift reply.

I indeed forgot to mention that I cleared the cache on several occasions and this option has never fully worked....when not set to 1, no site ever updates automatically and when set to 1 very few sites do.

As explained here: http://www.imasuper.com/2008/10/07/firefox-caching-get-latest-page-every-time/

"Internet Explorer has a fantastic Web Cache option in Tools > Internet Options > Browsing History > Settings > called “Check for newer versions of Stored Pages:’. This option lets you override Internet Explorers smart caching option."

I want this exact same option to work in FF, and browser.cache.check_doc_frequency=1 doesn't do it for me in FF27.01 =/

I run a few extensions such as Ghostery but disabling them doesn't help.

more options

Does this same failure to refresh occur if you close a page and then open it again during the same session, or is the problem specific to restoring a previous session?

more options

The browser.cache.check_doc_frequency pref doesn't have effect when starting Firefox and reopening pages automatically, but should work otherwise during the current session.
I'm seeing this as well with some pages.
This is likely caused by the cache headers that are part of the HTTP response headers.

The only way to prevent this would be to disable the disk cache by using "Clear history when Firefox closes" to clear the disk cache, but that setting is not really recommended.

more options

OK, that's what I thought...so Firefox is a great browser if you want to read old outdated webpages and the only fixes are to clear the cache on exit or use another browser. I really wonder how this broken design got through QA and I can only hope that somebody at Mozilla will realize how much of a failure this is.

Is there any way I could get them to acknowledge this behavior as a bug?

PS: humm, apparently nobody cares that "browser.cache.check_doc_frequency" is completely broken: https://bugzilla.mozilla.org/show_bug.cgi?id=736230

I guess it's time to install Chrome? =(

Modified by leeperry

more options

This could be the philosophy of "Restore Previous Session": literally speaking, you go back what you had at that point in time.

If you decide you don't like Chrome, you could consider an extension or userscript as a workaround. (I'm not aware of anything particular that addresses the scenario of post-session-restore reloads.)

more options

It makes no sense to allow the browser to remember the open tabs from the previous session, add a hidden "browser.cache.check_doc_frequency=1" configuration option and ignore it altogether.

Whatever IE, Chrome or Opera are able to remember the open tabs from the previous session and chech whether they've been updated.....it's hard to believe that the FF team finds the contrary acceptable?

I couldn't locate any extension that would get FF to stop living in the past, I guess I'll install Chrome or Opera as it seems that this bug will never be fixed. Too bad I really like FF but manual refreshes are getting old.

But it's definitely a bug as setting this option to "1" makes some webpages(head-fi.org for instance) auto-update but not others(forum.doom9.org), something's fishy in the HTTP headers checks.

Modified by leeperry

more options

Just thinking out loud, I think a userscript would need to:

  • inject a pageshow event listener into every page to call your reload function; this runs when you show a page from cache, unlike a load event listener
  • inject a reload function with a time cut-off (e.g., if document.lastModified was less than 15 minutes ago, don't reload)

I haven't tested this idea.

Extensions have more sophisticated access, but I'm not familiar with the details.

more options

Well it's a bug, it should be fixed. How can I post an official bug report? And get someone to look at it if any possible ^^

more options

Hi leeperry, you can post a new bug here: https://bugzilla.mozilla.org/

I don't know how bugs get prioritized. If the current behavior is considered a "regression", i.e., it was an unintentional loss of functionality compared with an earlier version, that might get it faster consideration.