X
Tap here to go to the mobile version of the site.

Support Forum

Firefox 27.0.1 is using up to 500,000k of my memory!!! Why and how do I fix this?

Posted

I have Firefox. And sometimes when I'm trying to watch a video, the video lags immensely! So I went to task manager to see how much memory its using. And it's using a whopping 480,000k!!! I have a basic theme and very basic addons. Nothing fancy. Almost as if it were a clean install. How do I make it so it doesn't use up all my memory? I have 8 gb ram but somehow it still gets the best of it.

I have Firefox. And sometimes when I'm trying to watch a video, the video lags immensely! So I went to task manager to see how much memory its using. And it's using a whopping 480,000k!!! I have a basic theme and very basic addons. Nothing fancy. Almost as if it were a clean install. How do I make it so it doesn't use up all my memory? I have 8 gb ram but somehow it still gets the best of it.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 12.0 r0
  • iTunes Detector Plug-in
  • Pando Web Plugin
  • 5.1.20913.0
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.8
  • Unity Player 4.2.0f4
  • LogMeIn, Inc. Remote Access Components
  • 2.1.7
  • A plugin to detect whether the Adobe Application Manager is installed on this machine.
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • VLC media player Web Plugin 2.0.0-rc
  • Intel web components updater - Installs and updates the Intel web components
  • Intel web components for Intel® Identity Protection Technology
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0

More Information

Diego Victor
  • Top 25 Contributor
  • Moderator
631 solutions 4024 answers

Chosen Solution

Hello, When this happens try clear your history: *[https://support.mozilla.org/en-US/kb/remove-recent-browsing-search-and-download-history Clear recent history] Also: *[https://support.mozilla.org/en-US/kb/firefox-uses-too-many-cpu-resources-how-fix Firefox uses too many CPU resources ] *[https://support.mozilla.org/en-US/kb/firefox-uses-too-much-memory-ram Firefox uses too much memory (RAM)] *[http://www.mozilla.org/en-US/plugincheck/ Check plugins] *[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Firefox in safe mode]

Question owner

I have it clearing everything except cookies when I quit Firefox.

I have it clearing everything except cookies when I quit Firefox.
George Matthew 0 solutions 7 answers

Some problems with Flash video playback can be resolved by disabling hardware acceleration in your Flash Player settings. (See this article for more information on using the Flash plugin in Firefox).

To disable hardware acceleration in Flash Player:

  1. Go to this Adobe Flash Player Help page.
  2. Right-click on the Flash Player logo on that page.
  3. Click on Settings in the context menu. The Adobe Flash Player Settings screen will open.
  4. Click on the icon at the bottom-left of the Adobe Flash Player Settings window to open the Display panel.

    fpSettings1.PNG
  5. Remove the check mark from Enable hardware acceleration.
  6. Click Close to close the Adobe Flash Player Settings Window.
  7. Restart Firefox.

This Flash Player Help - Display Settings page has more information on Flash Player hardware acceleration, if you're interested.

Does this solve the problem? Let us know.

Some problems with Flash video playback can be resolved by disabling hardware acceleration in your Flash Player settings. (See [[Flash Plugin - Keep it up to date and troubleshoot problems|this article]] for more information on using the Flash plugin in Firefox). To disable hardware acceleration in Flash Player: #Go to this [http://helpx.adobe.com/flash-player/kb/video-playback-issues.html#main_Solve_video_playback_issues Adobe Flash Player Help page]. #Right-click on the Flash Player logo on that page. #Click on '''Settings''' in the context menu. The Adobe Flash Player Settings screen will open. # Click on the icon at the bottom-left of the Adobe Flash Player Settings window to open the Display panel. <br/> <br/>[[Image:fpSettings1.PNG]] <br/> # Remove the check mark from '''Enable hardware acceleration'''. # Click '''Close''' to close the Adobe Flash Player Settings Window. # Restart Firefox. This [http://www.macromedia.com/support/documentation/en/flashplayer/help/help01.html Flash Player Help - Display Settings page] has more information on Flash Player hardware acceleration, if you're interested. Does this solve the problem? Let us know.