X
Tap here to go to the mobile version of the site.

Support Forum

Firefox doesn't save password

Posted

Firefox does not remember my password even after I click remember password on all of the websites I visit. I recently installed a new computer and copied my old profile folder into the new firefox profile folder. I am using newest version of firefox.

Also, all of the Gmail accounts are deleted when I associate different Gmail accounts to a list. But the autocomplete for my username still works.

Firefox does not remember my password even after I click remember password on all of the websites I visit. I recently installed a new computer and copied my old profile folder into the new firefox profile folder. I am using newest version of firefox. Also, all of the Gmail accounts are deleted when I associate different Gmail accounts to a list. But the autocomplete for my username still works.

Modified by potato123

Chosen solution

Do you see any passwords in the Password Manager?

It is possible that there is a problem with the key3.db and signons.sqlite files that store the encrypted names and passwords in Firefox.
Rename the key3.db and signons.sqlite files in the Firefox profile folder.
You can add .old to the file names (key3.db.old and signons.sqlite.old) or move them to another folder to make it possible to undo the action.
You need to set a new Master Password after renaming or deleting key3.db and all currently saved passwords are lost.
If that has worked then you can remove the renamed files that are no longer needed.
Otherwise you can rename the files to their previous names (signons.sqlite and key3.db).

See:

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Google Update
  • Shockwave Flash 12.0 r0
  • iTunes Detector Plug-in
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.06
  • Intel web components for Intel® Identity Protection Technology
  • Intel web components updater - Installs and updates the Intel web components
  • 5.1.20913.0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
17673 solutions 159870 answers

Do you mean names and passwords in the Password Manager or do you mean that you are no longer logged on to (remembered by) websites after closing and restarting Firefox?

There is a difference between remembering the name and password in the Password Manager and a "remember me" check box on a web page to log you in automatically.
The latter usually involves the creation of a special "remember me" cookie that is stored on your computer and that is send to the server.
If that "remember me" cookie is removed or gets corrupted or is not send to the server then the server won't remember you anymore and you need to sign in once again.

You can inspect and manage the permissions the domain of the currently selected tab via these steps:

  • Click the "Site Identity Button" (globe/padlock) on the location bar
  • Click "More Information" to open the "Page Info > Security" window
  • Go to the Permissions tab (Tools > Page Info > Permissions) to check the permissions the domain of the currently selected tab
Do you mean names and passwords in the Password Manager or do you mean that you are no longer logged on to (remembered by) websites after closing and restarting Firefox? There is a difference between remembering the name and password in the Password Manager and a "remember me" check box on a web page to log you in automatically.<br /> The latter usually involves the creation of a special "remember me" cookie that is stored on your computer and that is send to the server.<br /> If that "remember me" cookie is removed or gets corrupted or is not send to the server then the server won't remember you anymore and you need to sign in once again. * http://kb.mozillazine.org/Cookies * http://kb.mozillazine.org/Password_Manager You can inspect and manage the permissions the domain of the currently selected tab via these steps: *Click the "Site Identity Button" (globe/padlock) on the location bar *Click "More Information" to open the "Page Info > Security" window *Go to the Permissions tab (Tools > Page Info > Permissions) to check the permissions the domain of the currently selected tab

Question owner

Yes, I clicked remember me, but the passwords are never saved. On my old computer it saved the password such that the password autocompletes everytime I type in my username.

Yes, I clicked remember me, but the passwords are never saved. On my old computer it saved the password such that the password autocompletes everytime I type in my username.

Question owner

Also, it's not after closing firefox. Everytime I log out, it forgets my password.

Also, it's not after closing firefox. Everytime I log out, it forgets my password.
cor-el
  • Top 10 Contributor
  • Moderator
17673 solutions 159870 answers

Do you see that password in the Password Manager?

  • Tools > Options > Security: Passwords: "Saved Passwords" > "Show Passwords"

Do you keep cookies from those sites?

Make sure that you do not run Firefox in (permanent) Private Browsing mode (Never remember history).

  • Tools > Options > Privacy > Firefox will: "Use custom settings for history"
  • Deselect: [ ] "Always use private browsing mode"

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window.
Do you see that password in the Password Manager? *Tools > Options > Security: Passwords: "Saved Passwords" > "Show Passwords" Do you keep cookies from those sites? Make sure that you do not run Firefox in (permanent) Private Browsing mode (Never remember history). *https://support.mozilla.org/kb/Private+Browsing *Tools > Options > Privacy > Firefox will: "Use custom settings for history" *Deselect: [ ] "Always use private browsing mode" ---- Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance). *Do NOT click the Reset button on the Safe Mode start window. *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes

Question owner

There are no passwords in the "saved password" window.

I allow all cookies on my settings. I specifically checked the page info and it says the cookie is allowed for their website, but there are no passwords saved for the websites.

I have private browsing off.

This is a new computer, and I actually have less extensions and add ons than my last computer. None of which, the extensions in my last computer, gave me trouble when remembering password. I have only few of the same add ons on this computer than my last computer.

It is probably something having to do with copying and pasting my old profile folder to my new computer.

There are no passwords in the "saved password" window. I allow all cookies on my settings. I specifically checked the page info and it says the cookie is allowed for their website, but there are no passwords saved for the websites. I have private browsing off. This is a new computer, and I actually have less extensions and add ons than my last computer. None of which, the extensions in my last computer, gave me trouble when remembering password. I have only few of the same add ons on this computer than my last computer. It is probably something having to do with copying and pasting my old profile folder to my new computer.

Modified by potato123

Question owner

I tried safe mode and the passwords are still not saved, there aren't any under security's tab and "saved passwords" window.

I tried safe mode and the passwords are still not saved, there aren't any under security's tab and "saved passwords" window.
cor-el
  • Top 10 Contributor
  • Moderator
17673 solutions 159870 answers

Do you get a key icon on the location bar and a possible dialog to save the password when you have entered the name and password?

Websites may be using autocomplete=off to prevent Firefox from saving form data like name and password.

You can remove autocomplete=off with a bookmarklet to make Firefox store form data like names and passwords.

Note that Firefox won't auto-fill saved form data automatically when autocomplete=off is used, so you need to double-click the empty name field to get a drop-down list.

Do you get a key icon on the location bar and a possible dialog to save the password when you have entered the name and password? Websites may be using autocomplete=off to prevent Firefox from saving form data like name and password. You can remove autocomplete=off with a bookmarklet to make Firefox store form data like names and passwords. *http://kb.mozillazine.org/User_name_and_password_not_remembered Note that Firefox won't auto-fill saved form data automatically when autocomplete=off is used, so you need to double-click the empty name field to get a drop-down list.

Question owner

autocomplete is on for all websites I am using. I know because I have no trouble remembering password on the same websites on my last computer two days ago. I installed RememberPass extension and it doesn't work either. No passwords are saved.

autocomplete is on for all websites I am using. I know because I have no trouble remembering password on the same websites on my last computer two days ago. I installed RememberPass extension and it doesn't work either. No passwords are saved.

Question owner

I tried bookmarking "remember password", then opening it after typing out my username and password before clicking submit. Then I log out and log in again. The password was not saved. Did this on different accounts for different websites.

I tried bookmarking "remember password", then opening it after typing out my username and password before clicking submit. Then I log out and log in again. The password was not saved. Did this on different accounts for different websites.

Modified by potato123

cor-el
  • Top 10 Contributor
  • Moderator
17673 solutions 159870 answers

Chosen Solution

Do you see any passwords in the Password Manager?

It is possible that there is a problem with the key3.db and signons.sqlite files that store the encrypted names and passwords in Firefox.
Rename the key3.db and signons.sqlite files in the Firefox profile folder.
You can add .old to the file names (key3.db.old and signons.sqlite.old) or move them to another folder to make it possible to undo the action.
You need to set a new Master Password after renaming or deleting key3.db and all currently saved passwords are lost.
If that has worked then you can remove the renamed files that are no longer needed.
Otherwise you can rename the files to their previous names (signons.sqlite and key3.db).

See:

Do you see any passwords in the Password Manager? It is possible that there is a problem with the key3.db and signons.sqlite files that store the encrypted names and passwords in Firefox.<br /> Rename the key3.db and signons.sqlite files in the Firefox profile folder.<br /> You can add .old to the file names (key3.db.old and signons.sqlite.old) or move them to another folder to make it possible to undo the action.<br /> You need to set a new Master Password after renaming or deleting key3.db and all currently saved passwords are lost.<br /> If that has worked then you can remove the renamed files that are no longer needed.<br /> Otherwise you can rename the files to their previous names (signons.sqlite and key3.db). See: * "Troubleshooting" in http://kb.mozillazine.org/Password_Manager

Question owner

Perfect, thank you so much. I knew something in my profile was corrupted, but didn't know what.

Thanks again, now I don't have to keep typing passwords.

Perfect, thank you so much. I knew something in my profile was corrupted, but didn't know what. Thanks again, now I don't have to keep typing passwords.
cor-el
  • Top 10 Contributor
  • Moderator
17673 solutions 159870 answers

You're welcome

You're welcome