X
Tap here to go to the mobile version of the site.

Support Forum

How to shut off the preloading of my quick links

Posted

I want to turn off the quick links from the recent 9-box layout that was added to firefox. It used to be just bookmark links, but now it's quite obvious that there is some sort of internet activity that occurs as those box links load. And Firefox is now using 210mb on a single tab.

If there is no way of turning that off, then i'm just going to find an older version of firefox and run it for the time being, because I just want no part of those box links working that way.

So if someone would be so kind to tell me how to turn it off, and not just hide the function, it would be appreciated.

I want to turn off the quick links from the recent 9-box layout that was added to firefox. It used to be just bookmark links, but now it's quite obvious that there is some sort of internet activity that occurs as those box links load. And Firefox is now using 210mb on a single tab. If there is no way of turning that off, then i'm just going to find an older version of firefox and run it for the time being, because I just want no part of those box links working that way. So if someone would be so kind to tell me how to turn it off, and not just hide the function, it would be appreciated.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.9 r900
  • DivX Web Player version 3.1.0.13
  • DivX VOD Helper Plug-in

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
12487 solutions 115209 answers

That content are thumbnails that are created from the disk cache (so shouldn't cause internet activity) and stored in the thumbnails folder in the same location as used for the disk cache (see the about:cache page via the location bar), but at a different level (replace the trailing \Cache\ to \thumbnails\).

You can create these Boolean prefs on the about:config page to prevent Firefox from generating thumbnails for the about:newtab page.

  • name: browser.pagethumbnails.capturing_disabled with value: true
  • name: pageThumbs.enabled with value: false

Delete the thumbnails folder in the Firefox profile folder to remove already stored web page thumbnails.

See also:

That content are thumbnails that are created from the disk cache (so shouldn't cause internet activity) and stored in the thumbnails folder in the same location as used for the disk cache (see the about:cache page via the location bar), but at a different level (replace the trailing \Cache\ to \thumbnails\). You can create these Boolean prefs on the about:config page to prevent Firefox from generating thumbnails for the about:newtab page. *name: <b>browser.pagethumbnails.capturing_disabled</b> with value: true *name: <b>pageThumbs.enabled</b> with value: false Delete the thumbnails folder in the Firefox profile folder to remove already stored web page thumbnails. See also: *http://kb.mozillazine.org/about:config

Question owner

First, I have Firefox set to delete all cache, as well as any passwords after closing.

Secondly, this has never happened prior to yesterday when I updated to 27.0.1

So if it's finding this in a folder, then it's finding it in a folder that shouldn't have anything saved, since I tell Firefox not to save anything, nevermind the fact that it only started with the new update.

First, I have Firefox set to delete all cache, as well as any passwords after closing. Secondly, this has never happened prior to yesterday when I updated to 27.0.1 So if it's finding this in a folder, then it's finding it in a folder that shouldn't have anything saved, since I tell Firefox not to save anything, nevermind the fact that it only started with the new update.

Modified by Tubes

cor-el
  • Top 10 Contributor
  • Moderator
12487 solutions 115209 answers

Did you find any thumbnails in the thumbnails folder?

See also this article about the New Tab page (about:newtab):


Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window.
Did you find any thumbnails in the thumbnails folder? See also this article about the New Tab page (about:newtab): *https://support.mozilla.org/kb/new-tab-page-show-hide-and-customize-top-sites ---- Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance). *Do NOT click the Reset button on the Safe Mode start window. *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes

Question owner

There is no thumbnail folder in my Profiles folder. I checked every single folder and sub folder in there, as well as searching for "thumbnail" in the folder search (windows 7) And yes, this is with "show hidden files and folders" selected.

There is no thumbnail folder in my Profiles folder. I checked every single folder and sub folder in there, as well as searching for "thumbnail" in the folder search (windows 7) And yes, this is with "show hidden files and folders" selected.

Modified by Tubes

Question owner

Also, I believe you're mistaken about the thumbnail situation in general. I have witnessed the thumbnail view in that shortcut box changing while I was viewing it. It was clearly updating, which would imply a live internet feed for this function, and not something saved from a previous usage.

Also, I believe you're mistaken about the thumbnail situation in general. I have witnessed the thumbnail view in that shortcut box changing while I was viewing it. It was clearly updating, which would imply a live internet feed for this function, and not something saved from a previous usage.
cor-el
  • Top 10 Contributor
  • Moderator
12487 solutions 115209 answers

Are you sure that you hadn't visited that page in between?

Try to set the browser.newtab.preload pref to false on the about:config page.

Are you sure that you hadn't visited that page in between? Try to set the browser.newtab.preload pref to false on the <b>about:config</b> page.

Question owner

No i'm not, tbh.

But I did come up with something that seems to show that it does connect to the website.

I did a full computer search for thumbnails, and found the folder of them. Didn't seem to have anything to do with firefox, either. But those shortcut thumbnails were in there, so I deleted them. But I left that folder open, and then opened up the Firefox shortcut tab, and one by one they repopulated in both firefox, as well as the folder, all while I was watching.

That really seems like it's connecting to the internet to accomplish this, which I don't like.

At this point, i'm probably going to try turning that feature off like you posted, and see how it goes from there. But it's very unfortunate that this seems to have piggybacked in with the 27.0.1 update.

Not to mention, that FF is now using almost 3x as much memory as IE does with a single tab open.

No i'm not, tbh. But I did come up with something that seems to show that it does connect to the website. I did a full computer search for thumbnails, and found the folder of them. Didn't seem to have anything to do with firefox, either. But those shortcut thumbnails were in there, so I deleted them. But I left that folder open, and then opened up the Firefox shortcut tab, and one by one they repopulated in both firefox, as well as the folder, all while I was watching. That really seems like it's connecting to the internet to accomplish this, which I don't like. At this point, i'm probably going to try turning that feature off like you posted, and see how it goes from there. But it's very unfortunate that this seems to have piggybacked in with the 27.0.1 update. Not to mention, that FF is now using almost 3x as much memory as IE does with a single tab open.

Modified by Tubes

cor-el
  • Top 10 Contributor
  • Moderator
12487 solutions 115209 answers

In which location did you find those thumbnails?

In which location did you find those thumbnails?

Question owner

I just opened My Computer > C drive, then typed thumbnails into the upper right search window. It actually pulls up 5 thumbnail folders, but only the top 3 have the thumbnails in them. When you delete the thumbnails from one of them, it deletes them from all 3.

Interestingly, I kept the folder open as I logged off, and it did indeed delete all of them the way I have firefox set to do.

But as soon as I re-open the FF shortcut tab, the folder repopulates again, along with the shortcut tab windows, of which I have 8 set to various shortcuts.

So this really seems like it's firefox connecting to the internet to accomplish this. Which could be part of why FF is using so much memory.

I just opened My Computer > C drive, then typed thumbnails into the upper right search window. It actually pulls up 5 thumbnail folders, but only the top 3 have the thumbnails in them. When you delete the thumbnails from one of them, it deletes them from all 3. Interestingly, I kept the folder open as I logged off, and it did indeed delete all of them the way I have firefox set to do. But as soon as I re-open the FF shortcut tab, the folder repopulates again, along with the shortcut tab windows, of which I have 8 set to various shortcuts. So this really seems like it's firefox connecting to the internet to accomplish this. Which could be part of why FF is using so much memory.
cor-el
  • Top 10 Contributor
  • Moderator
12487 solutions 115209 answers

Do the thumbnails also get (re)created if you clear the disk cache (see about:cache for the location)?

Do the thumbnails also get (re)created if you clear the disk cache (see about:cache for the location)?

Question owner

Is that supposed to be on the about:config page? Because I don't have either one of these in there.

name: browser.pagethumbnails.capturing_disabled with value: true

name: pageThumbs.enabled with value: false

There's actually nothing even close to the pagethumbs one, but there's one close to the first one.

Is that supposed to be on the about:config page? Because I don't have either one of these in there. name: browser.pagethumbnails.capturing_disabled with value: true name: pageThumbs.enabled with value: false There's actually nothing even close to the pagethumbs one, but there's one close to the first one.
cor-el
  • Top 10 Contributor
  • Moderator
12487 solutions 115209 answers

Those prefs are hidden prefs and do not appear on the about:config page unless you create them, so you need to create new Boolean prefs via the right-click context menu with those names and values.

Those prefs are hidden prefs and do not appear on the <b>about:config</b> page unless you create them, so you need to create new Boolean prefs via the right-click context menu with those names and values.

Helpful Reply

Oh ok, I get it now. But that still didn't work. I deleted the thumbnails, closed FF, did a reboot, and as soon as I opened up the shortcut page, the thumbnails immediately started repopulating again.

I then tried one last idea, and deleted every single shortcut, and then closed FF to let cache clear, then rebooted and added a youtube shortcut. Then I one more time closed FF, and opened it again to the shortcut tab, and the youtube thumbnail instantly repopulated.

So i'm just going to go ahead and delete FF and install an older version for now.

Thanks anyway for your help.

Oh ok, I get it now. But that still didn't work. I deleted the thumbnails, closed FF, did a reboot, and as soon as I opened up the shortcut page, the thumbnails immediately started repopulating again. I then tried one last idea, and deleted every single shortcut, and then closed FF to let cache clear, then rebooted and added a youtube shortcut. Then I one more time closed FF, and opened it again to the shortcut tab, and the youtube thumbnail instantly repopulated. So i'm just going to go ahead and delete FF and install an older version for now. Thanks anyway for your help.

Modified by Tubes

SoluF 0 solutions 1 answers

Are you sure you set the new about:config preference mentioned above correctly?

The following worked for me:

  1. Load about:config
  2. Right click anywhere and choose New > Boolean
  3. Name it 'browser.pagethumbnails.capturing_disabled'
  4. Set the value to true
  5. Restart Firefox and no more thumbnail prefetching

Also make sure that you have deleted any stored thumbnails from Appdata > Local > Mozilla > Firefox > Profiles > Profilename > thumbnails.

Are you sure you set the new about:config preference mentioned above correctly? The following worked for me: # Load about:config # Right click anywhere and choose New > Boolean # Name it 'browser.pagethumbnails.capturing_disabled' # Set the value to true # Restart Firefox and no more thumbnail prefetching Also make sure that you have deleted any stored thumbnails from Appdata > Local > Mozilla > Firefox > Profiles > Profilename > thumbnails.

Modified by SoluF