Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Dialog box pops up when refreshing pages

  • 12 replies
  • 3 have this problem
  • 2408 views
  • Last reply by Kanade_

more options

Basically, whenever I tried to refresh certain pages, a dialog box would pop up as you can see from the screenshot (http://i.imgur.com/yyVNkRE.png). It only happens for some sites (e.g http://ch.nicovideo.jp/portal/anime) and it happened straight after upgrading to 27.0.

I'm not sure if this is actually a problem or not but it's getting pretty annoying at the moment.

Thank you, help would be appreciated it.

Modified by Kanade_

Chosen solution

Do you have any content blocking extensions in Firefox or otherwise on your computer (security software) that might be modifying links or the HTTP response headers?

Read this answer in context 👍 1

All Replies (12)

more options

Hello, please see this help article Pop-up blocker settings, exceptions and troubleshooting

more options

You can try these steps in case of issues with web pages:

Reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • Hold down the Shift key and left-click the Reload button
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Command + Shift + R" (Mac)

Clear the cache and cookies only from websites that cause problems.

"Clear the Cache":

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox/Tools > Options > Privacy > Cookies: "Show Cookies"

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window.
more options

It's not one of those pop up ads.

I'm talking about dialog boxes such as when downloading, saving etc...

more options

Thank you for the reply cor-el.

I've tried all of those steps however the dialog box keeps popping up every time whenever I refresh the pages with the problem.

However, when I tried refreshing while bypassing the cache continually it won't pop up. I'm guessing there is something to do with website's cache.

Is there a way to fix this?

more options

Note that "application/octet-stream" is a generic content type that will make Firefox always offer to download and save the file.

What kind of file (link) are you trying to download or open?

more options

To be honest. I'm not really sure what its trying to download...

Also I don't know anything about source codes so I'm not sure what its trying to download/open.

more options

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window.
more options

"To be honest. I'm not really sure what its trying to download.."

I'm not a Firefox expert -- just waiting for help with my own problem. But I do know, that if you innocently browse to a website, and it tries to download something that you haven't asked for, it's probably not a reputable site, at the very least. And probably it's not a safe site at all. I would avoid visiting it!

I could be wrong, but I'm guessing it was probably a coincidence that it seemed to have started after an upgrade.

There are several security programs which will alert you when you visit an unsafe site. Some can even block them for you. One that I know of is McAfee SiteAdvisor.

more options

I've already tried it on safe mode and I just did it again though the results were same - dialog box pops up.

more options

I don't think the site (http://ch.nicovideo.jp/portal/anime) counts as "not a reputable site" as it's one of the popular sites in Japan. Think of it like Japanese youtube as the userbase and the content is pretty massive.

The fact that the problem is happening on one certain page/section of the site is pretty weird as other pages/services in that site doesn't suffer from such ordeal.

Modified by Kanade_

more options

Chosen Solution

Do you have any content blocking extensions in Firefox or otherwise on your computer (security software) that might be modifying links or the HTTP response headers?

more options

I have Kaspersky content blocking addon disabled though I think I found who the culprit is.

I recently installed Kaspersky Pure 3.0 and there is a feature called web anti virus which scans for web traffics and prevents dangerous scripts from running on my PC. I've lowered the security level of that feature to "low" and added the websites with problems to "trusted URLs" and boom... the problem is gone. I've uploaded the screenshot of the settings here if you want to have a look at it: http://i.imgur.com/FpF9OMx.png

Although feature itself is handy, it's causing such problem which I find it very annoying. Disabling it will make the program persistently tell me to enable it again so yeah...

That said, to prevent such problems to happen again, it seems like I need to add the sites to the trusted URLs. I think I'll ask Kaspersky official forum regarding to this feature as well as content blocker addon (some users reported that it slows down browsing).

Thank you very much for the help, I really appreciate it.