X
Tap here to go to the mobile version of the site.

Support Forum

Missing a plugin but when try to search for it , it won't find it.

Posted

I am trying to run a chatroom. Whenever I load the page, it says "A plugin is needed to display content" When I click that, it says to do "Java Runtime Environment" When I click next to have it run, it says not available and to try Manual Install. When I try that, nothing works. I've tried to search for that plugin and won't work. I was able to get on this chat site for months until I had to update java about 3 weeks ago. What can I do to fix this?

I am trying to run a chatroom. Whenever I load the page, it says "A plugin is needed to display content" When I click that, it says to do "Java Runtime Environment" When I click next to have it run, it says not available and to try Manual Install. When I try that, nothing works. I've tried to search for that plugin and won't work. I was able to get on this chat site for months until I had to update java about 3 weeks ago. What can I do to fix this?

Chosen solution

Your Java(TM) Platform SE 7 plugin isn't showing in your More System Details. Can you check whether it has become disabled (set to "Never Activate")?

Open the Add-ons page using either:

  • Ctrl+Shift+a
  • orange Firefox button (or Tools menu) > Add-ons

In the left column, click Plugins. Then scroll to the bottom to see whether Java is down there and if you find it, try changing to "Always Activate" or "Ask to Activate".

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Shockwave Flash 12.0 r0
  • npsitesafety (Official)
  • Shockwave Flash 11.9 r900
  • Google Update
  • Facebook Video Calling Plugin
  • 5.1.20913.0
  • McAfee MSS+ NPAPI Plugin
  • iTunes Detector Plug-in
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.3
  • NPWLPG

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0

More Information

Wesley Branton 435 solutions 4033 answers

To protect against potential Java vulnerabilities, Firefox now asks you to activate Java by default, for each website you visit that uses Java. When you see an "Activate Java" message box, simply click it to load the Java content normally.

Fx24-JavaActivate

If there is no visible area to activate Java content in the page, click the plugin icon in the address bar. In the message panel that opens, choose "Allow Now" to enable Java content temporarily.

Fx24-JavaAllowNow

The next time you visit the site or any other that uses Java you will see this message again. If you want to always activate Java for a particular site, you can use the "Allow and Remember" option shown above.

For more information about using Java in Firefox, see the articles How to allow Java on trusted sites and Use the Java plugin to view interactive content on websites.

Important: After activating Java, you may see a security prompt, asking you to confirm that you want to run Java, or you may see an "Application Blocked" message, depending on the website and your security settings in the Java Control Panel. These messages come from Java itself, not from Firefox.

For help with Java security prompts and "Application Blocked" messages, see the Java Help pages What should I do when I see a security prompt from Java? and Why are Java applications blocked by your security settings with the latest Java?

Does this solve your problem? Let us know.

To protect against potential Java vulnerabilities, Firefox now asks you to activate Java by default, for each website you visit that uses Java. When you see an "Activate Java" message box, simply click it to load the Java content normally. [[Image:Fx24-JavaActivate]] If there is no visible area to activate Java content in the page, click the plugin icon in the address bar. In the message panel that opens, choose "Allow Now" to enable Java content temporarily. [[Image:Fx24-JavaAllowNow]] The next time you visit the site or any other that uses Java you will see this message again. If you want to always activate Java for a particular site, you can use the "Allow and Remember" option shown above. For more information about using Java in Firefox, see the articles [[How to allow Java on trusted sites]] and [[Use the Java plugin to view interactive content on websites]]. '''Important:''' After activating Java, you may see a security prompt, asking you to confirm that you want to run Java, or you may see an "Application Blocked" message, depending on the website and your security settings in the [http://www.java.com/en/download/help/jcp_security.xml#control%20panel Java Control Panel]. These messages come from Java itself, not from Firefox. For help with Java security prompts and "Application Blocked" messages, see the Java Help pages [http://www.java.com/en/download/help/appsecuritydialogs.xml What should I do when I see a security prompt from Java?] and [http://www.java.com/en/download/help/java_blocked.xml Why are Java applications blocked by your security settings with the latest Java?] Does this solve your problem? Let us know.
cor-el
  • Top 10 Contributor
  • Moderator
16659 solutions 150573 answers

Your System Details List doesn't show the Java plugin

Do you see the Java plugin in Firefox/Tools > Add-ons > Plugins?

Note that Firefox is a 32 bit application, so you need to install the 32 bit Java version.

You can find the latest Java version on the Oracle website.

See Java Platform > Java SE 7U51 (JRE Download)


There are other things that need your attention.

Note that your System Details List shows multiple Flash plugins.

  1. Shockwave Flash 12.0 r0
  2. Shockwave Flash 11.9 r900

You can find the installation path of all plugins on the about:plugins page.

You can check the Flash player installation folder for multiple Flash player plugins and remove all (older) version(s) of the plugin (NPSWF32) and (re)install the latest Flash player.

  • (32 bit Windows) C:\Windows\System32\Macromed\Flash\
  • (64 bit Windows) C:\Windows\SysWOW64\Macromed\Flash\
Your System Details List doesn't show the Java plugin Do you see the Java plugin in Firefox/Tools > Add-ons > Plugins? Note that Firefox is a 32 bit application, so you need to install the 32 bit Java version. You can find the latest Java version on the Oracle website. See Java Platform > Java SE 7U51 (JRE Download) *http://www.oracle.com/technetwork/java/javase/downloads/index.html ---- There are other things that need your attention. Note that your System Details List shows multiple Flash plugins. # Shockwave Flash 12.0 r0 # Shockwave Flash 11.9 r900 You can find the installation path of all plugins on the <b>about:plugins</b> page. You can check the Flash player installation folder for multiple Flash player plugins and remove all (older) version(s) of the plugin (NPSWF32) and (re)install the latest Flash player. *(32 bit Windows) C:\Windows\System32\Macromed\Flash\ *(64 bit Windows) C:\Windows\SysWOW64\Macromed\Flash\
jscher2000
  • Top 10 Contributor
7875 solutions 64242 answers

Chosen Solution

Your Java(TM) Platform SE 7 plugin isn't showing in your More System Details. Can you check whether it has become disabled (set to "Never Activate")?

Open the Add-ons page using either:

  • Ctrl+Shift+a
  • orange Firefox button (or Tools menu) > Add-ons

In the left column, click Plugins. Then scroll to the bottom to see whether Java is down there and if you find it, try changing to "Always Activate" or "Ask to Activate".

Your Java(TM) Platform SE 7 plugin isn't showing in your More System Details. Can you check whether it has become disabled (set to "Never Activate")? Open the Add-ons page using either: * Ctrl+Shift+a * orange Firefox button (or Tools menu) > Add-ons In the left column, click Plugins. Then scroll to the bottom to see whether Java is down there and if you find it, try changing to "Always Activate" or "Ask to Activate".

Question owner

What's weird is when I go look at the plugins, Java isn't there. At all. I have tried to download/redownload/un install, etc a couple of times. I try to search for java and it's not on any plugin.

What's weird is when I go look at the plugins, Java isn't there. At all. I have tried to download/redownload/un install, etc a couple of times. I try to search for java and it's not on any plugin.

Question owner

I have seen that screen before and it is not what is popping up on the website. It says specifically "a plugin is needed to display content" and that is it. I try to get the plugin and it's not there/available.

I have seen that screen before and it is not what is popping up on the website. It says specifically "a plugin is needed to display content" and that is it. I try to get the plugin and it's not there/available.
cor-el
  • Top 10 Contributor
  • Moderator
16659 solutions 150573 answers

If Firefox doesn't find the Java plugin then it is possible that the Java installer didn't create the registry key that Firefox uses to scan for plugins.

64 bit Windows:

HKLM\Software\Wow6432Node\MozillaPlugins\@java.com/JavaPlugin,version=xx.xx.xx
If Firefox doesn't find the Java plugin then it is possible that the Java installer didn't create the registry key that Firefox uses to scan for plugins. 64 bit Windows: HKLM\Software\Wow6432Node\MozillaPlugins\@java.com/JavaPlugin,version=xx.xx.xx *http://kb.mozillazine.org/Java

Question owner

Here is ex 1-4 of what I see.

Here is ex 1-4 of what I see.

Question owner

last photo

last photo
jscher2000
  • Top 10 Contributor
7875 solutions 64242 answers

The Java (32-bit) Control Panel also has a setting not to run Java in your browsers. That might not be the problem, but no harm in checking.

Note: These attached images are from an older version of Java

The Java (32-bit) Control Panel also has a setting not to run Java in your browsers. That might not be the problem, but no harm in checking. ''Note: These attached images are from an older version of Java''

Modified by jscher2000

cor-el
  • Top 10 Contributor
  • Moderator
16659 solutions 150573 answers

Note that you sou still to remove that older Flash plugin like I posted above.

Did you check the registry, assuming that you did install the 32 bit Java version?

Note that you sou still to remove that older Flash plugin like I posted above. Did you check the registry, assuming that you did install the 32 bit Java version?

Question owner

I got it to work by "Configure Java" which appeared randomly lol (I swear) but doing what jscher2000 said, fixed it. THANK YOU THANK YOU!

I got it to work by "Configure Java" which appeared randomly lol (I swear) but doing what jscher2000 said, fixed it. THANK YOU THANK YOU!