Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox blurry web page text

  • 12 replies
  • 51 have this problem
  • 19606 views
  • Last reply by nicero

more options

When in Internet Explorer web page screen text is clear. The same web page is blurry when using Firefox (see attached - text in middle of screen). Could you tell me how to fix please.

Chosen solution

SOLVED (weird but solved)

I had the same problem on both my PCs (one with Windows 7, the other with Windows XP). I tried the above fixes without success:

  • zoom = zero
  • gfx.direct2d.disabled = true
  • hardware acceleration = disabled

I read that Open Sans displayed correctly in Firefox 17.0 so I downloaded the portable version as I wanted to post two snapshots of the issue (one with FF 17.0 and one with FF 29.0) hoping to find some help. (I did this on my Win7 PC)

I launched FF 17.0, went to a page that used Opens Sans and noticed that FF 17.0 actually displayed the font correctly. I took the snapshot and closed FF 17.0. I then opened the same link in FF 29.0 to get the second snapshot and... magically Open Sans displayed correctly in FF 29.0 too! (I restarted FF 29.0 and it's still working).

Present configuration is:

  • gfx.direct2d.disabled = false
  • hardware acceleration = enabled

After lauching (and then closing) FF 17.0 portable the issue in FF 29.0 had gone.

Absolutely don't know why. Experts may help us understand.

Read this answer in context 👍 1

All Replies (12)

more options

hello RalphB, you can attach a screenshot in a reply to your original post...

more options

Reset the page zoom on pages that cause problems.

  • View > Zoom > Reset (Ctrl+0 (zero); Command+0 on Mac)

Try to disable hardware acceleration in Firefox (you need to close and restart Firefox).

more options

Many thanks. This seems to have eliminated the problem.

more options

Many thanks. The problem now seems to have gone away.

more options

This was the problem. Hopefully, now gone ! Thank you for your help.

more options

I have the same problem. I have changed the zoom and disabled acceleration and it works on the Mozilla site. However, it doesn't work for most other websites..web mail, Facebook, etc. A strange thing I've noticed is that if I highlight text the problem goes away but only for the text I've highlighted. I have Firefox 27. Any other ideas???

more options

Hello tnsquirejay, The problem you have seems to be exactly as the one I was experiencing (highlighting etc). However, I do not have (or use) the other features which you mention and therefore I am unable to comment regarding this. I do hope that someone may have the solution for you. Needless to say, I will keep an eye on the forum.

more options

Note that Firefox stores the zoom settings per domain, so you may have to reset the page zoom on those pages as well.

Try to disable Direct2D by setting the gfx.direct2d.disabled pref to true on the about:config page and leave hardware acceleration otherwise enabled.

See also comment 414 in bug 812695:

You can try to uninstall Windows update KB2670838 if you have this update.

more options

Where do I change that setting? I can't find it.

more options

Is this about the page zoom or about the pref that is mentioned in comment 414 of the bug report?

The layout.paint_rects_separately pref doesn't exist by default and need to be created on the about:config page via the right-click context menu.

--- Use this to reset the page zoom for the page in the currently selected tab:

  • View > Zoom > Reset (Ctrl+0 (zero); Command+0 on Mac)
more options

I also have this problem after update to Firefox 28. is it bug from Firefox? My website that using Open Sans look blurry. What I must to do with the css? because not everyone know how to set about:config :(

please help

more options

Chosen Solution

SOLVED (weird but solved)

I had the same problem on both my PCs (one with Windows 7, the other with Windows XP). I tried the above fixes without success:

  • zoom = zero
  • gfx.direct2d.disabled = true
  • hardware acceleration = disabled

I read that Open Sans displayed correctly in Firefox 17.0 so I downloaded the portable version as I wanted to post two snapshots of the issue (one with FF 17.0 and one with FF 29.0) hoping to find some help. (I did this on my Win7 PC)

I launched FF 17.0, went to a page that used Opens Sans and noticed that FF 17.0 actually displayed the font correctly. I took the snapshot and closed FF 17.0. I then opened the same link in FF 29.0 to get the second snapshot and... magically Open Sans displayed correctly in FF 29.0 too! (I restarted FF 29.0 and it's still working).

Present configuration is:

  • gfx.direct2d.disabled = false
  • hardware acceleration = enabled

After lauching (and then closing) FF 17.0 portable the issue in FF 29.0 had gone.

Absolutely don't know why. Experts may help us understand.

Modified by nicero