X
Tap here to go to the mobile version of the site.

Support Forum

This thread was closed and archived. Please ask a new question if you need help.

How to shut-off or disable "plugin-container.exe"

Posted

I'm running XP on a lap-top that originally had Vista that didn't work as well and Firefox 26.0, up-to date. I have "Add-Ons" of; Adblock Plus 2.4.1, Advanced System Care 1.0 and NoScript 2.6.8.12

Ever since updating to 26.0 that damnable "plug-in container.exe" has been slowing down my web surfing and I'm constantly ending the process in task Manager. I want to disable or remove it completely with easy-to-read instructions - Not some of the 5-page "mumbo-jumbo" I've been reading for other "solutions". It has slowed me down and irritated me to the point of considering returning to I-E.

It has to go or I'm going.

I'm running XP on a lap-top that originally had Vista that didn't work as well and Firefox 26.0, up-to date. I have "Add-Ons" of; Adblock Plus 2.4.1, Advanced System Care 1.0 and NoScript 2.6.8.12 Ever since updating to 26.0 that damnable "plug-in container.exe" has been slowing down my web surfing and I'm constantly ending the process in task Manager. I want to disable or remove it completely with easy-to-read instructions - Not some of the 5-page "mumbo-jumbo" I've been reading for other "solutions". It has slowed me down and irritated me to the point of considering returning to I-E. It has to go or I'm going.

Chosen solution

Hi RadRon, as the name implies, plugin-container.exe is used to run plugins. This was created around the time of Firefox 3.6.4 to isolate plugins from firefox.exe because they were responsible for a large percentage of Firefox crashes. Placing them in plugin-container.exe prevened misbehaved plugins from taking down your entire Firefox session (at least, in theory it should do that).

So to return to your question of what might have caused your earlier problems with plugin-container.exe, it probably was a problem with the relevant plugin, and the most likely culprit is Flash. But since the error is gone, it's difficult to speculate on the confluence of circumstances that might have been responsible, or what alternative fixes might have helped.

Read this answer in context 3

Additional System Details

Installed Plug-ins

  • McAfee MSS+ NPAPI Plugin
  • Npdsplay dll

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:26.0) Gecko/20100101 Firefox/26.0

More Information

iamjayakumars 480 solutions 5891 answers

Hello,

Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that turns off some settings and disables most add-ons (extensions and themes).

(If you're using an added theme, switch to the Default theme.)

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu by clicking on the Restart with Add-ons Disabled... menu item:
FirefoxSafeMode

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

Once you get the pop-up, just select "'Start in Safe Mode" Safe Mode Fx 15 - Win

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

Thank you.

Hello, '''Try Firefox Safe Mode''' to see if the problem goes away. [[Troubleshoot Firefox issues using Safe Mode|Firefox Safe Mode]] is a troubleshooting mode that turns off some settings and disables most add-ons (extensions and themes). ''(If you're using an added theme, switch to the Default theme.)'' If Firefox is open, you can restart in Firefox Safe Mode from the Help menu by clicking on the '''Restart with Add-ons Disabled...''' menu item:<br> [[Image:FirefoxSafeMode|width=520]]<br><br> If Firefox is not running, you can start Firefox in Safe Mode as follows: * On Windows: Hold the '''Shift''' key when you open the Firefox desktop or Start menu shortcut. * On Mac: Hold the '''option''' key while starting Firefox. * On Linux: Quit Firefox, go to your Terminal and run ''firefox -safe-mode'' <br>(you may need to specify the Firefox installation path e.g. /usr/lib/firefox) ''Once you get the pop-up, just select "'Start in Safe Mode"'' [[Image:Safe Mode Fx 15 - Win]] '''''If the issue is not present in Firefox Safe Mode''''', your problem is probably caused by an extension, and you need to figure out which one. Please follow the [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems]] article to find the cause. ''To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.'' When you figure out what's causing your issues, please let us know. It might help others with the same problem. Thank you.

Helpful Reply

NOTHING CHANGED in "Safe Mode" and after a few days of somewhat better results in trying various solutions, the problem came roaring back even worse and my only alternative has been to leave the "Task Manager" open and "End Process" after every web site is opened.

I'm really fed-up with Firefox that they would add such a trublesome feature and then not allow it to be disabled when it is so obviously causing problems. I guess my only alternative is to return to IE in spite of it's obvious security problems. At least I can web surf without my computer hanging-up or going slow.

Thanks for trying.

NOTHING CHANGED in "Safe Mode" and after a few days of somewhat better results in trying various solutions, the problem came roaring back even worse and my only alternative has been to leave the "Task Manager" open and "End Process" after every web site is opened. I'm really fed-up with Firefox that they would add such a trublesome feature and then not allow it to be disabled when it is so obviously causing problems. I guess my only alternative is to return to IE in spite of it's obvious security problems. At least I can web surf without my computer hanging-up or going slow. Thanks for trying.

Helpful Reply

PS:

The only solution that I have found is to allow all scripts to be written on every opened page which negates the job of my NoScript Add-On.

The few Add-Ons that I do have work very well and if I must disable them to allow Firefox to run, then, I don't need Firefox.

PS: The only solution that I have found is to allow all scripts to be written on every opened page which negates the job of my NoScript Add-On. The few Add-Ons that I do have work very well and if I must disable them to allow Firefox to run, then, I don't need Firefox.
John99 971 solutions 13138 answers

If you use no-script that should stop FlashPlayer running unless you really need it.

Otherwise maybe it is better to use IE if you need to use FlashPlayer. There is nothing to stop you using Firefox day-to-day, but IE for FlashPlayer content.

The plugincontainer may be disabled, but that is not recommended, because it may make matters worse. FlashPlayer is no longer tested and designed to run outside the plugin container. Disabling the plugincontainer may well result in Firefox itself becoming crashy.

If you use no-script that should stop FlashPlayer running unless you really need it. Otherwise maybe it is better to use IE if you need to use FlashPlayer. There is nothing to stop you using Firefox day-to-day, but IE for FlashPlayer content. The plugincontainer may be disabled, but that is not recommended, because it may make matters worse. FlashPlayer is no longer tested and designed to run outside the plugin container. Disabling the plugincontainer may well result in Firefox itself becoming crashy. * If you wish to disable see http://kb.mozillazine.org/Plugin-container_and_out-of-process_plugins#Windows_and_Linux although I strongly recommend against doing that but it is your own choice. ** '''Update''', ''the linked article does not directly explain how to disable the plugin-container, it '''does''' contain a linked article that does explicitly explain how to do this.'' * also see [[What is plugin-container]]

Modified by John99

Question owner

NoScript DOES stop Flash Player That was my original intent on installing it.

However, after following the instructions you supplied in "about:config" - By resetting the value to "true" then opening various sites that were causing the "plugin-container.exe" problems, I no longer had the problems. Next, I re-set the value back to "false" as recommended and still didn't have the problems.

My questions now are: Could there have been something "hanging-up" and causing the "plugin-container.exe" problems or, since I have not yet logged-out of Firefox, will they return with a fresh start-up? I guess I'll log-off and re-start after sending this.

Thanks.

NoScript DOES stop Flash Player That was my original intent on installing it. However, after following the instructions you supplied in "about:config" - By resetting the value to "true" then opening various sites that were causing the "plugin-container.exe" problems, I no longer had the problems. Next, I re-set the value back to "false" as recommended and still didn't have the problems. My questions now are: Could there have been something "hanging-up" and causing the "plugin-container.exe" problems or, since I have not yet logged-out of Firefox, will they return with a fresh start-up? I guess I'll log-off and re-start after sending this. Thanks.
John99 971 solutions 13138 answers

Post back with how you get on and we will try to help.

Note the suggestions about using safe mode or disabling plugins are intended as troubleshooting steps. Certain combinations of addons and addon settings may sometimes cause issues with Firefox use.

Firefox is highly customisable. That is a great but also means it may be difficult to get to the bottom of some problems.

I am assuming by the way that the plugincontainer instances you see are usually in relation to FlashPlayer.

Post back with how you get on and we will try to help. Note the suggestions about using safe mode or disabling plugins are intended as troubleshooting steps. Certain combinations of addons and addon settings may sometimes cause issues with Firefox use. Firefox is highly customisable. That is a great but also means it may be difficult to get to the bottom of some problems. I am assuming by the way that the plugincontainer instances you see are usually in relation to FlashPlayer.
Carm 5 solutions 178 answers

Here is the correct information to disable the plugin container as the above mentioned article does not disable the plugin container in the newer versions of Firefox. The proof is under task manager plugin container not being there:

http://firefoxcrash.blogspot.com/2014/01/how-to-fix-flash-player-crashes-in.html

in depth video tutorial and script to do it, and the original article i used for reference below

and

http://www.fluxbytes.com/software-tips/how-to-disable-plugin-container-exe/

Here is the correct information to disable the plugin container as the above mentioned article does not disable the plugin container in the newer versions of Firefox. The proof is under task manager plugin container not being there: http://firefoxcrash.blogspot.com/2014/01/how-to-fix-flash-player-crashes-in.html in depth video tutorial and script to do it, and the original article i used for reference below and http://www.fluxbytes.com/software-tips/how-to-disable-plugin-container-exe/

Question owner

Does anyone have an answer to my above question? "My questions now are: Could there have been something "hanging-up" and causing the "plugin-container.exe" problems?"

I closed-out Firefox and logged back on using my desk-top icon as usual. I visited about 2 dozen web sites without a hang-up, freeze, slow-down or crash. First time in months.

"plugin-container.exe" did not re-appear as a process in my Task Manager and my CPU time and commit charge has stabilized. Web surfing speed is faster.

I have gotten warnings on some sites to enable Flash Player to read all of the content. Most I ignored but with some more trusted sites I temporarily enabled scripts thru NoScript without any more problems.

It seems to have been fixed - Thanks again.

Does anyone have an answer to my above question? "My questions now are: Could there have been something "hanging-up" and causing the "plugin-container.exe" problems?" I closed-out Firefox and logged back on using my desk-top icon as usual. I visited about 2 dozen web sites without a hang-up, freeze, slow-down or crash. First time in months. "plugin-container.exe" did not re-appear as a process in my Task Manager and my CPU time and commit charge has stabilized. Web surfing speed is faster. I have gotten warnings on some sites to enable Flash Player to read all of the content. Most I ignored but with some more trusted sites I temporarily enabled scripts thru NoScript without any more problems. It seems to have been fixed - Thanks again.
jscher2000
  • Top 10 Contributor
7438 solutions 60716 answers

Chosen Solution

Hi RadRon, as the name implies, plugin-container.exe is used to run plugins. This was created around the time of Firefox 3.6.4 to isolate plugins from firefox.exe because they were responsible for a large percentage of Firefox crashes. Placing them in plugin-container.exe prevened misbehaved plugins from taking down your entire Firefox session (at least, in theory it should do that).

So to return to your question of what might have caused your earlier problems with plugin-container.exe, it probably was a problem with the relevant plugin, and the most likely culprit is Flash. But since the error is gone, it's difficult to speculate on the confluence of circumstances that might have been responsible, or what alternative fixes might have helped.

Hi RadRon, as the name implies, plugin-container.exe is used to run plugins. This was created around the time of Firefox 3.6.4 to isolate plugins from firefox.exe because they were responsible for a large percentage of Firefox crashes. Placing them in plugin-container.exe prevened misbehaved plugins from taking down your entire Firefox session (at least, in theory it should do that). So to return to your question of what might have caused your earlier problems with plugin-container.exe, it probably was a problem with the relevant plugin, and the most likely culprit is Flash. But since the error is gone, it's difficult to speculate on the confluence of circumstances that might have been responsible, or what alternative fixes might have helped.
22utoo 0 solutions 8 answers

This quick video https://www.youtube.com/watch?v=gEcQdtC_wLo will help you disable plugin-container.exe in a snap! Hope that helps :)

This quick video https://www.youtube.com/watch?v=gEcQdtC_wLo will help you disable plugin-container.exe in a snap! Hope that helps :)
the-edmeister
  • Top 10 Contributor
  • Moderator
5270 solutions 39006 answers

locking this thread due ti its age

''locking this thread due ti its age''