Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Silverlight using 100% CPU after v26 update

  • 11 replies
  • 12 have this problem
  • Last reply by tnchuck100

more options

Website: Select a campground Facility Map Select Switch to Enhanced Map (Requires Silverlight)

This work fine before Firefox 26 update. Since the update CPU usage goes to 100% and destroys the system response. Changing the current tab to another stops the 100% CPU usage. Re-selecting the tab will again go to 100% CPU.

This condition exists with all add-ons disabled.

I am using Windows XP. This condition does NOT occur on Internet Explorer.

Key point: The Firefox version 26 update resulted in this issue.

Question: How can I to revert to the previous Firefox version?

All Replies (11)

more options


You can download Firerfox releases here:

Or download Firefox Portable:

Isn't recommended use previous versions because it has fail security

But try solve the problem with SIlverligt:

Try Clean your Recent History:

See other questions:

Modified by Diego Victor

more options

I have cleared caches, history, cookies, etc. Silverlight is current and did work before v26.

I looked at the repository. If there is a way to use anything there it is very obscure. Essentially not much help. It even has the appearance of a version 27 being there but the repository is very cryptic. My decoder ring failed to make heads nor tails of it.

Thanks anyway.

more options

Modified by Diego Victor

more options

Well, it looks like this issue is more complex than I thought. Re-installing version 25 did not fix the problem. I have uninstalled and re-installed Silverlight also. No help.

Thank you for your assistance.

Did you, by chance, try the website and observe the problem? You do not need an account or registration to get there.

If you do maybe you can point me toward another solution or possibly tell me what the Firefox is doing or waiting for during this 100% CPU usage.

more options

I went to the site, but my process continued normal, 8 percent!

This happens only this site?

EDIT: try disable your antivirus, sometimes the antivirus try block some pages!

Modified by Diego Victor

more options

This is the only site that uses Silverlight that I know of that I use. The only other thing I might ask is when the map loaded did the navigation parts on the left side (Zoom in, out, pan) change to white background which is normal. Mine stay a dark color which is NOT normal. This pertains to the navigation parts only, not the entire map.

Thanks some more. I really appreciate your help.

more options

I dont know if hardware acceleration can be the problem but disable: Hello,

Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches.

You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

Then perform these steps:

  • Click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options.
  • In the Firefox options window click the Advanced tab, then select "General".
  • In the settings list, you should find the Use hardware acceleration when available checkbox. Uncheck this checkbox.
  • Now, restart Firefox and see if the problems persist.

Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles:

Did this fix your problems? Please report back to us!

Thank you.

more options

I tried disabling the affect. I have MS Security Essentials. Tried disabling that as well....again, no help.

Is there any way I can determine what loop Firefox is stuck in?

The only other thing I might ask is when the map loaded did the navigation parts on the left side (Zoom in, out, pan) change to white background which is normal. Mine stay a dark color which is NOT normal. This pertains to the navigation parts only, not the entire map.

Modified by tnchuck100

more options

More information.

I removed Silverlight from the system. When using Internet Explorer and trying to access the - Facility Map - Switch to Enhanced Map you get a message indicating Silverlight neeeds to be installed. This is what I expected.

Now the strange part. When accessing this on Firefox it behaves exactly as it did before I removed Silverlight. It sill will display the Enhanced Map even with Silverlight removed. I expected it would prompt to install Silverlight just as Internet Explorer did.

Somehow it appears Firefox is using some remnant left over from the past that is not fixable. Cache has been cleared. History cleared. Rebooted. Firefox still allows Enhanced Maps to display but with 100% CPU usage.

more options

Several things to try. First, clear out your cache, and remove the cookies for the site. Firefox > Permissions Manager.
How to clear the Firefox cache

After, try the page again.

If there is still a problem; Holding down the Shift Key, press

<F5> or the reload key.

My last idea is Start Firefox in Safe Mode.

more options

Thanks for the reply but all those things have already been done as previous stated.