X
Tap here to go to the mobile version of the site.

Support Forum

Very annoying scrolling lag

Posted

Hi everyone!

I've been experienced an issue on my new laptop: in Firefox, on every website, It became very laggy when I scroll through a page and when I use "Energy Saver" Windows's power plan. Is there a fix?

I don't think that my hardware is the issue, there is:

Dell XPS 15 Platinum (9530) with Windows 8.1, i7-4702HQ at 2,2/3,2 GHz, 16 GB Ram, Nvidia 750M GT (2GB DDR5) and 512Go Samsung SSD.

Hi everyone! I've been experienced an issue on my new laptop: in Firefox, on every website, It became very laggy when I scroll through a page and when I use "Energy Saver" Windows's power plan. Is there a fix? I don't think that my hardware is the issue, there is: Dell XPS 15 Platinum (9530) with Windows 8.1, i7-4702HQ at 2,2/3,2 GHz, 16 GB Ram, Nvidia 750M GT (2GB DDR5) and 512Go Samsung SSD.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.9 r900
  • Google Update
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • VLC media player Web Plugin 2.1.0
  • The plugin allows you to have a better experience with Microsoft Lync
  • GEPlugin
  • iTunes Detector Plug-in
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.05
  • 5.1.20913.0
  • Intel web components for Intel® Identity Protection Technology
  • Intel web components updater - Installs and updates the Intel web components
  • A plugin to detect whether the Adobe Application Manager is installed on this machine.
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • NPWLPG

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0

More Information

ideato 893 solutions 6250 answers

Hello tomboudiboudi, try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches.

You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

Then perform these steps:

  • Click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options.
  • In the Firefox options window click the Advanced tab, then select "General".
  • In the settings list, you should find the Use hardware acceleration when available checkbox. Uncheck this checkbox.
  • Now, restart Firefox and see if the problems persist.

Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles:

Did this fix your problems? Please report back to us!

Thank you.

Hello tomboudiboudi, try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches. You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.). Then perform these steps: *Click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options. *In the Firefox options window click the ''Advanced'' tab, then select "General". *In the settings list, you should find the ''Use hardware acceleration when available'' checkbox. Uncheck this checkbox. *Now, restart Firefox and see if the problems persist. Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles: * [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems]] * [[Upgrade your graphics drivers to use hardware acceleration and WebGL]] Did this fix your problems? Please report back to us! Thank you.

Helpful Reply

Hi, and thanks for the answer!

I've disabled "hardware acceleration" but it didn't fix the issue... And my graphic driver is the very last one!

Hi, and thanks for the answer! I've disabled "hardware acceleration" but it didn't fix the issue... And my graphic driver is the very last one!
cor-el
  • Top 10 Contributor
  • Moderator
17571 solutions 158915 answers

Does this only happen with "Energy Saver" Windows's power plan active or otherwise as well?


Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window.
Does this only happen with "Energy Saver" Windows's power plan active or otherwise as well? ---- Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance). *Do NOT click the Reset button on the Safe Mode start window. *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes

Question owner

Hi Cor-el!

No, it happens with "Balanced" power plan too. I don't know why, and that's so annoying.

Hi Cor-el! No, it happens with "Balanced" power plan too. I don't know why, and that's so annoying.

Question owner

Any solution?...

Any solution?...
cor-el
  • Top 10 Contributor
  • Moderator
17571 solutions 158915 answers

Did you check which settings are used in the balanced power plan and try to modify them selectively to a setting that works better to see if you can find a culprit?

Did you check which settings are used in the balanced power plan and try to modify them selectively to a setting that works better to see if you can find a culprit?

Question owner

Unfortunately yes... I've tried to turn on/off each settings of the balanced power plan and nothing change...

Unfortunately yes... I've tried to turn on/off each settings of the balanced power plan and nothing change...
jutusoniva 0 solutions 1 answers

Helpful Reply

I had the same problem. This fixed it for me.

Click the orange Firefox button at the top left, select the "Options" button. In the Firefox options window click the Advanced tab, then select "General". Uncheck the box that says "Use Smooth Scrolling"

I had the same problem. This fixed it for me. Click the orange Firefox button at the top left, select the "Options" button. In the Firefox options window click the Advanced tab, then select "General". Uncheck the box that says "Use Smooth Scrolling"
adlerhn 0 solutions 1 answers

I have found a similar problem. I also use an XPS 15 9530, and had severe lag in some websites, such as feedly.com.

Some users have suggested disabling smooth scrolling, but that only makes the problem less aparent, but it is still there.

It turns out that for the HiDPI support I had layout.css.devPixelsPerPx set to 1.75.

I have found out that leaving it with the default value (-1.0), or setting it to 2, the scrolling is really smooth, as it should. I also get the slowdowns now if I set the zoom with CTRL+mouse wheel.

So, my experience is that setting the zoom one way or another to a non-integer value is what causes the slowdown. I have opened a bug for that: https://bugzilla.mozilla.org/show_bug.cgi?id=1007449

Can you try setting an integer zoom multiplier, and if that solves the issue for you as it did for me, comment on the aforementioned bug?

I have found a similar problem. I also use an XPS 15 9530, and had severe lag in some websites, such as feedly.com. Some users have suggested disabling smooth scrolling, but that only makes the problem less aparent, but it is still there. It turns out that for the HiDPI support I had layout.css.devPixelsPerPx set to 1.75. I have found out that leaving it with the default value (-1.0), or setting it to 2, the scrolling is really smooth, as it should. I also get the slowdowns now if I set the zoom with CTRL+mouse wheel. So, my experience is that setting the zoom one way or another to a non-integer value is what causes the slowdown. I have opened a bug for that: https://bugzilla.mozilla.org/show_bug.cgi?id=1007449 Can you try setting an integer zoom multiplier, and if that solves the issue for you as it did for me, comment on the aforementioned bug?