X
Tap here to go to the mobile version of the site.

Support Forum

how do you stop websites from automaticly redirecting to other sites?

Posted

there are a few websites i use that have lately been automaticly redirecting to other unrelated sites the moment i go to the site. for example one site i watch shows on has been redirecting to a brasilian adoby website and i have to quickly stop the page from loading half way through to stop it from happening, the site works fine if i time it right. i know firefox has pop up blockers, so i was woundering if it can block these bothersome redirects?

there are a few websites i use that have lately been automaticly redirecting to other unrelated sites the moment i go to the site. for example one site i watch shows on has been redirecting to a brasilian adoby website and i have to quickly stop the page from loading half way through to stop it from happening, the site works fine if i time it right. i know firefox has pop up blockers, so i was woundering if it can block these bothersome redirects?

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.9 r900

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:24.0) Gecko/20100101 Firefox/24.0 Waterfox/24.0

More Information

Andrew
  • Moderator
321 solutions 4048 answers

Helpful Reply

Hello,

It may be possible an add-on may be causing this or that you may have malware. Let's start off but trying safe mode:


Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • On Windows you can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac you can open Firefox 4.0+ in Safe Mode by holding the option key while starting Firefox.
  • On Linux you can open Firefox 4.0+ in Safe Mode by quitting Firefox and then going to your Terminal and running: firefox -safe-mode (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

FirefoxSafeMode

Once you get the pop-up, just select "'Start in Safe Mode" Safe Mode Fx 15 - Win

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

Thank you.

Hello, It may be possible an add-on may be causing this or that you may have malware. Let's start off but trying safe mode: '''Try Firefox Safe Mode''' to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons. ''(If you're not using it, switch to the Default theme.)'' * On Windows you can open Firefox 4.0+ in Safe Mode by holding the '''Shift''' key when you open the Firefox desktop or Start menu shortcut. * On Mac you can open Firefox 4.0+ in Safe Mode by holding the '''option''' key while starting Firefox. * On Linux you can open Firefox 4.0+ in Safe Mode by quitting Firefox and then going to your Terminal and running: firefox -safe-mode (you may need to specify the Firefox installation path e.g. /usr/lib/firefox) * Or open the Help menu and click on the '''Restart with Add-ons Disabled...''' menu item while Firefox is running. [[Image:FirefoxSafeMode|width=520]] ''Once you get the pop-up, just select "'Start in Safe Mode"'' [[Image:Safe Mode Fx 15 - Win]] '''''If the issue is not present in Firefox Safe Mode''''', your problem is probably caused by an extension, and you need to figure out which one. Please follow the [[Troubleshooting extensions and themes]] article for that. ''To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.'' ''When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.'' Thank you.
Diego Victor 658 solutions 4175 answers

Also:

Sometimes a problem with Firefox may be a result of malware installed on your computer, that you may not be aware of.

You can try these free programs to scan for malware, which work with your existing antivirus software:

Microsoft Security Essentials is a good permanent antivirus for Windows 7/Vista/XP if you don't already have one.

Further information can be found in the Troubleshoot Firefox issues caused by malware article.

Did this fix your problems? Please report back to us!

Also: Sometimes a problem with Firefox may be a result of malware installed on your computer, that you may not be aware of. You can try these free programs to scan for malware, which work with your existing antivirus software: * [http://www.microsoft.com/security/scanner/default.aspx Microsoft Safety Scanner] * [http://www.malwarebytes.org/products/malwarebytes_free/ MalwareBytes' Anti-Malware] * [http://support.kaspersky.com/faq/?qid=208283363 TDSSKiller - AntiRootkit Utility] * [http://www.surfright.nl/en/hitmanpro/ Hitman Pro] * [http://www.eset.com/us/online-scanner/ ESET Online Scanner] [http://windows.microsoft.com/MSE Microsoft Security Essentials] is a good permanent antivirus for Windows 7/Vista/XP if you don't already have one. Further information can be found in the [[Troubleshoot Firefox issues caused by malware]] article. Did this fix your problems? Please report back to us!

Modified by Diego Victor

Question owner

thank you for suggesting safe mode, im still not sure what the problem was, but after i ran safe mode to try and figure it out, i havent had the issue. it buggs me i couldnt figure it out, but im glad its working normaly again anyway haha

thank you for suggesting safe mode, im still not sure what the problem was, but after i ran safe mode to try and figure it out, i havent had the issue. it buggs me i couldnt figure it out, but im glad its working normaly again anyway haha
Diego Victor 658 solutions 4175 answers

Verify your addons maybe one of them is the problem, try disable one by one until you find what is the problem

Verify your addons maybe one of them is the problem, try disable one by one until you find what is the problem
cor-el
  • Top 10 Contributor
  • Moderator
17537 solutions 158573 answers

If it happens again the also try to clear the cache and cookies. "Clear the Cache":

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems or all cookies:

  • Firefox/Tools > Options > Privacy > Cookies: "Show Cookies"
If it happens again the also try to clear the cache and cookies. "Clear the Cache": *Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now" "Remove Cookies" from sites causing problems or all cookies: *Firefox/Tools > Options > Privacy > Cookies: "Show Cookies"
me4all55 1 solutions 15 answers
Hope this Video May Help : [https://www.youtube.com/watch?v=y5e871SRrEs How to Disable Redirects in Mozilla Firefox] https://www.youtube.com/watch?v=y5e871SRrEs