X
Tap here to go to the mobile version of the site.

Support Forum

Checked box for 'do not ask again' on stop unresponsive script dailogue, now facebook page does not load... Help!

Posted

I'm not sure exactly where this question should go, so apologies if I picked the wrong category. As far as I can tell, it fits into 'other problems': So I was getting an 'unresponsive script on page, do you want to stop it' dialogue for a Facebook page I frequent. Got sick of telling FF to stop the script every time, so I checked the 'do not ask again' box, hoping it would automatically just stop the script whenever it became a problem. Well, it's working a little too well. Now the page loads zero content. I'm just wondering how to 'undo' checking that box. Is there maybe a line in about:config I can look for, some setting I can adjust, to reset the 'do not ask again' option on 'stop unresponsive script' dialogues? Thanks in advance for any help!

I'm not sure exactly where this question should go, so apologies if I picked the wrong category. As far as I can tell, it fits into 'other problems': So I was getting an 'unresponsive script on page, do you want to stop it' dialogue for a Facebook page I frequent. Got sick of telling FF to stop the script every time, so I checked the 'do not ask again' box, hoping it would automatically just stop the script whenever it became a problem. Well, it's working a little too well. Now the page loads zero content. I'm just wondering how to 'undo' checking that box. Is there maybe a line in about:config I can look for, some setting I can adjust, to reset the 'do not ask again' option on 'stop unresponsive script' dialogues? Thanks in advance for any help!

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.9 r900
  • Google Update
  • Next Generation Java Plug-in 10.45.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • 5.1.20913.0
  • Nitro PDF plugin for Firefox and Chrome
  • VLC media player Web Plugin 2.0.2
  • Pando Web Plugin
  • wpidetector
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • 6.0.12.46

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20100101 Firefox/24.0

More Information

guigs 1072 solutions 11697 answers

Hi Jade-Raevyn,

Thank you for contacting support. I understand that you are looking for a way to turn back on the unresponsive script message and we are happy to help.

Warning Unresponsive script - What it means and how to fix it

The about:config you are looking for is : dom.max_script_run_time

Reference:

Hi Jade-Raevyn, Thank you for contacting support. I understand that you are looking for a way to turn back on the unresponsive script message and we are happy to help. [[Warning Unresponsive script - What it means and how to fix it]] The about:config you are looking for is : '''dom.max_script_run_time''' Reference: * [http://forums.mozillazine.org/viewtopic.php?f=38&t=2393831] * [https://bugzilla.mozilla.org/show_bug.cgi?id=230909#c14]

Question owner

Hi, thanks for your reply! That is exactly what I'm trying to do.

I looked through your links and checked the about:config setting you indicated, but I'm still having the same problem. The dom.max_script_run_time setting was already at default, so I couldn't reset it (i.e. checking the 'don't ask again' box doesn't seem to have had any effect on that setting). I also tried downloading the YesScript addon as suggested in your first link, but that also made no difference on the page. Finally, I tried manually changing the about:config value to 0, restarting, and then resetting it and restarting again. Still no change.

Based on the last link, it looks like the behavior for clicking the 'don't ask again' check box has changed at some point since 2005... Lol. If you have any other suggestions, that would be awesome! I'll see if I can maybe nose around, find anything else out in the meantime. Thanks again!

Hi, thanks for your reply! That is exactly what I'm trying to do. I looked through your links and checked the about:config setting you indicated, but I'm still having the same problem. The dom.max_script_run_time setting was already at default, so I couldn't reset it (i.e. checking the 'don't ask again' box doesn't seem to have had any effect on that setting). I also tried downloading the YesScript addon as suggested in your first link, but that also made no difference on the page. Finally, I tried manually changing the about:config value to 0, restarting, and then resetting it and restarting again. Still no change. Based on the last link, it looks like the behavior for clicking the 'don't ask again' check box has changed at some point since 2005... Lol. If you have any other suggestions, that would be awesome! I'll see if I can maybe nose around, find anything else out in the meantime. Thanks again!
cor-el
  • Top 10 Contributor
  • Moderator
17419 solutions 157376 answers

Note that there is also a pref for chrome (extension) content.

This can also be a problem with a plugin that runs JavaScript (Flash).

You can check for problems with current Flash plugin versions and try these:

  • disable a possible RealPlayer Browser Record Plugin extension for Firefox and update the RealPlayer if installed
  • disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later)
  • disable hardware acceleration in the Flash plugin

Try to disable hardware acceleration in Firefox (you need to close and restart Firefox).

Note that there is also a pref for chrome (extension) content. This can also be a problem with a plugin that runs JavaScript (Flash). You can check for problems with current Flash plugin versions and try these: *disable a possible RealPlayer Browser Record Plugin extension for Firefox and update the RealPlayer if installed *disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later) *disable hardware acceleration in the Flash plugin *http://kb.mozillazine.org/Flash#Troubleshooting Try to disable hardware acceleration in Firefox (you need to close and restart Firefox). *Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available" *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes
guigs 1072 solutions 11697 answers

HI Jade-Raevyn,

Please let us know how the troubleshooting steps go that cor-el posted. If these are no longer working, it looks like you are using an older version of firefox. Please update to version 26 from the About Firefox menu.

You can also clear the cache and cookies after the update and see if that makes a difference.

HI Jade-Raevyn, Please let us know how the troubleshooting steps go that cor-el posted. If these are no longer working, it looks like you are using an older version of firefox. Please update to version 26 from the About Firefox menu. You can also clear the cache and cookies after the update and see if that makes a difference.