X
Tap here to go to the mobile version of the site.

Support Forum

How do I prevent Firefox from leaking my IP when I use the proxy settings?

Posted

So basically I use the manual proxy settings on Firefox from time to time to be more anonymous. Normally these proxies are pretty slow (but hey, that's the price you to pay for anonymity). Sometimes I'll see a sudden jump in speed. I suspected the proxy may not be working for whatever reason. So I've been using a website that tells you what your IP address is to see if the proxy settings are really working. Sure enough when I refresh the site it gives me my real IP. I check the proxy settings and it turns out the browser had reverted to using system proxy settings (for some reason that's the default instead of no proxy). This happens randomly and for no apparently reason when I'm using manual proxy settings and it leaks my IP whenever this happens (and I never know when it does unless I'm paying close attention). Is there a way to keep it from reverting back to system proxy settings for no reason? BTW I've tested the proxy in question after this happens and it still works so that rules out the possibility of the proxy not working (even if that was the case I'd rather it not connect at all than leak my IP). So yeah, any help in getting it to stop doing this would be nice.

So basically I use the manual proxy settings on Firefox from time to time to be more anonymous. Normally these proxies are pretty slow (but hey, that's the price you to pay for anonymity). Sometimes I'll see a sudden jump in speed. I suspected the proxy may not be working for whatever reason. So I've been using a website that tells you what your IP address is to see if the proxy settings are really working. Sure enough when I refresh the site it gives me my real IP. I check the proxy settings and it turns out the browser had reverted to using system proxy settings (for some reason that's the default instead of no proxy). This happens randomly and for no apparently reason when I'm using manual proxy settings and it leaks my IP whenever this happens (and I never know when it does unless I'm paying close attention). Is there a way to keep it from reverting back to system proxy settings for no reason? BTW I've tested the proxy in question after this happens and it still works so that rules out the possibility of the proxy not working (even if that was the case I'd rather it not connect at all than leak my IP). So yeah, any help in getting it to stop doing this would be nice.

Chosen solution

Hi internetman, in your More System Details it shows as Enabled. It may or may not be doing anything, but try disabling it in case that makes any difference.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.9 r900
  • Google Update
  • Next Generation Java Plug-in 10.45.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • iTunes Detector Plug-in
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.8
  • NPWLPG
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • Firefox 26.0
  • User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0
  • Support URL: https://support.mozilla.org/1/firefox/26.0/WINNT/en-US/

Extensions

  • Adblock Plus 2.4 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Hotspot Shield Extension 3.20 (afproxy@anchorfree.com)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Webroot Filtering Extension 1.0.0.21 (webrootsecure@webroot.com) (Inactive)
  • Webroot Password Manager 2.5.0 ({8ac62a8b-8b3f-43ba-9b1a-90c299b9dfda}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: AMD Radeon HD 7520G
  • adapterDescription2:
  • adapterDeviceID: 0x9990
  • adapterDeviceID2:
  • adapterDrivers: aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
  • adapterDrivers2:
  • adapterRAM: 512
  • adapterRAM2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'tryNewerDriver', u'!= 8.982.*.*']
  • directWriteEnabled: False
  • directWriteVersion: 6.2.9200.16581
  • driverDate: 9-12-2012
  • driverDate2:
  • driverVersion: 8.982.10.5000
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'none', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'tryNewerDriver', u'!= 8.982.*.*']
  • numTotalWindows: 1
  • webglRendererMessage: [u'tryNewerDriver', u'!= 8.982.*.*']
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Basic

Modified Preferences

  • accessibility.typeaheadfind.casesensitive: 1
  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.sessionstore.upgradeBackup.latestBuildID: 20131205075310
  • browser.startup.homepage_override.buildID: 20131205075310
  • browser.startup.homepage_override.mstone: 26.0
  • browser.tabs.warnOnClose: False
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 26.0
  • font.internaluseonly.changed: False
  • gfx.blacklist.direct2d: 3
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1388885034
  • places.history.expiration.transient_current_max_pages: 92985
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.cpd.offlineApps: True
  • privacy.cpd.siteSettings: True
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 4
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1387343566

Misc

  • User JS: No
  • Accessibility: Yes
cor-el
  • Top 10 Contributor
  • Moderator
12762 solutions 117267 answers

Helpful Reply

There is more than one proxy type.
Only an anonymous proxy will hide the IP and build two connections, one between you and the proxy and a second connection between the proxy and the website that uses an IP from that proxy.
A normal proxy merely passes all traffic without affecting it, so websites see your IP in such a case.

There is more than one proxy type.<br /> Only an anonymous proxy will hide the IP and build two connections, one between you and the proxy and a second connection between the proxy and the website that uses an IP from that proxy.<br /> A normal proxy merely passes all traffic without affecting it, so websites see your IP in such a case. *http://en.wikipedia.org/wiki/Proxy_server
jscher2000
  • Top 10 Contributor
3598 solutions 32242 answers

I believe "Use system proxy settings" uses the LAN settings in Internet Options, which you can set using either:

  • Windows Control Panel > Internet Options
  • Internet Explorer > Tools menu > Internet Options

That may help if Firefox is for some unknown reason losing track of your settings, but it sounds as though you know right away anyway...

I believe "Use system proxy settings" uses the LAN settings in Internet Options, which you can set using either: * Windows Control Panel > Internet Options * Internet Explorer > Tools menu > Internet Options That may help if Firefox is for some unknown reason losing track of your settings, but it sounds as though you know right away anyway...
jscher2000
  • Top 10 Contributor
3598 solutions 32242 answers

What protection does the Hotspot Shield extension provide? I wonder whether it might be playing some role in this issue.

What protection does the Hotspot Shield extension provide? I wonder whether it might be playing some role in this issue.

Question owner

Hotspot shield is off. I don't use it. A friend of mine told me it would help keep me secure. I'm actually considering uninstalling it because it keeps badgering me to turn it on. But I don't know if it would affect anything with it off.

Hotspot shield is off. I don't use it. A friend of mine told me it would help keep me secure. I'm actually considering uninstalling it because it keeps badgering me to turn it on. But I don't know if it would affect anything with it off.
jscher2000
  • Top 10 Contributor
3598 solutions 32242 answers

Chosen Solution

Hi internetman, in your More System Details it shows as Enabled. It may or may not be doing anything, but try disabling it in case that makes any difference.

Hi internetman, in your More System Details it shows as Enabled. It may or may not be doing anything, but try disabling it in case that makes any difference.
ololo123 2 solutions 30 answers

look for "privoxy" and "tor browser" they set up to tunnel traffic through chain of proxies. you may copy their configs and make your settings based on them.

look for "privoxy" and "tor browser" they set up to tunnel traffic through chain of proxies. you may copy their configs and make your settings based on them.

Question owner

@jscher2000 Thanks for the advice but how would I go about disabling it? I'm not really good with this stuff as my friend just taught me how to use the proxy settings not too long ago.

@ololo123 I shall look into that as well. Thanks for the suggestion.

@jscher2000 Thanks for the advice but how would I go about disabling it? I'm not really good with this stuff as my friend just taught me how to use the proxy settings not too long ago. @ololo123 I shall look into that as well. Thanks for the suggestion.
albundi2k 0 solutions 19 answers

Helpful Reply

use linux and install "tor privoxy" .problem solved.

http://askubuntu.com/questions/40175/ways-to-hide-an-ip

use linux and install "tor privoxy" .problem solved. http://askubuntu.com/questions/40175/ways-to-hide-an-ip
jscher2000
  • Top 10 Contributor
3598 solutions 32242 answers

Hi internetman, you can disable Hotspot Shield on the Add-ons page. Either:

  • Ctrl+Shift+a
  • orange Firefox button (or Tools menu) > Add-ons

In the left column, click Extensions.

Hi internetman, you can disable Hotspot Shield on the Add-ons page. Either: * Ctrl+Shift+a * orange Firefox button (or Tools menu) > Add-ons In the left column, click Extensions.

Question owner

Looks like the extension was the problem. I haven't had the issue since I disabled it. Thanks for all the help guys.

Looks like the extension was the problem. I haven't had the issue since I disabled it. Thanks for all the help guys.