X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Javascript problems with Firefox 27

Posted

I have an image carousel that doesn't display the images in Firefox 27. I know that the script is working because I can see the carousel working

Chosen solution

I can confirm that it only doesn't work in the current Firefox 27 beta release.
The current Firefox release and both the Nightly 29 and Aurora 28 release show the images for me.

The images do show if I add this style rule to the iframe via the DOM Inspector:

#carousel img {opacity:1}

So it seems that your assumption abut opacity could be right.

For what it is worth: I did notice a typo in the style sheet: a colon instead or a semicolon

    img.dawn{
	border-radius:50%;
	opacity:.99:
	}
	img{
	
	border-radius:45%;
	}
Read this answer in context 1
Post a Reply

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.9 r900
  • VLC media player Web Plugin 2.1.0
  • 3.0.40624.0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:17.0) Gecko/17.0 Firefox/17.0

More Information

gnittala 28 solutions 307 answers

Hello,

Can you please confirm if you are able to access the site where the images are being retrieved from. Also, if you can please check the developer tools (or) Firebug to see if there are network errors that could give some clues on why the carousel is not working.

And also, does this work on other browsers? That will rule out network issues and point to JavaScript / HTML issues on FF27.

Thank you

Was this helpful to you? 1
Reply
cor-el
  • Top 10 Contributor
  • Moderator
10780 solutions 97024 answers

Helpful Reply

Can you post a link to a publicly accessible page that doesn't require authentication (signing on)?


If images are missing then check that you aren't blocking images from some domains.

  • Press the F10 key or tap the Alt key to bring up the hidden "Menu Bar" temporarily.
  • Check the permissions for the domain in the currently selected tab in "Tools > Page Info > Permissions"
  • Check "Tools > Page Info > Media" for blocked images
  • Select the first image link and use the cursor Down key to scroll through the list.
  • If an image in the list is grayed and "Block Images from..." has a check-mark then remove this check-mark to unblock images from this domain.

Make sure that you do not block (third-party) images, the permissions.default.image pref on the about:config page should be 1.


Make sure that you haven't enabled a High Contrast theme in the Windows/Mac Accessibility settings.

Make sure that you allow pages to choose their own colors.

  • Tools > Options > Content : Fonts & Colors > Colors : [X] "Allow pages to choose their own colors, instead of my selections above"

Note that these settings affect background images.

See also:


There are extensions like Adblock Plus (Firefox/Tools > Add-ons > Extensions) and security software (firewall, anti-virus) that can block images and other content.

See also:

Was this helpful to you? 2
Reply

Question owner

the page in question can be viewed here

http://codepigs.us/New%20Driving%20School/index.html

Everything works fine with all versions of FF except FF27

It also works with other browsers

I just realized this could be a prob with css as well, as I am using opacity

Modified by Steve666

Was this helpful to you? 0
Reply
cor-el
  • Top 10 Contributor
  • Moderator
10780 solutions 97024 answers

Chosen Solution

I can confirm that it only doesn't work in the current Firefox 27 beta release.
The current Firefox release and both the Nightly 29 and Aurora 28 release show the images for me.

The images do show if I add this style rule to the iframe via the DOM Inspector:

#carousel img {opacity:1}

So it seems that your assumption abut opacity could be right.

For what it is worth: I did notice a typo in the style sheet: a colon instead or a semicolon

    img.dawn{
	border-radius:50%;
	opacity:.99:
	}
	img{
	
	border-radius:45%;
	}
Was this helpful to you? 1
Reply

Question owner

Thank you, for this insight, now that I think about this more, the problem probably is with the way FF27 is parsing CSS and not a javascript issue

I will correct my typo and add your inclusion

Respectfully

Steve

Was this helpful to you? 1
Reply
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.