Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Change default save files directory

  • 12 replies
  • 44 have this problem
  • 22548 views
  • Last reply by xx3121kxx

more options

I'm trying to switch where files are saved on my computer but Firefox just ignores the new directory and keeps saving in the same place instead of what's set in options/downloads/savefilesto. How can I make it so that my downloads go in a specific folder?

Chosen solution

Thank for all of the help everyone, and no I'm fine now. Strangely the problem just seemed to solve itself and I forgot about the issue over time. Sorry about that.

Read this answer in context 👍 0

All Replies (12)

more options

Current Firefox versions remember the download directory based upon the URL, so if the URL changes then the default folder may be chosen if there hasn't been selected a download folder before for that server.
You can disable this feature to remember the download directory via the Boolean pref browser.download.lastDir.savePerSite on the about:config page.
The browser.download.lastDir.savePerSite pref doesn't exist by default (it is a hidden pref), so you need to create it.

Create a new Boolean pref with the name browser.download.lastDir.savePerSite and set the value to false.

You can delete the content-prefs.sqlite file in the Profile Folder to only remove settings stored in this file and keep the exceptions that are stored in permissions.sqlite that would be lost if you clear the "Site Preferences" via Clear Recent History.

more options

Thanks for the reply but I've already tried that, Firefox still tries saving in the same spot every time.

more options

Hello,

Try change this option "browser.download.useDownloadDir" on about:config page to true, then close firefox and restart in safe mode

Hello,

Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • On Windows you can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac you can open Firefox 4.0+ in Safe Mode by holding the option key while starting Firefox.
  • On Linux you can open Firefox 4.0+ in Safe Mode by quitting Firefox and then going to your Terminal and running: firefox -safe-mode (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

FirefoxSafeMode

Once you get the pop-up, just select "'Start in Safe Mode" Safe Mode Fx 15 - Win

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

Thank you.

more options

I tried changing the "Save files to" setting in Options window - General panel to my Desktop instead of the Downloads folder (the default location) and it worked for me on Windows 7 in Firefox 26.

Options General Win 20

To change which folder is used, click Browse… but first make sure that "Always ask me where to save files" is NOT selected.

If it's not working for you, reset all preferences and try again. See Reset Firefox preferences to troubleshoot and fix problems under Solution 2: Delete Firefox preference files to reset all Firefox preferences to the default settings.

more options

To which folder do the files get saved?

If they end up in the temp folder then your anti-virus software might be interfering and causing this problem.

more options

I have this problem in Windows 7 with Firefox 27. Whatever I set in the "Save files to" box is overridden by Firefox. Files are saved to the Windows default Downloads folder ( [Windows user account]\Downloads ). I did not have this problem in Firefox 26.

more options

The problem is restricted to links that start the save dialog. For example a click on any download button on https://www.mozilla.org/en-US/firefox/all/

I can right click an image, do "save link as..." and choose a folder. The next "save link as..." use remembers that folder during the session.

Someone with Windows 7 and Firefox 27 please check if you can reproduce this error. Go to options > general > and temporarily set a different folder in the "save files to" option. Then click on a download on the page I linked to, save the file and see what folder it ends up in.

Modified by teilei

more options

I can 100% replicate this issue (27.0.1 on win7 64bit). The issue (at least for me) is that with this version the logic for the download dir seems to have changed to ignore any 'bare' drive.

That is, in my case I have a dedicated download partition mounted as 'E:', so my download directory is 'e:\'. This now gets ignored if set and instead the download goes to my 'downloads' directory. Re-setting the preference via about:config or via the options dialog makes no difference: it ignores the location.

If however I set the download location to e.g. 'e:\temp\' (or anywhere else with at least one non-root path component), the location is honored. If I use e.g. 'd:\', 'e:\' etc, it is ignored.

I really hope this is a bug which will be fixed rather than another attempt to 'dumb-down' or foolproof the software (or if it is the latter, that you provide a means via about:config to override it; if I, as the user, explicitly say I want to use a dedicated partition, I should be allowed to).

more options

I confirm what ccau is saying.

more options

ccau, You wrote,
I set the download location to e.g. 'e:\temp\' (or anywhere else with at least one non-root path component), the location is honored. If I use e.g. 'd:\', 'e:\' etc, it is ignored.

Mozilla developers are working on the bug introduced in Firefox 27 that prevents selecting a "root" directory as the download folder (you can vote for the bug to keep track of the progress)

  • Bug 958899 - Under Windows, cannot use a root directory as the destination for downloading
more options

xx3121kxx Are you still looking for help? You never replied to the answers posted by me, Diego Victor and cor-el, back in December (see above).

more options

Chosen Solution

Thank for all of the help everyone, and no I'm fine now. Strangely the problem just seemed to solve itself and I forgot about the issue over time. Sorry about that.