On Aug 14th 11 PM ET/Aug 15th 03:00 UTC, due to scheduled Firefox Account server maintenance, users may not be able to sign in or create a new subscription. This is expected to last approximately 30 minutes. Status updates can be found at https://status.vpn.mozilla.org or https://status.relay.firefox.com.

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Screen dims

  • 14 replies
  • 5 have this problem
  • 286 views
  • Last reply by Adendum

more options

Weird one here....

I have a Windows 8 PC running dual Samsung T220 screens running from an NVIDIA GeForce GT640. Both monitors have identical settings in the latest driver (always kept up to date) and the only difference is that the primary monitor is connected via a DVI cable and the other via VGA.

With Firefox and ONLY Firefox if I scroll down a page the primary monitor dims IF the website's background is dark or black. If I drag the Firefox window to the secondary monitor it does not dim the screen.

I have tested several other applications and browsers on both screens and ONLY Firefox is doing this and the condition ONLY happens with dark background websites. I have tried various settings in Firefox e.g. on/off for auto scroll, smooth scrolling, hardware acceleration but none of the settings affect this condition.

What could the cause be and how do I stop this from happening- cos it is ***** annoying. :)

Weird one here.... I have a Windows 8 PC running dual Samsung T220 screens running from an NVIDIA GeForce GT640. Both monitors have identical settings in the latest driver (always kept up to date) and the only difference is that the primary monitor is connected via a DVI cable and the other via VGA. With Firefox and ONLY Firefox if I scroll down a page the primary monitor dims IF the website's background is dark or black. If I drag the Firefox window to the secondary monitor it does not dim the screen. I have tested several other applications and browsers on both screens and ONLY Firefox is doing this and the condition ONLY happens with dark background websites. I have tried various settings in Firefox e.g. on/off for auto scroll, smooth scrolling, hardware acceleration but none of the settings affect this condition. What could the cause be and how do I stop this from happening- cos it is ***** annoying. :)

Chosen solution

Hi Adendum, I assume Firefox doesn't know what window it's on, and is just sending the same data to Windows regardless. If you are using the same display driver with the both monitors, I wonder whether it could be a feature of the monitor itself.

When I search around on the web for information about monitors that dim themselves when dark content is displayed, there are some threads for both LG and Samsung brand monitors/TVs. On some LG displays, for example, if you don't find it in the menu, there may be an extra button for "SUPER Energy Saving Mode".

Read this answer in context 👍 0

All Replies (14)

more options

This still sounds like an issue with hardware acceleration or some setting in the graphics display driver.

Did you close and restart Firefox after disabling hardware acceleration as this is needed?

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window.
more options

Not sure how or why but it is fixed now. I unset autoscroll, smoothscroll and hardware acceleration and restarted and it's OK now.

Many thanks.

more options

I lied! This is really weird...

I've restarted in Safe Mode and it's the same.

I can't see this as a hardware issue, as such, because the condition only happens in Firefox (I have created long documents with black backgrounds in several applications) and they are all OK when scrolling.

Any more ideas anyone?

more options

Does this happen on all pages or only with pages that use a fixed background that doesn't scroll?

more options

Can you replicate it on this site by setting the body background color to black? To do that, you can use the Web Console.

Select and copy this short line of script:

var bs=document.body.style; bs.backgroundColor="black"; bs.backgroundImage="none";

Press Ctrl+Shift+k to open the Web Console, then paste the script next to the caret (») and press Enter to run it. You can close the console after that.

more options

At the moment the answer is no.....BUT...also at the moment it's not doing it on any other dark background site.

So SOMETHING is triggering this condition. Just what you don't want to hear huh!

I have found that everything is fine for a while and then it starts. I've tried doing what I generally do each day and so far I can't replicate the condition but this is a holiday so I'm not working and probably not doing all the things I normally do. I spend most of the day dipping into various client WordPress sites, various forums, Google etc etc.

Aha....as I write it happened again!!! I had Google Chrome running on the other monitor and then closed it down. Immediately FF started to dim on a dark website (this one) but after running the code above THIS site (mozilla.org) doesn't dim.

So I've Googled a few other dark sites and I am consistently seeing the entire screen dim on page load but some sites don't dim on scroll while others do.

This one dims:- http://ryanlottering.tumblr.com/

This one dims on load and is partly OK until you scroll all the way to the footer and then dims:- http://www.ascensionlatorre.com/home

This dims a little (!!!) at the first slideshow and then dims massively when you scroll down to the SERVICE section of the page:- http://www.hytwatches.com/

This one dims on load, gets dimmer as you scroll down:- http://synth76.com/

This dims to almost black and unviewable and lightens and dims at various points while scrolling http://www.darkprayers.com/

But equally many dark sites aren't dimming......so there must be a clue in there somewhere. Any bright ideas?

And thanks to everyone for trying to help me with this annoying situation. Hope you all had a great Christmas!

Modified by Adendum

more options

I haven't come up with any new ideas, but could you clarify: does the entire monitor dim, or only the web page area, or only the vertical width of the web page (not affecting the scroll bar, for example, or any windows or desktop visible to the sides of the browser?

more options

You can check for problems with color profiles for your display monitor.

Try to disable color management to test if it is caused by a problem with color management.

You can set the gfx.color_management.mode pref to 0 on the about:config page to disable Color Management.

You need to close and restart Firefox to make the change effective.

See:

more options

@jscher2000 The entire monitor dims but only the primary monitor - the identical secondary monitor remains unaffected.

But I can now add that this only happens when I have the browser running at full screen (1680x1050)....no I lie! It happens when the browser is sized BIGGER than 1367 x 873.

So I can browse to a dark site where this happens and resize the width and height until the dim effect goes away. If I drag the browser window 1px on any side the dim effect happens - for the whole screen.

Modified by Adendum

more options

@cor-el

I found two gfx settings in prefs.js (I assume this is what you meant by the about:config reference?).:-

user_pref("gfx.direct3d.last_used_feature_level_idx", 0); user_pref("gfx.direct3d.prefer_10_1", true);

I tried setting the latter to false and after the restart of FF there was no change but looking at the prefs.js file I see it had reverted to true.

Or were you thinking about something different?

more options

Hi Adendum, the preferences which still have their default values are not listed in prefs.js, only the ones that have been modified from their defaults. For best results, use the about:config preferences editor to modify preferences if at all possible.

more options

Hi jscher200,

Thanks for your persistence - appreciated!

I have changed the about:config gfx.color_management.mode preference to 0 and restarted FF and tested a couple of sites - same condition. I have therefore reset back to 2 (default).

If I drag the FF window over to the secondary (but identical monitor) and browse some of these dimming websites they don't dim, drag it back to the primary monitor and they do.

Which kind of points to a hardware or driver issue doesn't it?

more options

Chosen Solution

Hi Adendum, I assume Firefox doesn't know what window it's on, and is just sending the same data to Windows regardless. If you are using the same display driver with the both monitors, I wonder whether it could be a feature of the monitor itself.

When I search around on the web for information about monitors that dim themselves when dark content is displayed, there are some threads for both LG and Samsung brand monitors/TVs. On some LG displays, for example, if you don't find it in the menu, there may be an extra button for "SUPER Energy Saving Mode".

more options

Guys,

Unbelievable......problem fixed.

My sincerest apologies to all of you as I completely wasted everyone's time!

There is a setting in the monitor menu (actual monitor not driver) that was set in the Picture>MagicBright section to use Dynamic Contrast. As soon as I changed that to a different setting (choices are Text, Internet, Game, Sport, Movie, Dynamic Contrast and Custom) the problem evaporated - I was in a dark site when I changed the settings and the dimming undimmed!

Well, maybe not a complete waste of time - jsher2000's last post pointed me in the right direction and maybe this thread may help someone else - let's hope so!

Again, many many thanks to you all and I hope you all have a fantastic 2014!

Paul (Adendum)