X
Tap here to go to the mobile version of the site.

Support Forum

Cannot see embedded Youtube videos; I get a black screen

Posted

So, embedded Youtube videos suddenly stopped working. I can still watch videos on the Youtube website just fine. Making an embedded video fullscreen also allows me to see it. I have seen an answer on another thread asking to try Safe Mode. Interestingly, disabling every add-on and plugin (besides Flash and Shockwave) does not fix the issue, but using Safe Mode, which theoretically does the same thing, fixes it :S

The embeds are black screen, and when I hover the mouse over them I see the Refresh and HD buttons, but not the Youtube icon on the lower right. Clicking the lower right area still brings me to the Youtube website, so the button still works, just isn't visible. Reinstalling Waterfox and using a new profile do not fix the issue.

I can't test the issue on Firefox because it has a long-standing problem of the Flash Player crashing constantly every second, which rendered it unusable and is the reason I switched to Waterfox in the first place (in which Flash does not crash).

The troubleshoot information with all Waterfox add-ons disabled (which again, doesn't fix the issue, despite Safe Mode fixing it) can be seen by navigating to the "More system details" on the menu to the right.

Thanks!

So, embedded Youtube videos suddenly stopped working. I can still watch videos on the Youtube website just fine. Making an embedded video fullscreen also allows me to see it. I have seen an answer on another thread asking to try Safe Mode. Interestingly, disabling every add-on and plugin (besides Flash and Shockwave) does not fix the issue, but using Safe Mode, which theoretically does the same thing, fixes it :S The embeds are black screen, and when I hover the mouse over them I see the Refresh and HD buttons, but not the Youtube icon on the lower right. Clicking the lower right area still brings me to the Youtube website, so the button still works, just isn't visible. Reinstalling Waterfox and using a new profile do not fix the issue. I can't test the issue on Firefox because it has a long-standing problem of the Flash Player crashing constantly every second, which rendered it unusable and is the reason I switched to Waterfox in the first place (in which Flash does not crash). The troubleshoot information with all Waterfox add-ons disabled (which again, doesn't fix the issue, despite Safe Mode fixing it) can be seen by navigating to the "More system details" on the menu to the right. Thanks!

Modified by Kelvets

Chosen solution

I'm not aware of any Waterfox-specific issues or fixes, so this is some standard guidance that addresses the most common issues with the Flash Player plugin. I'm sure you've seen some of it before, but just in case:

(1) If you have any recorders/downloaders that interact with Flash media make sure they are as up-to-date as possible, or disable them temporarily.

(2) Disable hardware graphics acceleration in Firefox and in Flash

(A) In Firefox, un-check the box here and restart:

orange Firefox button (or Tools menu) > Options > Advanced > General > "Use hardware acceleration when available"

(B) In Flash, see this support article from Adobe: http://helpx.adobe.com/flash-player/kb/video-playback-issues.html#main_Solve_video_playback_issues

(3) Disable protected mode (Windows Vista and higher)

See this support article from Adobe under the heading "Last Resort": Adobe Forums: How do I troubleshoot Flash Player's protected mode for Firefox?

Note: the 32-bit and 64-bit plugins inhabit different folders, so you will need to do the mms.cfg fix in both folders to cover both Waterfox and Firefox.

Read this answer in context 3

Additional System Details

Installed Plug-ins

  • Next Generation Java Plug-in 10.45.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 11.9 r900
  • 5.1.20513.0
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:24.0) Gecko/20100101 Firefox/24.0 Waterfox/24.0

More Information

Application Basics
Name: Firefox Version: 24.0 User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:24.0) Gecko/20100101 Firefox/24.0 Waterfox/24.0
Extensions
Name: Adblock Plus Version: 2.4 Enabled: false ID: {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}
Name: Busca Wikipedia PT Version: 0.4 Enabled: false ID: jid1-q9Ovmt2YHtaBOw@jetpack
Name: Download Statusbar Version: 0.9.10 Enabled: false ID: {D4DD63FA-01E4-46a7-B6B1-EDAB7D6AD389}
Name: DownloadHelper Version: 4.9.21 Enabled: false ID: {b9db16a4-6edc-47ec-a1f4-b86292ed211d}
Name: FabTabs Version: 1.5.2 Enabled: false ID: fabtab@captaincaveman.nl
Name: GlassMyFox Version: 1.3.3 Enabled: false ID: GlassMyFox@ArisT2_Noia4dev
Name: GMarks Version: 1.0.3.3 Enabled: false ID: {A64F9D1E-FA5E-11DA-A187-6B94C2ED2B83}
Name: Google Bookmarks for Firefox Version: 0.7 Enabled: false ID: {473f9a20-ce5a-11da-a94d-0800200c9a66}
Name: Google Translator for Firefox Version: 2.1.0.3 Enabled: false ID: translator@zoli.bod
Name: Greasemonkey Version: 1.13 Enabled: false ID: {e4a8a97b-f2ed-450b-b12d-ee082ba24781}
Name: HTTPS Finder Version: 0.85 Enabled: false ID: {6bdc61ae-7b80-44a3-9476-e1d121ec2238}
Name: Persona Switcher Version: 1.17 Enabled: false ID: drsjb80@gmail.com
Name: ReminderFox Version: 2.1.2 Enabled: false ID: {ada4b710-8346-4b82-8199-5de2b400a6ae}
Name: Smartest Bookmarks Bar Version: 1.11 Enabled: false ID: {b442f4c0-c292-4998-aabe-48608a73ba75}
Name: Stylish Version: 1.4.0 Enabled: false ID: {46551EC9-40F0-4e47-8E18-8E5CF550CFB8}
Name: Test Pilot Version: 1.2.3 Enabled: false ID: testpilot@labs.mozilla.com
Name: Toggle Persona Version: 1.0.9 Enabled: false ID: togglepersona@davidvincent.tld
Name: YouTube Auto Replay Version: 2.88 Enabled: false ID: YouTubeAutoReplay@arikv.com
Important Modified Preferences
accessibility.typeaheadfind.flashBar: 0 browser.cache.disk.capacity: 358400 browser.cache.disk.smart_size.first_run: false browser.cache.disk.smart_size.use_old_max: false browser.cache.disk.smart_size_cached_value: 358400 browser.places.smartBookmarksVersion: 4 browser.privatebrowsing.dont_prompt_on_enter: true browser.sessionstore.upgradeBackup.latestBuildID: 20131205075310 browser.startup.homepage: https://startpage.com/eng/ browser.startup.homepage_override.buildID: 20131007042817 browser.startup.homepage_override.mstone: 24.0 browser.tabs.loadInBackground: false browser.tabs.warnOnClose: false browser.tabs.warnOnOpen: false dom.max_script_run_time: 0 dom.mozApps.used: true extensions.lastAppVersion: 24.0 font.internaluseonly.changed: false gfx.direct3d.last_used_feature_level_idx: 0 gfx.direct3d.prefer_10_1: true network.cookie.prefsMigrated: true places.database.lastMaintenance: 1387414025 places.history.expiration.transient_current_max_pages: 104858 plugin.disable_full_page_plugin_for_types: application/pdf plugin.importedState: true plugin.state.flash: 2 plugin.state.npauthz: 2 plugin.state.npctrl: 2 plugin.state.npspwrap: 2 print.printer_HP_Deskjet_3050_J610_series.print_bgcolor: false print.printer_HP_Deskjet_3050_J610_series.print_bgimages: false print.printer_HP_Deskjet_3050_J610_series.print_colorspace: print.printer_HP_Deskjet_3050_J610_series.print_command: print.printer_HP_Deskjet_3050_J610_series.print_downloadfonts: false print.printer_HP_Deskjet_3050_J610_series.print_duplex: -1 print.printer_HP_Deskjet_3050_J610_series.print_edge_bottom: 0 print.printer_HP_Deskjet_3050_J610_series.print_edge_left: 0 print.printer_HP_Deskjet_3050_J610_series.print_edge_right: 0 print.printer_HP_Deskjet_3050_J610_series.print_edge_top: 0 print.printer_HP_Deskjet_3050_J610_series.print_evenpages: true print.printer_HP_Deskjet_3050_J610_series.print_footercenter: print.printer_HP_Deskjet_3050_J610_series.print_footerleft: &PT print.printer_HP_Deskjet_3050_J610_series.print_footerright: &D print.printer_HP_Deskjet_3050_J610_series.print_headercenter: print.printer_HP_Deskjet_3050_J610_series.print_headerleft: &T print.printer_HP_Deskjet_3050_J610_series.print_headerright: &U print.printer_HP_Deskjet_3050_J610_series.print_in_color: true print.printer_HP_Deskjet_3050_J610_series.print_margin_bottom: 0.5 print.printer_HP_Deskjet_3050_J610_series.print_margin_left: 0.5 print.printer_HP_Deskjet_3050_J610_series.print_margin_right: 0.5 print.printer_HP_Deskjet_3050_J610_series.print_margin_top: 0.5 print.printer_HP_Deskjet_3050_J610_series.print_oddpages: true print.printer_HP_Deskjet_3050_J610_series.print_orientation: 0 print.printer_HP_Deskjet_3050_J610_series.print_page_delay: 50 print.printer_HP_Deskjet_3050_J610_series.print_paper_data: 9 print.printer_HP_Deskjet_3050_J610_series.print_paper_height: 11,00 print.printer_HP_Deskjet_3050_J610_series.print_paper_name: print.printer_HP_Deskjet_3050_J610_series.print_paper_size_type: 0 print.printer_HP_Deskjet_3050_J610_series.print_paper_size_unit: 1 print.printer_HP_Deskjet_3050_J610_series.print_paper_width: 8,50 print.printer_HP_Deskjet_3050_J610_series.print_plex_name: print.printer_HP_Deskjet_3050_J610_series.print_resolution: 1 print.printer_HP_Deskjet_3050_J610_series.print_resolution_name: print.printer_HP_Deskjet_3050_J610_series.print_reversed: false print.printer_HP_Deskjet_3050_J610_series.print_scaling: 1,00 print.printer_HP_Deskjet_3050_J610_series.print_shrink_to_fit: true print.printer_HP_Deskjet_3050_J610_series.print_to_file: false print.printer_HP_Deskjet_3050_J610_series.print_unwriteable_margin_bottom: 0 print.printer_HP_Deskjet_3050_J610_series.print_unwriteable_margin_left: 0 print.printer_HP_Deskjet_3050_J610_series.print_unwriteable_margin_right: 0 print.printer_HP_Deskjet_3050_J610_series.print_unwriteable_margin_top: 0 privacy.cpd.cache: false privacy.cpd.cookies: false privacy.cpd.downloads: false privacy.cpd.formdata: false privacy.cpd.history: false privacy.cpd.offlineApps: true privacy.cpd.sessions: false privacy.donottrackheader.enabled: true privacy.sanitize.migrateFx3Prefs: true privacy.sanitize.timeSpan: 0 security.warn_viewing_mixed: false storage.vacuum.last.index: 1 storage.vacuum.last.places.sqlite: 1387150299
Graphics
Adapter Description: NVIDIA GeForce GTX 560 Adapter Drivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um Adapter RAM: 1024 Device ID: 0x1201 Direct2D Enabled: true DirectWrite Enabled: true (6.2.9200.16571) Driver Date: 11-11-2013 Driver Version: 9.18.13.3182 GPU #2 Active: false GPU Accelerated Windows: 1/1 Direct3D 10 Vendor ID: 0x10de WebGL Renderer: Google Inc. -- ANGLE (NVIDIA GeForce GTX 560 Direct3D9Ex vs_3_0 ps_3_0) windowLayerManagerRemote: false AzureCanvasBackend: direct2d AzureContentBackend: direct2d AzureFallbackCanvasBackend: cairo
JavaScript
Incremental GC: true
Accessibility
Activated: false Prevent Accessibility: 0
Library Versions
NSPR Expected minimum version: 4.10 Version in use: 4.10
NSS Expected minimum version: 3.15.1 Basic ECC Version in use: 3.15.1 Basic ECC
NSSSMIME Expected minimum version: 3.15.1 Basic ECC Version in use: 3.15.1 Basic ECC
NSSSSL Expected minimum version: 3.15.1 Basic ECC Version in use: 3.15.1 Basic ECC
NSSUTIL Expected minimum version: 3.15.1 Version in use: 3.15.1

jscher2000
  • Top 10 Contributor
3762 solutions 33335 answers

Chosen Solution

I'm not aware of any Waterfox-specific issues or fixes, so this is some standard guidance that addresses the most common issues with the Flash Player plugin. I'm sure you've seen some of it before, but just in case:

(1) If you have any recorders/downloaders that interact with Flash media make sure they are as up-to-date as possible, or disable them temporarily.

(2) Disable hardware graphics acceleration in Firefox and in Flash

(A) In Firefox, un-check the box here and restart:

orange Firefox button (or Tools menu) > Options > Advanced > General > "Use hardware acceleration when available"

(B) In Flash, see this support article from Adobe: http://helpx.adobe.com/flash-player/kb/video-playback-issues.html#main_Solve_video_playback_issues

(3) Disable protected mode (Windows Vista and higher)

See this support article from Adobe under the heading "Last Resort": Adobe Forums: How do I troubleshoot Flash Player's protected mode for Firefox?

Note: the 32-bit and 64-bit plugins inhabit different folders, so you will need to do the mms.cfg fix in both folders to cover both Waterfox and Firefox.

I'm not aware of any Waterfox-specific issues or fixes, so this is some standard guidance that addresses the most common issues with the Flash Player plugin. I'm sure you've seen some of it before, but just in case: (1) If you have any recorders/downloaders that interact with Flash media make sure they are as up-to-date as possible, or disable them temporarily. (2) Disable hardware graphics acceleration in Firefox and in Flash (A) In Firefox, un-check the box here and restart: orange Firefox button (or Tools menu) > Options > Advanced > General > "Use hardware acceleration when available" (B) In Flash, see this support article from Adobe: http://helpx.adobe.com/flash-player/kb/video-playback-issues.html#main_Solve_video_playback_issues (3) Disable protected mode (Windows Vista and higher) See this support article from Adobe under the heading "Last Resort": [http://forums.adobe.com/message/4468493#TemporaryWorkaround Adobe Forums: How do I troubleshoot Flash Player's protected mode for Firefox?] ''Note: the 32-bit and 64-bit plugins inhabit different folders, so you will need to do the mms.cfg fix in both folders to cover both Waterfox and Firefox.''
jscher2000
  • Top 10 Contributor
3762 solutions 33335 answers

Incidentally, if you have this problem on secure (HTTPS) pages and you notice a shield icon to the left of the URL in the address bar, check this article regarding the mixed content blocker: How does content that isn't secure affect my safety?

Incidentally, if you have this problem on secure (HTTPS) pages and you notice a shield icon to the left of the URL in the address bar, check this article regarding the mixed content blocker: [[How does content that isn't secure affect my safety?]]

Helpful Reply

I had disabled hardware accel in Waterfox and it didn't fix the embeds, but doing so in Firefox fixed them for Waterfox! Odd. It didn't fix the constant Flash Player crashing, though. Thanks for solving the embeds!

I had disabled hardware accel in Waterfox and it didn't fix the embeds, but doing so in Firefox fixed them for Waterfox! Odd. It didn't fix the constant Flash Player crashing, though. Thanks for solving the embeds!

Modified by Kelvets

jscher2000
  • Top 10 Contributor
3762 solutions 33335 answers

For the severe issues, you really should disable the protected mode feature. If Windows gives you problems with permissions, try this way:

(1) In a My Computer or Windows Explorer window, open this folder:

C:\Windows\SysWOW64\Macromed\Flash

If that folder does not exist, then you are using 32-bit Windows, and you can open the following folder instead:

C:\Windows\System32\Macromed\Flash

(Note: This folder exists on both 32-bit and 64-bit Windows, but on 64-bit Windows Firefox uses the Flash player in the SysWOW64 folder instead.)

(2) Check for a file named mms.cfg:

Note: If you do not see file extensions such as .ocx, .dll, .exe, and .cfg on the files in this folder, then Windows may be hiding these from you. In order to work with file names accurately, it is best to unhide the extensions. This Microsoft support article has the steps: http://support.microsoft.com/kb/865219.

(A) If mms.cfg exists, drag it to your Documents folder where you can edit it without being bothered about administrator privileges

(B) If mms.cfg does not exist, open your Documents folder, right-click > New > Text File and name the new file mms.cfg

(3) Open mms.cfg from Documents into a text editor such as Notepad.

Add this on its own line (I put it last):

ProtectedMode=0

Save the file and close Notepad.

(4) Hold down the Ctrl key and drag the mms.cfg file back to the Flash folder to make a copy there, keeping the original in Documents

This change will take effect once the Flash plugin is completely unloaded, which may require exiting and restarting Firefox (allow a few minutes for all the Flash processes in memory to terminate after exiting Firefox).

For the severe issues, you really should disable the protected mode feature. If Windows gives you problems with permissions, try this way: (1) In a My Computer or Windows Explorer window, open this folder: C:\Windows\SysWOW64\Macromed\Flash If that folder does not exist, then you are using 32-bit Windows, and you can open the following folder instead: C:\Windows\System32\Macromed\Flash ''(Note: This folder exists on both 32-bit and 64-bit Windows, but on 64-bit Windows Firefox uses the Flash player in the SysWOW64 folder instead.)'' (2) Check for a file named mms.cfg: '''''Note:''' If you do not see file extensions such as .ocx, .dll, .exe, and .cfg on the files in this folder, then Windows may be hiding these from you. In order to work with file names accurately, it is best to unhide the extensions. This Microsoft support article has the steps: [http://support.microsoft.com/kb/865219].'' (A) ''If mms.cfg exists,'' drag it to your '''Documents folder''' where you can edit it without being bothered about administrator privileges (B) ''If mms.cfg does not exist,'' open your '''Documents folder''', right-click > New > Text File and name the new file mms.cfg (3) Open mms.cfg from Documents into a text editor such as Notepad. Add this on its own line (I put it last): ProtectedMode=0 Save the file and close Notepad. (4) Hold down the Ctrl key and drag the mms.cfg file back to the Flash folder to make a copy there, keeping the original in Documents This change will take effect once the Flash plugin is completely unloaded, which may require exiting and restarting Firefox (allow a few minutes for all the Flash processes in memory to terminate after exiting Firefox).

Helpful Reply

I disabled Protected Mode, and Flash doesn't crash anymore on FF and I can use it normally. Embeds will work on FF with hardware accel enabled or disabled. They will work on Waterfox only with hardware accel disabled. Since disabling it slows down some elements on a website I use, I have reverted back to Firefox. Is there any issue in leaving Protected Mode forever disabled?

I disabled Protected Mode, and Flash doesn't crash anymore on FF and I can use it normally. Embeds will work on FF with hardware accel enabled or disabled. They will work on Waterfox only with hardware accel disabled. Since disabling it slows down some elements on a website I use, I have reverted back to Firefox. Is there any issue in leaving Protected Mode forever disabled?
jscher2000
  • Top 10 Contributor
3762 solutions 33335 answers

Hi Kelvets, my understanding of the benefit of the Protected Mode feature is that it isolates different Flash processes from one another which reduces the potential for a successful attack between Flash media from two different sites. Since most uses of Flash are noncritical (e.g., movies and games), I don't think this is important in day-to-day browsing. However, if you are using a Flash-based application to make purchases or submit confidential information, then you might want to close down other tabs using Flash until that is completed.

Hi Kelvets, my understanding of the benefit of the Protected Mode feature is that it isolates different Flash processes from one another which reduces the potential for a successful attack between Flash media from two different sites. Since most uses of Flash are noncritical (e.g., movies and games), I don't think this is important in day-to-day browsing. However, if you are using a Flash-based application to make purchases or submit confidential information, then you might want to close down other tabs using Flash until that is completed.
MarkVictor 0 solutions 15 answers

Interesting that when I installed Waterfox, Flash doesn't crash anymore in Firefox. It's still running the same Flash version. However, I have also disabled protected mode. One website, 7online.com , still shows only a very small footprint on the page for the Flash plugin element (in this case, videos). However, I was able to switch to full screen, and got the weather forecast (had to take a bit of a break, eh?!). YouTube and WhiteHouse.gov functioned normally.

Flash is installed on my computer both as 32-bit and 64-bit in separate branches of c:\Windows. I modified both mms.cfg files, backing up the original as mms.cfg.old before editing the mms.cfg file from another location (you're right, jscher2000; one needs to copy or move the file to a "user permitted" location; even though I am the Administrator on my computer, I can't open the file for editing from the containing folder). One should always back up an original file before editing it.

[I'm having some issues running both Firefox and Waterfox at the same time even though I've added the "-P" and "-no-remote" parameters to the command line in the start menu items. I'll have to find a way to have them not use the same profile — but that's a separate, but possibly related issue...?]

Now to test and see whether Waterfox is running Flash properly and whether it persists as a background process when/if Flash crashes. To that point:

Always make sure that there are no processes for WF, FF, and/or Flash before, during, and after making the changes that jscher2000 suggest (and which seem to work). Load Task Manager and check both the Processes tab and the Details tab. I had to restart my computer to get rid of about ten (yes, ten!!) "suspended" Flash processes which only showed up in the Details tab. I was unable to end these processes in the Details tab using End Task; however, restarting the computer did the trick. And I think it helped. (But I shouldn't have to do that... grrr...)

Interesting that when I installed Waterfox, Flash doesn't crash anymore in '''Firefox'''. It's still running the same Flash version. However, I have also disabled protected mode. One website, 7online.com , still shows only a very small footprint on the page for the Flash plugin element (in this case, videos). However, I was able to switch to full screen, and got the weather forecast (had to take a bit of a break, eh?!). YouTube and WhiteHouse.gov functioned normally. Flash is installed on my computer both as 32-bit and 64-bit in separate branches of c:\Windows. I modified both mms.cfg files, backing up the original as mms.cfg.old before editing the mms.cfg file from another location (you're right, jscher2000; one needs to copy or move the file to a "user permitted" location; even though I am the Administrator on my computer, I can't open the file for editing from the containing folder). One should always back up an original file before editing it. [I'm having some issues running both Firefox and Waterfox at the same time even though I've added the "-P" and "-no-remote" parameters to the command line in the start menu items. I'll have to find a way to have them not use the same profile — but that's a separate, but possibly related issue...?] Now to test and see whether Waterfox is running Flash properly and whether it persists as a background process when/if Flash crashes. To that point: Always make sure that there are no processes for WF, FF, and/or Flash before, during, and after making the changes that jscher2000 suggest (and which seem to work). Load Task Manager and check '''''both''''' the Processes tab ''and'' the Details tab. I had to restart my computer to get rid of about ten (yes, ten!!) "suspended" Flash processes which only showed up in the Details tab. I was unable to end these processes in the Details tab using End Task; however, restarting the computer did the trick. And I think it helped. (But I shouldn't have to do that... grrr...)

Modified by MarkVictor

MarkVictor 0 solutions 15 answers

Waterfox runs fine with the above changes made. No Flash crash.

Jscher2000: Can the changes you suggest be edited and posted in a general help area of Mozilla so that more Win8.1 users can have easier access to it? I think there might be enough evidence that your suggestions work to put it out for wider user inquiry. If this is done, please let me know the URL so that I can pass it on.

Sent 7online.com (WABC-TV New York) screenshots of their malfunctioning pages. Since I can't replicate the 7online.com issues on other pages, this is not a Mozilla/Flash problem, in my estimation.

Generally, the problems seem to be with FF and WF running Win8.1 OS, fully updated (including Flash). Don't have issues with Win7 and WinXp running FF 28. Will not upgrade those machines to v.29, but may try WF on the Win7 computer — unless one of you expert commenter/moderators advise otherwise. Don't think it wise to run WF with Xp+64bit... right?

I consider the above a workaround until Flash and/or Mozilla can get the Flash plugin to work without changing default settings.

And the "fix one and the other works" thing is a mystery to me...

Waterfox runs fine with the above changes made. No Flash crash. Jscher2000: Can the changes you suggest be edited and posted in a general help area of Mozilla so that more Win8.1 users can have easier access to it? I think there might be enough evidence that your suggestions work to put it out for wider user inquiry. If this is done, please let me know the URL so that I can pass it on. Sent 7online.com (WABC-TV New York) screenshots of their malfunctioning pages. Since I can't replicate the 7online.com issues on other pages, this is not a Mozilla/Flash problem, in my estimation. Generally, the problems seem to be with FF and WF running Win8.1 OS, fully updated (including Flash). Don't have issues with Win7 and WinXp running FF 28. Will not upgrade those machines to v.29, but may try WF on the Win7 computer — unless one of you expert commenter/moderators advise otherwise. Don't think it wise to run WF with Xp+64bit... right? I consider the above a workaround until Flash and/or Mozilla can get the Flash plugin to work without changing default settings. And the "fix one and the other works" thing is a mystery to me...

Modified by MarkVictor

jscher2000
  • Top 10 Contributor
3762 solutions 33335 answers

Hi MarkVictor, I'm sure there is a link to Adobe's page on protected mode somewhere in the Knowledge Base, but probably not detailed steps spelled out. I haven't reviewed all the Flash articles again.

I don't know whether Waterfox or other 64-bit executables can run on Windows XP. You should check with those sites on their system requirements.

In the long run, Mozilla is trying to eliminate the need for a Flash plugin by using a native player. You can read more about the Shumway project here: http://mozilla.github.io/shumway/

Hi MarkVictor, I'm sure there is a link to Adobe's page on protected mode somewhere in the Knowledge Base, but probably not detailed steps spelled out. I haven't reviewed all the Flash articles again. I don't know whether Waterfox or other 64-bit executables can run on Windows XP. You should check with those sites on their system requirements. In the long run, Mozilla is trying to eliminate the need for a Flash plugin by using a native player. You can read more about the Shumway project here: http://mozilla.github.io/shumway/