Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

firefox is blocking quickbooks online popups even after adding to the allowed list

  • 10 replies
  • 7 have this problem
  • 40 views
  • Last reply by cor-el

more options

after the recent update of quickbooks online, while using certain functions, a popup is apparently blocked by Firefox and I keep getting a message from qb that says: "uh-oh.Please unblock us. We use pop-ups for things like adding new customers, showing alerts, and more. It's simple. Here's what to do: Click Options or Preferences in the upper right of your browser. Select Allow pop-ups for qbo.intuit.com. the address of the site blocked actually is lvdc.qbo.intuit.com. I have also added that to the allow list. The popups continue to be blocked and this annoying message will not go away unless I close out completely, re-open and accomplish tasks that do not involve customers. As soon a I need to do a task with a customer, the demon popup messages reappear.

Chosen solution

The point is that Firefox stops showing pop-up after this limit of 20 has been reached. You can try to increase this maximum to a higher value and set the dom.popup_maximum pref to 100 or more (don't go too high) to see if that makes the pop-ups reappear.

Read this answer in context 👍 0

All Replies (10)

more options

This problem could be caused by the AdBlock Plus extension installed on your Firefox.
Please disable this extension and then see if the issue continues.

Please report back soon with the results.

more options

I disabled the adblocker add-on. The problem persists.

more options

Can you please try starting Firefox in Safe Mode? (More Details)

more options

Any suggestions going forward. I really like adblocker A LOT!!

more options

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window.

You can inspect and manage the permissions for all domains on the about:permissions page or for the domain in the currently selected tab via these steps:

  • Click the "Site Identity Button" (globe/padlock) on the location bar
  • Click "More Information" to open Page Info
  • Go to the Permissions tab
  • Tools > Page Info > Permissions
more options

Did safe mode stop the issue from occurring?

If so, please refer to this article for further instructions.

more options

Hi, I have the same problem with MF 26.0. However I have set remember everything in Privacy, after restart of MF the popup allowed list is empty. I have tested also with uninstalled ADD BLOCK PLUS. No success. Also the last login cookies are deleted/destroyed. I think it is bug of MF 26.0. Does some one have solution?

more options

It is possible that you run into this pop-up maximum (the default value is 20).

more options

the popup_max is set on default ( 20 ) the same issue

more options

Chosen Solution

The point is that Firefox stops showing pop-up after this limit of 20 has been reached. You can try to increase this maximum to a higher value and set the dom.popup_maximum pref to 100 or more (don't go too high) to see if that makes the pop-ups reappear.