X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

All add-ons & plugins are in disable mode!

Posted

hi everyone i'm using firefox ESR version

a few days ago,firefox updated to 24.2.0 and after restart, all addons & plugins disabled shown & all icons changed to blue puzzle piece icon,while they are work correctly !

instance,in "adblock plus" written (disabled) but it works on sites. I tried other option like "enable", "disable" and "find update" but take no action

win 7 64bit,ff esr 24.2.0 any solution?

Chosen solution

It is possible that there is a problem with the file(s) that store the extensions registry.

Delete the extensions.* files (e.g. extensions.sqlite, extensions.ini) and compatibility.ini in the Firefox profile folder to reset the extensions registry.

New files will be created when required.

See "Corrupt extension files":

If you see disabled or not compatible extensions in "Firefox/Tools > Add-ons > Extensions" then click the Tools button at the left end side of the Search Bar to check if there is a compatibility update available.

If this hasn't helped then also delete the addons.sqlite file.

Read this answer in context 1
Post a Reply

Additional System Details

Installed Plug-ins

  • Google Update
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • The plugin allows you to have a better experience with Microsoft Lync
  • Autofill Engine for Gecko and Webkit-based web browsers
  • 5.1.20913.0
  • Shockwave Flash 11.7 r700
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.03
  • Adobe Shockwave for Director Netscape plug-in, version 12.0.2.122
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • Yahoo Application State Plugin version 1.0.0.7
  • np-mswmp

Application

  • Firefox 24.2.0
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20100101 Firefox/24.0
  • Support URL: https://support.mozilla.org/1/firefox/24.2.0/WINNT/en-US/

Extensions

  • Adblock Plus 2.4 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Adblock Plus Pop-up Addon 0.9.1 (adblockpopups@jessehakanen.net)
  • All-in-One Sidebar 0.7.18 ({097d3191-e6fa-4728-9826-b533d755359d})
  • Dangerous Websites Blocker 14.0.0.4764 (content_blocker@kaspersky.com)
  • DownloadHelper 4.9.21 ({b9db16a4-6edc-47ec-a1f4-b86292ed211d})
  • Easy YouTube Video Downloader 6.8 ({c0c9a2c7-2e5c-4447-bc53-97718bc91e1b})
  • feedly 16.0.528 (feedly@devhd)
  • Flagfox 4.2.15 ({1018e4d6-728f-4b20-ad56-37578a4de76b})
  • Freemake Youtube Download Button 1.0.0 (ytfmdownloader@gmail.com)
  • Google Shortcuts 2.1.7.1 ({5C46D283-ABDE-4dce-B83C-08881401921C})
  • IDM CC 7.3.65 (mozilla_cc@internetdownloadmanager.com)
  • Kaspersky URL Advisor 14.0.0.4764 (url_advisor@kaspersky.com)
  • NewScrollbars (aka NoiaScrollbars) 1.2.1 (NoiaScrollbars@ArisT2_Noia4dev)
  • Password Manager Autofill Engine 5.0.0.178 ({72CA2996-F580-47DF-98FF-0B853D09CEC8})
  • Pocket 3.0.4 (isreaditlater@ideashower.com)
  • Safe Money 14.0.0.4764 (online_banking@kaspersky.com)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Virtual Keyboard 14.0.0.4794 (virtual_keyboard@kaspersky.com)
  • Xmarks 4.2.1 (foxmarks@kei.com)
  • 365Scores Notifier 1.1.2 (Firefox@365scores.com) (Inactive)
  • Anti-Banner 14.0.0.4764 (anti_banner@kaspersky.com) (Inactive)
  • Freecorder 7.0.0.7 (addon@freecorder.com) (Inactive)
  • Freemake Video Downloader Plugin 1.0.0 (fmdownloader@gmail.com) (Inactive)
  • NoScript 2.6.8.6 ({73a6fe31-595d-460b-a920-fcc0f8843232}) (Inactive)
  • SaveFrom.net helper 2.23 (helper@savefrom.net) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce 9600 GT
  • adapterDescription2:
  • adapterDeviceID: 0x0622
  • adapterDeviceID2:
  • adapterDrivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterDrivers2:
  • adapterRAM: 1024
  • adapterRAM2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16571
  • driverDate: 10-23-2013
  • driverDate2:
  • driverVersion: 9.18.13.3165
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce 9600 GT Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.privatebrowsing.dont_prompt_on_enter: True
  • browser.search.useDBForOrder: True
  • browser.startup.homepage: http://www.google.com/
  • browser.startup.homepage_override.buildID: 20131205180928
  • browser.startup.homepage_override.mstone: 24.2.0
  • dom.max_chrome_script_run_time: 0
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 24.2.0
  • gfx.direct3d.checkDX10: False
  • gfx.direct3d.last_used_feature_level_idx: 1
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1387288024
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.sanitize.migrateFx3Prefs: True
  • security.enable_tls: False
  • security.warn_viewing_mixed: False
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1386960731

Misc

  • User JS: Yes
  • Accessibility: No
debjanichatterjee 2 solutions 38 answers

Hi,

Firefox is stuck in Safe Mode

Hope this helps

Was this helpful to you? 0
Reply
cor-el
  • Top 10 Contributor
  • Moderator
10753 solutions 96760 answers

Chosen Solution

It is possible that there is a problem with the file(s) that store the extensions registry.

Delete the extensions.* files (e.g. extensions.sqlite, extensions.ini) and compatibility.ini in the Firefox profile folder to reset the extensions registry.

New files will be created when required.

See "Corrupt extension files":

If you see disabled or not compatible extensions in "Firefox/Tools > Add-ons > Extensions" then click the Tools button at the left end side of the Search Bar to check if there is a compatibility update available.

If this hasn't helped then also delete the addons.sqlite file.

Was this helpful to you? 1
Reply

Question owner

@debjanichatterjee tnx for your reply but my addons or plugins not in gray like in safe mode just written disabled & option not work but addons & plugins are working in pages!!

Modified by mohammad_87

Was this helpful to you?
Reply
Pranay Moluguri 2 solutions 26 answers

Could you post a screenshot please.. Will be very much helpful in understanding and to solve the issue

Was this helpful to you?
Reply

Helpful Reply

@cor-el.

i did all of them. after restart,i accepted to install for all add ons but "disabled" appears again.(like first pic)

i tried to reinstall add ons in randomize. after reinstalling "AIO sidebar" problem solved !

"all-in-one side bar" was problem without any report !! i don't understand why?

when ff updated to 24.2.0, just reported "kaspersky password manager" is not compatible & i've updated it. "AIO Sidebar" was updated too.

note:if "AIO" is installed,when user goes to addons,they will be shown by "AIO".(like first pic)

The problem is solved now (second pic)

(Maybe cor-el's solution was effective)

Thank you guys

Modified by mohammad_87

Was this helpful to you? 1
Reply
cor-el
  • Top 10 Contributor
  • Moderator
10753 solutions 96760 answers

You can check for problems with preferences.

Rename or delete the prefs.js file and possible numbered prefs-##.js and user.js files to reset all prefs to the default value.

You can also check for issue caused by one of the extensions.

Was this helpful to you? 0
Reply
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.