X
Tap here to go to the mobile version of the site.

Support Forum

How to disconnect "search suggest"? The "browser.search.suggest.enabled = false" function doesn't work!

Posted

Even at obvious shutdown of "search suggest", the browser continues to send requests to the search engine chosen by me. It is a bug or spy function?

Even at obvious shutdown of "search suggest", the browser continues to send requests to the search engine chosen by me. It is a bug or spy function?

Chosen solution

Due to a completely unrelated topic, I think I discovered the cause of this. Maybe you already found it in the past 5 months but just in case:

When you click in the search box, Firefox opens a connection to your search engine. It doesn't send anything, but this allows you to get a response more quickly once you submit your search. This is called a "speculative connection" and apparently appeared in Firefox around Firefox 15.

Can you test the following approach to turning this off? This sets the cap on the number of such connections to zero:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste specu and pause while the list is filtered

(3) Double-click the network.http.speculative-parallel-limit and set it to 0 (zero).

Does that work?

Read this answer in context 1

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.2; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/32.0.1667.0 Safari/537.36

More Information

jscher2000
  • Top 10 Contributor
6133 solutions 50432 answers

Could you describe where you have this problem? For example:

  • Firefox built-in search bar (typically has the "g" icon at the left)
  • Firefox built-in home page (about:home)
  • Third party search bar
  • Search engine page

The setting in the Manage Search Engines dialog should take care of the first two.

Could you describe where you have this problem? For example: * Firefox built-in search bar (typically has the "g" icon at the left) * Firefox built-in home page (about:home) * Third party search bar * Search engine page The setting in the Manage Search Engines dialog should take care of the first two.
jscher2000
  • Top 10 Contributor
6133 solutions 50432 answers

Helpful Reply

Using the Fiddler proxy, I watched traffic for Bing in the search bar (because it's not encrypted, it's easier to watch).

With search suggestions turned on, I see numerous suggestion requests before I choose one and run the search:

GET http://api.bing.com/osjson.aspx?query=i&language=en-US&form=OSDJAS 200 OK (application/json)

GET http://api.bing.com/osjson.aspx?query=ipad&language=en-US&form=OSDJAS 200 OK (application/json)

GET http://api.bing.com/osjson.aspx?query=ipad+&language=en-US&form=OSDJAS 200 OK (application/json)

GET http://api.bing.com/osjson.aspx?query=ipad+surf&language=en-US&form=OSDJAS 200 OK (application/json)

GET http://api.bing.com/osjson.aspx?query=ipad+surfa&language=en-US&form=OSDJAS 200 OK (application/json)

GET http://api.bing.com/osjson.aspx?query=ipad+surfac&language=en-US&form=OSDJAS 200 OK (application/json)

GET http://api.bing.com/osjson.aspx?query=ipad+surface&language=en-US&form=OSDJAS 200 OK (application/json)

GET http://www.bing.com/search?q=ipad+surface+comparison&form=OSDSRC 200 OK (text/html)

With search suggestions turned off, it's just the search:

GET http://www.bing.com/search?q=kindle+vs.+surface&form=OSDSRC 200 OK (text/html)

Using the Fiddler proxy, I watched traffic for Bing in the search bar (because it's not encrypted, it's easier to watch). With search suggestions turned on, I see numerous suggestion requests before I choose one and run the search: GET http://api.bing''.''com/osjson.aspx?query=i&language=en-US&form=OSDJAS 200 OK (application/json) GET http://api.bing''.''com/osjson.aspx?query=ipad&language=en-US&form=OSDJAS 200 OK (application/json) GET http://api.bing''.''com/osjson.aspx?query=ipad+&language=en-US&form=OSDJAS 200 OK (application/json) GET http://api.bing''.''com/osjson.aspx?query=ipad+surf&language=en-US&form=OSDJAS 200 OK (application/json) GET http://api.bing''.''com/osjson.aspx?query=ipad+surfa&language=en-US&form=OSDJAS 200 OK (application/json) GET http://api.bing''.''com/osjson.aspx?query=ipad+surfac&language=en-US&form=OSDJAS 200 OK (application/json) GET http://api.bing''.''com/osjson.aspx?query=ipad+surface&language=en-US&form=OSDJAS 200 OK (application/json) GET http://www.bing''.''com/search?q=ipad+surface+comparison&form=OSDSRC 200 OK (text/html) With search suggestions turned off, it's just the search: GET http://www.bing''.''com/search?q=kindle+vs.+surface&form=OSDSRC 200 OK (text/html)
John99
  • Top 25 Contributor
  • Moderator
971 solutions 13138 answers

I am not sure I understand exactly what it is you are asking. What is it that you are trying to achieve ?

Note that there is an option from the search bar

Or are you concerned about what is shown from the address bar ?

I am not sure I understand exactly what it is you are asking. What is it that you are trying to achieve ? Note that there is an option from the search bar * USE: Search Bar -> down triangle ->|Manage Search engines...| -> []Show Search Suggestions * see [[How to use popular search suggestions in the Search Bar]] <br />The article even has a very short video clip Or are you concerned about what is shown from the address bar ? * [[Remove websites from the Awesome Bar suggestions]] <br /> & [[Awesome Bar - Find your bookmarks, history and tabs when you type in the address bar]] * also related [[Private Browsing - Browse the web without saving information about the sites you visit]] <br /> & [[Remove recent browsing, search and download history]]

Helpful Reply

The problem is observed in Firefox search bar. Addons not installed. The problem in Firefox (I checked) 25, 26, and "aurora". Possibly is present and at earlier versions.

Firefox shouldn't send information against my will! This principled position. I forbade the use the "Search Suggestions", removing the checkbox "Show Search Suggestions" (browser.search.suggest.enabled = false). Why Firefox sends the data? Me surprises that the option "Show Search Suggestions" (browser.search.suggest.enabled) intended for the solution of my problem doesn't work!

Besides I removed section: <Url type="application/x-suggestions+json" method="GET" template="https://www.google.com/complete/search?&q={searchTerms}"/> from the file "google.xml" (I use Google), but it didn't solve a problem.

At the moment, it is impossible to disable these requests :(

The problem is observed in Firefox search bar. Addons not installed. The problem in Firefox (I checked) 25, 26, and "aurora". Possibly is present and at earlier versions. Firefox shouldn't send information against my will! This principled position. I forbade the use the "Search Suggestions", removing the checkbox "Show Search Suggestions" (browser.search.suggest.enabled = false). Why Firefox sends the data? Me surprises that the option "Show Search Suggestions" (browser.search.suggest.enabled) intended for the solution of my problem doesn't work! Besides I removed section: <Url type="application/x-suggestions+json" method="GET" template="https://www.google.com/complete/search?&amp;q={searchTerms}"/> from the file "google.xml" (I use Google), but it didn't solve a problem. At the moment, it is impossible to disable these requests :(
jscher2000
  • Top 10 Contributor
6133 solutions 50432 answers

Hi Ugins, could you clarify something for me: how are you determining that Firefox is sending your query to Google to get suggestions? Does the "Suggestions" drop-down appear (example attached)? Or are you checking the traffic that Firefox is sending using an external tool (I don't think it shows up in the console)?

Hi Ugins, could you clarify something for me: how are you determining that Firefox is sending your query to Google to get suggestions? Does the "Suggestions" drop-down appear (example attached)? Or are you checking the traffic that Firefox is sending using an external tool (I don't think it shows up in the console)?

Question owner

Please see this video.

Please see this [http://bit.ly/19lEFqK video].
jscher2000
  • Top 10 Contributor
6133 solutions 50432 answers

Hi Ugins, it's strange that Firefox connects with Google when you click in the search box, but then doesn't send anything while you are typing (judging from the scroll bar in Wireshark not moving -- is that a reasonable conclusion). I don't know why that initial connection is made.

How did you get Wireshark to only show Firefox traffic? It's completely swamped with other traffic when I run it.

Hi Ugins, it's strange that Firefox connects with Google when you click in the search box, but then doesn't send anything while you are typing (judging from the scroll bar in Wireshark not moving -- is that a reasonable conclusion). I don't know why that initial connection is made. How did you get Wireshark to only show Firefox traffic? It's completely swamped with other traffic when I run it.

Question owner

I don't understand, why there is this activity...

Wireshark can't be adjusted on a traffic grabbing only from one program. I use "clean" the virtual machine, specially for the analysis, there the foreign traffic is absent.

As you can notice the abnormal activity specified by me really is present at Firefox. The additional indignation causes that FF is open source. What for?

May I report/ask Mozilla about this problem? How it is better to make it?

I don't understand, why there is this activity... Wireshark can't be adjusted on a traffic grabbing only from one program. I use "clean" the [https://www.virtualbox.org/ virtual machine], specially for the analysis, there the foreign traffic is absent. As you can notice the abnormal activity specified by me really is present at Firefox. The additional indignation causes that FF is open source. What for? May I report/ask Mozilla about this problem? How it is better to make it?
jscher2000
  • Top 10 Contributor
6133 solutions 50432 answers

Hi Ugins, you can file a bug on https://bugzilla.mozilla.org/

I think it will be easier to attach a log file than a video, however, the developers probably will suggest some kind of built-in log first rather than a Wireshark log.

After creating the new bug, you can post a link to it back here in the thread for future reference.

Hi Ugins, you can file a bug on https://bugzilla.mozilla.org/ I think it will be easier to attach a log file than a video, however, the developers probably will suggest some kind of built-in log first rather than a Wireshark log. After creating the new bug, you can post a link to it back here in the thread for future reference.

Question owner

Jscher2000 thanks, soon I will write about a problem to Mozilla.

Jscher2000 thanks, soon I will write about a problem to Mozilla.
jscher2000
  • Top 10 Contributor
6133 solutions 50432 answers

Chosen Solution

Due to a completely unrelated topic, I think I discovered the cause of this. Maybe you already found it in the past 5 months but just in case:

When you click in the search box, Firefox opens a connection to your search engine. It doesn't send anything, but this allows you to get a response more quickly once you submit your search. This is called a "speculative connection" and apparently appeared in Firefox around Firefox 15.

Can you test the following approach to turning this off? This sets the cap on the number of such connections to zero:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste specu and pause while the list is filtered

(3) Double-click the network.http.speculative-parallel-limit and set it to 0 (zero).

Does that work?

Due to a completely unrelated topic, I think I discovered the cause of this. Maybe you already found it in the past 5 months but just in case: When you click in the search box, Firefox opens a connection to your search engine. It doesn't send anything, but this allows you to get a response more quickly once you submit your search. This is called a "speculative connection" and apparently appeared in Firefox around Firefox 15. * http://bitsup.blogspot.com/2012/04/making-firefox-search-snappier.html Can you test the following approach to turning this off? This sets the cap on the number of such connections to zero: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter. Click the button promising to be careful. (2) In the search box above the list, type or paste '''specu''' and pause while the list is filtered (3) Double-click the '''network.http.speculative-parallel-limit''' and set it to 0 (zero). Does that work?

Question owner

Yes, this method work! Thank you very much!

Yes, this method work! Thank you very much!
John99
  • Top 25 Contributor
  • Moderator
971 solutions 13138 answers

Glad it helped.

Thanks for posting back. I will mark Jeff's answer as the thread solution.

Glad it helped. Thanks for posting back. I will mark Jeff's answer as the thread solution.