Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

When I right click on a report I need to run, I can not run it because a pop-up says "Back Forward Reload... Inspect Element ". How do I prevent this popup?

more options

I have created reports in Wal-Mart Retail Link. To run the report, you right click on the report and a pop-up comes up that allows you to modify, submit, delete or share this report. These options are hidden by another popup that gives the options to Back Forward Reload...Inspect Element (Q). It runs correctly when using Internet Explorer but not Firefox.

Chosen solution

Hi chaspc, do you know whether the site says it supports Firefox? This is a bit discouraging (from the login page):

Note: for best results, set your monitor resolution to at least 1024x768 and use Internet Explorer

There are still some sites built using Microsoft technologies that only work correctly in IE because the owner doesn't believe there is a business justification to update the sites for newer browsers...

Also, several users have posted about Crystal Reports — a component from SAP used on some sites built with Microsoft technologies — not working correctly in Firefox.

These problems are hard for volunteers to troubleshoot because we typically can't get "hands on" with these sites (sensitive business information, need an account, etc.) or the problems do not occur in simple demos.

Read this answer in context 👍 2

All Replies (8)

more options

Many site issues can be caused by corrupt cookies or cache. In order to try to fix these problems, the first step is to clear both cookies and the cache. Note: This will temporarily log you out of all sites you're logged in to. To clear cache and cookies do the following:

  1. Go to Firefox > History > Clear recent history or (if no Firefox button is shown) go to Tools > Clear recent history.
  2. Under "Time range to clear", select "Everything".
  3. Now, click the arrow next to Details to toggle the Details list active.
  4. From the details list, check Cache and Cookies and uncheck everything else.
  5. Now click the Clear now button.

Further information can be found in the Clear your cache, history and other personal information in Firefox article.

Did this fix your problems? Please report back soon.

more options

I still have this problem and I must be able to run these reports. What causes the right click to pull up the menu I described? Is there something in Firefox's Options that needs to be changed?

more options

Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • On Windows you can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac you can open Firefox 4.0+ in Safe Mode by holding the option key while starting Firefox.
  • On Linux you can open Firefox 4.0+ in Safe Mode by quitting Firefox and then going to your Terminal and running: firefox -safe-mode (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

FirefoxSafeMode

Once you get the pop-up, just select "'Start in Safe Mode" Safe Mode Fx 15 - Win

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

Please report back soon.

more options

Normally, Firefox will allow websites to present custom right-click context menus, but there is an option to always show the Firefox right-click menu. This may appear in front of the site's menu. On some sites, you can clear Firefox's menu and use the site's menu by pressing the Esc key once. On other sites, however, this will clear both menus.

If the Esc key trick doesn't work, or isn't convenient, you can review and modify this setting in the about:config preferences editor. Here's how:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste context and pause while the list is filtered

(3) If the dom.event.contextmenu.enabled preference is bolded and "user set" to false, double-click it to restore the default value of true.

Then, in another tab, test right-clicking again. Does it work normally now?

more options

The Esc key does remove the popup but the report I need to update/modify/submit using the site's popup will not run and unfortunately the user set default was already true. Any other suggestions?

more options

Chosen Solution

Hi chaspc, do you know whether the site says it supports Firefox? This is a bit discouraging (from the login page):

Note: for best results, set your monitor resolution to at least 1024x768 and use Internet Explorer

There are still some sites built using Microsoft technologies that only work correctly in IE because the owner doesn't believe there is a business justification to update the sites for newer browsers...

Also, several users have posted about Crystal Reports — a component from SAP used on some sites built with Microsoft technologies — not working correctly in Firefox.

These problems are hard for volunteers to troubleshoot because we typically can't get "hands on" with these sites (sensitive business information, need an account, etc.) or the problems do not occur in simple demos.

more options

Only IE7 & IE8 are fully supported. Thank you for getting me to start at the beginning and thus alleviate my headaches!

more options

I am glad to hear that your problem has been resolved.

If you have not already, please mark this thread as solved by marking the solution.
This will help other users experiencing similar problems find help faster and more efficiently.

I hope you continue using our products and thank you for contacting Mozilla Support.