X
Tap here to go to the mobile version of the site.

Support Forum

Is there a configuration setting that can be set so that various web pages CANNOT disable the ability to past data from clipboard into a field instead of typing

Posted

Occasionally various web sites have forms to be completed. Frequently, the password field, and the ability to paste from the clipboard is disabled. Since I use a password manager and generate passwords like mN0ZJ1Pj (example generated for the posting) it would like to be able to paste the password since there is less tendency for me to mistype.

I would like to know if there is a configuration setting that will cause the instructions from the web site to disable the ability to paste to be ignored. My position is that it is MY computer and I should be able to do whatever I want on my end.

Thank you.

Fred

Occasionally various web sites have forms to be completed. Frequently, the password field, and the ability to paste from the clipboard is disabled. Since I use a password manager and generate passwords like mN0ZJ1Pj (example generated for the posting) it would like to be able to paste the password since there is less tendency for me to mistype. I would like to know if there is a configuration setting that will cause the instructions from the web site to disable the ability to paste to be ignored. My position is that it is MY computer and I should be able to do whatever I want on my end. Thank you. Fred

Chosen solution

Go to the Mozilla Add-ons Web Page. There is an add-on called RightToClick. Look around. There's lots of good stuff here.

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.9 r900
  • VLC media player Web Plugin 2.1.0
  • Adobe Shockwave for Director Netscape plug-in, version 12.0.5.146
  • Citrix Online App Detector Plugin
  • Google Update
  • 5.1.20913.0
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • RealDownloader Plugin
  • Foxit Reader Plug-In For Firefox and Netscape
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Picasa plugin
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20100101 Firefox/25.0

More Information

FredMcD
  • Top 10 Contributor
1121 solutions 16257 answers

Chosen Solution

Go to the Mozilla Add-ons Web Page. There is an add-on called RightToClick. Look around. There's lots of good stuff here.

Go to the '''''[https://addons.mozilla.org/en-US/firefox/ Mozilla Add-ons Web Page]'''''. There is an add-on called '''''[https://addons.mozilla.org/en-US/firefox/addon/righttoclick/?src=external-Add-ons_Manager_Context_Menu-extension RightToClick]'''''. Look around. There's lots of good stuff here.

Modified by FredMcD

cor-el
  • Top 10 Contributor
  • Moderator
13064 solutions 119644 answers

It is possible that websites use JavaScript to monitor/handle each key press in such a form and aren't working properly with pasting data.

Did you try the shortcut key (Ctrl+V and Shift+Insert)?

It is possible that websites use JavaScript to monitor/handle each key press in such a form and aren't working properly with pasting data. Did you try the shortcut key (Ctrl+V and Shift+Insert)?

Question owner

Thank you. Right to click solved the problem. The only option I'm using at the moment: Disable page cut/copy/past/test-selection handlers.

This will make my life easier going forward.

Again, Thank you.

Fred

Thank you. Right to click solved the problem. The only option I'm using at the moment: Disable page cut/copy/past/test-selection handlers. This will make my life easier going forward. Again, Thank you. Fred

Question owner

I had tried Ctrl+v. The earlier post solved the problem - Right to Click.

Thank you.

Fred

I had tried Ctrl+v. The earlier post solved the problem - Right to Click. Thank you. Fred