X
Tap here to go to the mobile version of the site.

Support Forum

Firefox 25.01 - Pop-up blocker blocks pop-ups even after disabling it

Posted

I am using a greasemonkey userscript that, on using some keyboard shortcuts, triggers searching of all the links in a webpage that contain a certain keyword and automatically opens them in new tabs. The script seems to work fine except when the opened links are too many (say more than 5), then firefox displays the popup blocker bar and prevents the opening of any further links. I have tried adding the website to the exceptions list and even disabling the pop-up blocker, but it still keeps blocking the new tabs even though the exceptions list shows the added website. Is there a workaround for this problem? Any suggestions? Please help.

Thanks in advance.

I am using a greasemonkey userscript that, on using some keyboard shortcuts, triggers searching of all the links in a webpage that contain a certain keyword and automatically opens them in new tabs. The script seems to work fine except when the opened links are too many (say more than 5), then firefox displays the popup blocker bar and prevents the opening of any further links. I have tried adding the website to the exceptions list and even disabling the pop-up blocker, but it still keeps blocking the new tabs even though the exceptions list shows the added website. Is there a workaround for this problem? Any suggestions? Please help. Thanks in advance.

Chosen solution

It is possible that you run into this pop-up maximum (the default value is 20).

Read this answer in context 2

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.9 r900
  • Next Generation Java Plug-in 10.45.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • VerbAce-Pro NPAPI Support
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.03
  • Intel web components for Intel® Identity Protection Technology
  • Intel web components updater - Installs and updates the Intel web components
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20100101 Firefox/25.0

More Information

iamjayakumars 475 solutions 5852 answers
Make sure you disable the pop-up block *https://support.mozilla.org/en-US/kb/pop-blocker-settings-exceptions-troubleshooting Try with Adblock Plus Addons *https://addons.mozilla.org/en-US/firefox/addon/adblock-plus-pop-up-addon *https://addons.mozilla.org/en-US/firefox/addon/adblock-plus/

Question owner

Hi, thanks for the prompt reply. Already tried disabling the pop-up blocker. It doesn't work. It seems that disabling the pop-up blocker has no effect if the number of links opened programatically exceeds 20. I have found this limit (of 20) after checking my greasemonkey script with various websites. It opens 20 links in new tabs and the remaining links are blocked. I think firefox developers have set this specific limit to activate the pop-up blocker even if it was disabled. Any comments/suggestions/workarounds?

Hi, thanks for the prompt reply. Already tried disabling the pop-up blocker. It doesn't work. It seems that disabling the pop-up blocker has no effect if the number of links opened programatically exceeds '''20'''. I have found this limit (of 20) after checking my greasemonkey script with various websites. It opens 20 links in new tabs and the remaining links are blocked. I think firefox developers have set this specific limit to activate the pop-up blocker even if it was disabled. Any comments/suggestions/workarounds?
cor-el
  • Top 10 Contributor
  • Moderator
12920 solutions 118511 answers

Chosen Solution

It is possible that you run into this pop-up maximum (the default value is 20).

It is possible that you run into this pop-up maximum (the default value is 20). * http://kb.mozillazine.org/dom.popup_maximum

Question owner

Thanks for the really helpful reply, cor-el. Increasing the value of Dom.popup_maximum in about:config has solved my problem.

Thanks for the really helpful reply, cor-el. Increasing the value of Dom.popup_maximum in about:config has solved my problem.
cabc_iw 0 solutions 1 answers

Helpful Reply

I now have Firefox 26 and I still have this problem. Even with the blocker off it still blocks the popups I want and displays the yellow bar. Very very annoying....

Is there any kind of way to trace why the blocker decided to block a page?

I now have Firefox 26 and I still have this problem. Even with the blocker off it still blocks the popups I want and displays the yellow bar. Very very annoying.... Is there any kind of way to trace why the blocker decided to block a page?
cor-el
  • Top 10 Contributor
  • Moderator
12920 solutions 118511 answers

If you do open a lot of pop-ups on one specific page then you may run into the above mentioned maximum of 20 and you need to increase the value of that pref.


Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window.

You can inspect and manage the permissions for all domains on the about:permissions page or for the domain in the currently selected tab by clicking the "Site Identity Button" (globe/padlock) on the location bar and "More Information" to open "Page Info" and go to the Permissions tab.

You can delete the permissions.sqlite file to reset all permissions.

If you do open a lot of pop-ups on one specific page then you may run into the above mentioned maximum of 20 and you need to increase the value of that pref. ---- Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance). *Do NOT click the Reset button on the Safe Mode start window. *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes You can inspect and manage the permissions for all domains on the <b>about:permissions</b> page or for the domain in the currently selected tab by clicking the "Site Identity Button" (globe/padlock) on the location bar and "More Information" to open "Page Info" and go to the Permissions tab. *https://support.mozilla.org/kb/how-do-i-manage-website-permissions *Tools > Page Info > Permissions You can delete the permissions.sqlite file to reset all permissions.