Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I've cleared history, cleared cache but still websites are coming up in my browser for example www.p brings up pof and pornhub. How do I delete?

  • 6 replies
  • 12 have this problem
  • 14159 views
  • Last reply by Skweefie

more options

I've tried deleting the history from the firefox and selecting all of the boxes so that site preferences are supposed to be deleted. I've tried going to the options tab and using advanced network option to clear the cache. I don't understand why the site suggestions are still coming up in the address bar when I type any letter in there are still a range of sites that I have visited yet they don't show up in my history. CONFUSED MUCH?

Chosen solution

It's gone now, had to reinstall the whole firefox. That was very confusing. Don't know why that was happening! So it is solved, but not through anything Firefox could do, only by me removing the entire programme and reinstalling. Thanks for your help though. I didn't know about the 'forget this site' tool so I learned something today.  :)

Read this answer in context 👍 1

All Replies (6)

more options

You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History > Show All History" or "View > Sidebar > History") or via the about:permissions page.

Using "Forget About This Site" will remove all data stored in Firefox from that domain like bookmarks, cookies, passwords, cache, history, and exceptions, so be cautious and if you have a password or other data from that domain that you do not want to lose then make a note of those passwords and bookmarks.

You can't recover from this 'forget' unless you have a backup of the involved files.

It doesn't have any lasting effect, so if you revisit such a 'forgotten' website then data from that website will be saved once again.


You can delete the places.sqlite file to clear all the history.

more options

I tried the forget about this site and it is still coming up in the address bar when I type 'po' the two sites are still coming up. I am soooo confused. It happens with other sites too but these are the two that I don't want seen. I always use them in a private window too so I don't know how the hell they are still coming up.

more options

I've now gone to the start menu and deleted all temporary files making sure to check the right boxes and leave unchecked ones that I am meant to and still it is there. I don't want to have to just change to damn google chrome but I am at a loss as to how to get rid. Maybe if I remove firefox altogether and reinstall it might happen.

more options

Chosen Solution

It's gone now, had to reinstall the whole firefox. That was very confusing. Don't know why that was happening! So it is solved, but not through anything Firefox could do, only by me removing the entire programme and reinstalling. Thanks for your help though. I didn't know about the 'forget this site' tool so I learned something today.  :)

more options

Did you at any time delete the places.sqlite file in the Firefox profile folder?

You can use this button to go to the Firefox profile folder:

more options

Among all of my searching I didn't come across this so the short answer is no, I didn't find that sqlite file.  :)