Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why won't tabs stay open when broswer reopens? Worked fine in previous versions but since 'update' doesn't work. Ever.

more options

Version 25.0.1 When I close the browser, all my previous tabs are gone when I reopen it and it goes to the firefox homepage. I have my options set for reopening previous tabs, and I've reset this at least 10 times and it will not stay. When I reopen the browser, I get the firefox home page, and the option has been reset to their default. This is NOT a feature, this is a bug. One of my favorite features of firefox has been that I can have 3 or 4 tabs open, and each time I restart, I get those exact same tabs without having to click or hunt.

I am not the only one with this problem, I've checked with a few people I know who updated their system to 25.0.1 and they are getting the same thing.

Ideas? Please????

Chosen solution

Hello, be sure that in Privacy panel > Firefox will: is set to either Remember history or Use custom settings for history

also if Firefox will: is set to Use custom settings for history then make sure that Permanent Private Browsing mode is not selected

and

if Firefox will: is set to Use custom settings for history and Clear history when Firefox closes is selected, then click the Settings button and make sure that Browsing History is not selected

also, in your system details it seems that you have in your profile folder a User.js file. The user.js file does not exist by default. If you create the file, forget it, if you have not create the file, then try to delete the User.js file, to see if the problem goes away (some programs create the file also).


thank you

Read this answer in context 👍 0

All Replies (9)

more options

Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • On Windows you can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac you can open Firefox 4.0+ in Safe Mode by holding the option key while starting Firefox.
  • On Linux you can open Firefox 4.0+ in Safe Mode by quitting Firefox and then going to your Terminal and running: firefox -safe-mode (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

FirefoxSafeMode

Once you get the pop-up, just select "'Start in Safe Mode" Safe Mode Fx 15 - Win

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

Please report back soon.

more options

Thanks for the fast reply. I restarted in safe mode and the problem is still there. I restarted the computer as well, and then did safe-mode for FF and still the problem persists. Every time I change the option to "restart with previous tabs" and then close out the browser, the next time I start, it goes to the FF home page only, and I look at the options setting and sure-enough, it's been reset the ff home page.

Do you have any other ideas? No other changes have been made to my computer, I've not downloaded any new software programs, installed any programs, nor made any hardware changes of any kind. Virus and spyware scans are up to date as always and check out clean.

Thanks

more options

The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information.
Note: This will cause you to lose any Extensions and some Preferences.

  • Open websites will not be saved in Firefox versions lower than 25.

To Reset Firefox do the following:

  1. Go to Firefox > Help > Troubleshooting Information.
  2. Click the "Reset Firefox" button.
  3. Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish.
  4. Firefox will open with all factory defaults applied.

Further information can be found in the Refresh Firefox - reset add-ons and settings article.

Did this fix your problems? Please report back soon.

more options

Chosen Solution

Hello, be sure that in Privacy panel > Firefox will: is set to either Remember history or Use custom settings for history

also if Firefox will: is set to Use custom settings for history then make sure that Permanent Private Browsing mode is not selected

and

if Firefox will: is set to Use custom settings for history and Clear history when Firefox closes is selected, then click the Settings button and make sure that Browsing History is not selected

also, in your system details it seems that you have in your profile folder a User.js file. The user.js file does not exist by default. If you create the file, forget it, if you have not create the file, then try to delete the User.js file, to see if the problem goes away (some programs create the file also).


thank you

more options

Did a reset and thought problem was solved but it isn't. How do I find this ".js" file??? I did a search and found nothing.

more options

In case you are using "Clear history when Firefox closes":

  • do not clear the Browsing History

Note that clearing "Site Preferences" clears all exceptions for cookies, images, pop-up windows, software installation, and passwords.


You can check the browser.sessionstore.* prefs on the about:config page and reset user set (bold) browser.sessionstore.*prefs to the default value via the right-click context menu to make sure that Session Restore is enabled and working properly.

Does Firefox create a sessionstore.js file in the Firefox profile folder?

  • Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder)
more options

ok regarding first paragraph, I do NOT have 'clear history..." checked and never did.

I reset to default regarding the broswer.sessionstore,... mentioned in your second paragraph. All addons have been uninstalled. I still have the same problem and it's highly irritating.

There were two 'sessionstore.js files (one marked bak? I think). I deleted them both, then went back to options, checked to reopen pages from previous session, and closed browser. Restarted FF and it worked and reopened the three pages I had open. I am going to try and reinstall a couple of add-ons and see what happens. Maybe this has solved it. I'm not holding my breath....

cv

more options

Tentatively, I'd say the problem is solved. I've added back the three add-ons I had before, and so far everything is working like it USED TO. Nothing was updated so I don't understand why this happened in the first place. I hope it stays this way, thanks to all of you for your fast help in tracking this down for me. Great!

cv

more options

I am glad to hear that your problem has been resolved.

I hope you continue using our products and thank you for contacting Mozilla Support.