X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox 25.0.1 and Facebook have JavaScript issues

Posted

I am using Firefox 25.0.1 with Mac IOS 10.9 on my Macbook Air. When trying to get to Facebook, I am told that I have to enable JavaScript in my browser or go to the mobile site. I am given no instructions on enabling JavaScript, nor can I find JavaScript in my settings or add-ons. Safari does not have this issue, but I'd prefer to use Firefox. Unfortunately, a web search of this issue does not bring me any results. Is it just me?

Chosen solution

Google searching is telling me that others are having this same issue with Firefox 25.0.1. So far, the only thing that has worked for everyone has been to do a reset of Firefox by going to Firefox > Help > Troubleshooting Information > Reset Firefox.

I tried it and it worked for me! Not sure what the original problem was, but it seems to have been corrected at this time.

Read this answer in context 4
Post a Reply

Additional System Details

Application

  • User Agent:

More Information

jscher2000
  • Top 10 Contributor
2365 solutions 20923 answers

Helpful Reply

Firefox has a general on/off setting for JavaScript. If it was off, lots of sites would be giving you the same message. Since it's only on Facebook, I think something else might be the culprit here.

Your post didn't include any information on your add-ons, so I'll give some general advice.

Removing obsolete/conflicting/corrupted stored data

When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Bypass Firefox's Cache

Use Command+Shift+r to reload the page fresh from the server.

Alternately, you also can clear Firefox's cache completely using:

Firefox menu > Preferences > Advanced

On the Network mini-tab > Cached Web Content : "Clear Now"

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either:

  • right-click and choose View Page Info > Security > "View Cookies"
  • Tools menu > Page Info > Security > "View Cookies"
  • click the padlock or globe icon in the address bar > More Information > "View Cookies"

In the dialog that opens, you can remove the site's cookies individually.

Then try reloading the page. Does that help?

Testing for an extension conflict

Firefox's Safe Mode is a standard diagnostic tool to bypass interference by extensions (and some custom settings). More info: Troubleshoot Firefox issues using Safe Mode.

You can restart Firefox in Safe Mode using

Help > Restart with Add-ons Disabled (Flash will still work)

In the dialog, click "Start in Safe Mode" (not Reset)

Does Facebook work any better?

Was this helpful to you? 47
Reply

Helpful Reply

Thank you - all great advice. I went through your list and did each and every thing you suggested, but nothing solved the issue. I have gone through my settings and tweaked those, trying to load Facebook after each tweak, but still I am unable to use Firefox with Facebook. This just happened yesterday. Prior to that, I had no issues.

I also can not view Facebook on a PC using the same Firefox version, so I know it's not platform specific.

Was this helpful to you? 8
Reply

Chosen Solution

Google searching is telling me that others are having this same issue with Firefox 25.0.1. So far, the only thing that has worked for everyone has been to do a reset of Firefox by going to Firefox > Help > Troubleshooting Information > Reset Firefox.

I tried it and it worked for me! Not sure what the original problem was, but it seems to have been corrected at this time.

Modified by Lori

Was this helpful to you? 4
Reply
jscher2000
  • Top 10 Contributor
2365 solutions 20923 answers

Thank you for the update. The Reset feature create a folder on your desktop named Old Firefox Data. You might want to keep that for a few weeks in case you notice anything critical missing after the reset.

Also, it contains the prefs.js file which has many of your old custom settings, one of which might be the problem. If you're in a forensic mood some time, you could compare it with your new prefs.js file. To find that file use either:

  • Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table in the page, click the "Show in Finder" button. This is your new profile folder which has the new prefs.js file in it. Initially, pres.js is mostly blank, but as you use Firefox, many custom preferences (and also some data stored by Firefox as it goes about its business) will be added.

Was this helpful to you? 4
Reply
blackappy 0 solutions 1 answers

I was unable to enable javascript in 25.0.1 for a few frustrating minutes. My solution that worked was to go to:

about:config (posted in browser)

and change: javascript.enabled from false to true under the value column.

Modified by blackappy

Was this helpful to you? 12
Reply
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.