Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Google borks Firefox in Gmail

  • 54 replies
  • 18 have this problem
  • 3104 views
  • Last reply by Mick Lee

more options

Google, ever helpful, has replaced the mp3 attachment player in gmail with something that apparently only works in Chrome. In other browsers, it blames the browser for not being able to play the attachment, and immediately demands that you download the file (preferable to Drive) and get yourself an app to listen. I just want to listen to my damn voicemail without being forced to do it in Chrome nor to preserve it for all posterity. Has anyone got a workaround for this crap?

Chosen solution

Hi funksucker, you can use this dialog to confirm your version:

Help > About Firefox

The current version is 26.0.

In order for Firefox to play MP3 media on Windows XP without using a plugin, the DirectShow technology is used. Some users have turned it off so it is easier to download MP3s instead of having them play in the browser. To check your current setting:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste media. and pause while the list is filtered

(3) If the media.directshow.enabled preference is bolded, then it has been switched from its default value of true to false.

If it's set to true and the media won't play in Gmail, perhaps Google has decided not to support XP users any more??? Unfortunately, I cannot get "hands on" and test this problem myself, since I have Windows 7.

Edit: Removed stray text pasted in error.

Read this answer in context 👍 0

All Replies (20)

more options

Nothing has been done. It still doesn't work.

more options

My apologies. It has been solved. When I upgraded to Firefox 26, it now works.

more options

None of this works unless you upgrade to 26+.

more options

Yes it says the value is false. Please let me know if you hear of a fix.

more options

I'm running 26 & it's still not fixed

more options

All I can say is try all of the steps in this thread. I did them all and upgrading to version 26 was the last piece needed to make it work on my computer.

Frankly, it would be helpful if Google would stop this crap. The previous solution didn't need fixing.

more options

Hi funksucker, sorry I didn't complete the thought there. That setting needs to be TRUE, i.e., the default value. If set to FALSE, then the media definitely won't play.

more options

Unfortunately jscher2000's solution seems to be windoze specific since I find no reference to this config key on FF 26 on linux (ubuntu).

more options

Hi steeve.mccauley, on Linux Firefox can use GStreamer to play MP3s. I don't know which Linux platforms include GStreamer, which need an add-on, which need it enabled, etc., but for sure you need to find steps for GStreamer instead of DirectShow.

more options

Thanks jscher2000, I'll look into it. I do see media.gstreamer.enabled set to true.

more options

Still no good mate. I changed it to TRUE & restarted but email mp3 still won't play

more options

Hi funksucker, I'm not sure why yours isn't playing, if they are MP3-format. It's possible that an extension (maybe a media downloader?) is overriding the usual behavior, or that Google has stored a cookie which is altering how the page works. These are the usual recommendations for testing:

When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Clear Firefox's Cache

orange Firefox button (or Tools menu) > Options > Advanced

On the Network mini-tab > Cached Web Content : "Clear Now"

If you have a large hard drive, this might take a few minutes.

(2) Remove your Google cookies (save any pending work first). While viewing a page on the site, try either:

  • right-click and choose View Page Info > Security > "View Cookies"
  • Alt+t (open the classic Tools menu) > Page Info > Security > "View Cookies"

In the dialog that opens, you can remove the site's cookies individually.

Then try reloading the page, log back in, and try the sound file. Any improvement?

A way to rule out extensions as a potential issue is to try the same action in Firefox's Safe Mode. That's a standard diagnostic tool to bypass interference by extensions (and some custom settings). More info: Diagnose Firefox issues using Troubleshoot Mode.

You can restart Firefox in Safe Mode using

Help > Restart with Add-ons Disabled

In the dialog, click "Start in Safe Mode" (not Reset)

Any difference?

more options

You may be missing a specific codec for this mp3 file if you do not hear the sound.

Do other mp3 files work?

more options

I tried all of your recommendations - still no good :(

more options

cor-el I'm not sure what you mean. it won't play any mp3 file or any audio file i've tried. i'm a songwriter & have been collaborating all day with my co-writer sending me around 30 mp4 files. it's so annoying that i've had to download each one to hear it

more options

If it doesn't work with GStreamer enabled then you need to disable the related pref (media.gstreamer.enabled = false) and use another program or plugin (Gecko Media Player) to play the MP3 files.

more options

I have gstreamer support for mp3 (plays in totem, rhythmbox) but still cannot play html5 embedded mp3 audio. No problem with vorbis, wav, flac, but fails on mp3. Really not sure what is going on.

more options

I don't have gstreamer installed. i did what it says in your link & Microsoft® Windows Media Player Firefox Plugin is definitely not amongst my firefox plugins. I downloaded it but when i try to install it asks me if i wish to change, repair or remove. As if it's installed. Which it isn't  :/

more options

should i install gstreamer? I googled it but i'm confused as to which to download

more options

Hi funksucker, the gstreamer stuff is for Linux.

Because the Windows Media Player plugin installer is a few years old now, it is dropping the DLL into a folder that Firefox no longer checks by default. This article has the solution for that: Windows Media or other plugins stopped working after Firefox update.

  1. 1
  2. 2
  3. 3