X
Tap here to go to the mobile version of the site.

Support Forum

no sound from translate.google.com

Posted

On translate.google.com web page, there is an icon to listen to the word or phrase being spoken. This does not work on Firefox. It works on Google Chrome.

On translate.google.com web page, there is an icon to listen to the word or phrase being spoken. This does not work on Firefox. It works on Google Chrome.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.9 r900
  • Adobe Shockwave for Director Netscape plug-in, version 12.0.7.148
  • Google Update
  • Next Generation Java Plug-in 10.45.2 for Mozilla browsers
  • VLC media player Web Plugin 2.1.0
  • 5.1.20913.0
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.04
  • GEPlugin
  • Picasa plugin
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • PDF-XChange Viewer Netscape Gecko Plugin

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:26.0) Gecko/20100101 Firefox/26.0

More Information

ideato 893 solutions 6250 answers

Helpful Reply

Hello BahtSimpson, Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • On Windows you can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

FirefoxSafeMode

Once you get the pop-up, just select "'Start in Safe Mode" Safe Mode Fx 15 - Win

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

Thank you.

Hello BahtSimpson, '''Try Firefox Safe Mode''' to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons. ''(If you're not using it, switch to the Default theme.)'' * On Windows you can open Firefox 4.0+ in Safe Mode by holding the '''Shift''' key when you open the Firefox desktop or Start menu shortcut. * Or open the Help menu and click on the '''Restart with Add-ons Disabled...''' menu item while Firefox is running. [[Image:FirefoxSafeMode|width=520]] ''Once you get the pop-up, just select "'Start in Safe Mode"'' [[Image:Safe Mode Fx 15 - Win]] '''''If the issue is not present in Firefox Safe Mode''''', your problem is probably caused by an extension, and you need to figure out which one. Please follow the [[Troubleshooting extensions and themes]] article for that. ''To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.'' ''When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.'' Thank you.

Question owner

Hi ideato,

Thanks very much for your quick response.

I restarted Firefox with Add-ons disabled, but the problem remained.

I then created a fresh profile (run firefox.exe -p) and the problem was gone.


So now the question is, what is the difference between "Add-ons disabled" and a new profile?

I am using Firefox 26.0, the default theme, 12 plugins and <ahem> 92 extensions.

They all work happily together, apart from this problem which probably started several weeks ago.


If you like, I can post a list of all the Add-ons.


Regards,

Baht.

Hi ideato, Thanks very much for your quick response. I restarted Firefox with Add-ons disabled, but the problem remained. I then created a fresh profile (run firefox.exe -p) and the problem was gone. So now the question is, what is the difference between "Add-ons disabled" and a new profile? I am using Firefox 26.0, the default theme, 12 plugins and <ahem> 92 extensions. They all work happily together, apart from this problem which probably started several weeks ago. If you like, I can post a list of all the Add-ons. Regards, Baht.
ideato 893 solutions 6250 answers

Helpful Reply

Hello Baht, it is great that a new profile solve the issue. A lot of things is inside the profile that maybe be corrupted after some time in firefox !

see for more information and to transfer your data into new profile: Transferring data to a new profile - Firefox

Files and folders in the profile


thank you

Hello Baht, it is great that a new profile solve the issue. A lot of things is inside the profile that maybe be corrupted after some time in firefox ! see for more information and to transfer your data into new profile: [http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox Transferring data to a new profile - Firefox] [http://kb.mozillazine.org/Profile_folder_-_Firefox#Files_and_folders_in_the_profile Files and folders in the profile] thank you
jscher2000
  • Top 10 Contributor
8792 solutions 71899 answers

Did this problem just start in Firefox 26?

For me, Google Translate is using Flash to play the sound. If you had Flash set to "Ask to Activate" instead of "Always Activate" that could be a difference from the default settings in a new profile.

Most of the relevant preferences probably would be in the prefs.js files in the respective profile folders. Setting aside printer and date information, the file consists largely of preferences modified through the UI, or the about:config preferences editor, or by add-ons. Could be looking for a needle in a haystack, but if you want to look, that's the haystack I suggest starting with.

Did this problem just start in Firefox 26? For me, Google Translate is using Flash to play the sound. If you had Flash set to "Ask to Activate" instead of "Always Activate" that could be a difference from the default settings in a new profile. Most of the relevant preferences probably would be in the prefs.js files in the respective profile folders. Setting aside printer and date information, the file consists largely of preferences modified through the UI, or the about:config preferences editor, or by add-ons. Could be looking for a needle in a haystack, but if you want to look, that's the haystack I suggest starting with.

Question owner

Hi jscher2000,

No, I've already tried FF versions 25.0.1, 25 and 24 (with my current profile) and they all produce no sound with translate.google.com.

I was thinking of going back to even earlier versions, but then recalled that the new profile in 26 is OK, so thought I'd better re-add all my extensions to that profile.

Actually, one of my "important" extensions was broken in Firefox 26 (Download Manager Tweak) so I have reverted back to v 25.0.1.

A new profile in FF v 25.0.1 also produces sounds in translate.google.com

Regarding Flash, I thought you had hit on a winner there, as I had recently changed my Flash settings. But the current settings are:

Storage - Allow sites to save information on this computer Camera and mic - Ask me Playback - Ask me Advanced - Notify me to install


I have another PC - a Samsung Netbook - which suffers the exact same problem as I have described above, all of which relates to my desktop PC.

Finally (I write this about an hour after the previous comments), I have started up my old Acer Laptop, which is also running FF v 25.0.1 and has roughly the same extensions installed - 91, not 92.

However, translate.google works! Unbelievable!

So I am now investigating the differences between the 3 computers in order to find the problem.

One point to note is that rather than configure all 92 extensions on the Netbook (which I only recently acquired), what I did was to install them all and then copy the entire contents of the Desktop profile folder - including pref.js - to the profile folder on the Netbook.

All the extensions then appeared configured correctly on the Netbook, but also the problem with the sound was copied across.

I'll let you know what I find but if you have any thoughts, please post them.

Hi jscher2000, No, I've already tried FF versions 25.0.1, 25 and 24 (with my current profile) and they all produce no sound with translate.google.com. I was thinking of going back to even earlier versions, but then recalled that the new profile in 26 is OK, so thought I'd better re-add all my extensions to that profile. Actually, one of my "important" extensions was broken in Firefox 26 (Download Manager Tweak) so I have reverted back to v 25.0.1. A new profile in FF v 25.0.1 also produces sounds in translate.google.com Regarding Flash, I thought you had hit on a winner there, as I had recently changed my Flash settings. But the current settings are: Storage - Allow sites to save information on this computer Camera and mic - Ask me Playback - Ask me Advanced - Notify me to install I have another PC - a Samsung Netbook - which suffers the exact same problem as I have described above, all of which relates to my desktop PC. Finally (I write this about an hour after the previous comments), I have started up my old Acer Laptop, which is also running FF v 25.0.1 and has roughly the same extensions installed - 91, not 92. However, translate.google works! Unbelievable! So I am now investigating the differences between the 3 computers in order to find the problem. One point to note is that rather than configure all 92 extensions on the Netbook (which I only recently acquired), what I did was to install them all and then copy the entire contents of the Desktop profile folder - including pref.js - to the profile folder on the Netbook. All the extensions then appeared configured correctly on the Netbook, but also the problem with the sound was copied across. I'll let you know what I find but if you have any thoughts, please post them.

Question owner

Thanks for the links, ideato. I'm sure I've been to those web pages before!

As you can see from my long reply above, I'm looking into why one of my PCs works OK on translate.google.com (the old Laptop), but the Desktop and the new Netbook don't.

I don't like mysteries so will persevere with this for a while and report back.

But eventually I may just have to re-add and re-configure all my extensions on the Desktop and Netbook.

Thanks for the links, ideato. I'm sure I've been to those web pages before! As you can see from my long reply above, I'm looking into why one of my PCs works OK on translate.google.com (the old Laptop), but the Desktop and the new Netbook don't. I don't like mysteries so will persevere with this for a while and report back. But eventually I may just have to re-add and re-configure all my extensions on the Desktop and Netbook.