Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

FireFox still identifies pdfs as Foxit documents even though I'm opening them in Adobe Reader and uninstalled the Foxit trial and FF plugin years ago.

  • 3 replies
  • 3 have this problem
  • 1 view
  • Last reply by oranji

more options

When I click on a pdf file link in FireFox, the Windows open file dialogue opens, saying "You have chosen to open [filename]

which is: Foxit Reader PDF Document [filesize] from: [author]

What should FireFox do with this file? [selected radio button] Open with Adobe Reader

THERE IS NO PROBLEM OPENING THE FILE. It opens in Adobe Reader, in a window outside of Firefox, which is exactly what I have it set up to do. The problem is that it identifies the file as a "Foxit Reeader PDF Document," even though I uninstalled the Foxit trial and associated FireFox plugin ages ago, and Foxit does not appear anywhere on my computer in any way, shape or form (that I have access to). No Foxit in the file associations for Windows, or in the applications associations for FireFox. There is no Foxit plugin installed, and I even went and deleted what was left of the Foxit directory. Yet pdfs are still identified in FireFox as Foxit files, so FireFox must be storing this old info somewhere. How do I get rid of it?

BTW, files open in a browser window inside the browser in the other 3 browsers I have installed, so there is no open file dialogue, and I can't tell whether there is the same problem. When I check the properties of a pdf outside of FireFox (by rightclicking a pdf on my desktop, for example), it is identified as an Adobe Reader file. I have both Adobe Reader and Adobe Acrobat. I have two Adobe Acrobat plugins showing in FireFox (10.1.8.24 and 11.0.5.3). Should I have two? No plugins, extensions, or anything else by Foxit.

When I click on a pdf file link in FireFox, the Windows open file dialogue opens, saying "You have chosen to open [filename] which is: Foxit Reader PDF Document [filesize] from: [author] What should FireFox do with this file? [selected radio button] Open with Adobe Reader THERE IS NO PROBLEM OPENING THE FILE. It opens in Adobe Reader, in a window outside of Firefox, which is exactly what I have it set up to do. The problem is that it identifies the file as a "Foxit Reeader PDF Document," even though I uninstalled the Foxit trial and associated FireFox plugin ages ago, and Foxit does not appear anywhere on my computer in any way, shape or form (that I have access to). No Foxit in the file associations for Windows, or in the applications associations for FireFox. There is no Foxit plugin installed, and I even went and deleted what was left of the Foxit directory. Yet pdfs are still identified in FireFox as Foxit files, so FireFox must be storing this old info somewhere. How do I get rid of it? BTW, files open in a browser window inside the browser in the other 3 browsers I have installed, so there is no open file dialogue, and I can't tell whether there is the same problem. When I check the properties of a pdf outside of FireFox (by rightclicking a pdf on my desktop, for example), it is identified as an Adobe Reader file. I have both Adobe Reader and Adobe Acrobat. I have two Adobe Acrobat plugins showing in FireFox (10.1.8.24 and 11.0.5.3). Should I have two? No plugins, extensions, or anything else by Foxit.

All Replies (3)

more options

Most likely this information is in the mimeTypes.rdf file, which can accumulate a lot of obsolete information which occasionally does cause problems. You can rename the file and have Firefox rebuild it from scratch with only the current applications detected (as far as Firefox can tell from the Windows Registry).

Open your current Firefox settings (AKA Firefox profile) folder using

Help > Troubleshooting Information > "Show Folder" button

Switch back to Firefox and Exit

Pause while Firefox finishes its cleanup, then rename mimeTypes.rdf to something like mimeTypes.old

Restart Firefox. Presumably now it will forget all about Foxit. Unfortunately, it may also have forgotten some of your application preferences, but hopefully those won't take too long to reestablish.

more options

You can check the value of the plugin.disable_full_page_plugin_for_types pref on the about:config page and remove the application/pdf part if present or reset the pref to the default via the right-click context menu if you want to display PDF documents in Firefox with another application (i.e. not the built-in PDF Viewer).

See also:

more options

Hmm. That sort of solved the problem. It eliminated the dialogue box - now it just opens in Adobe Reader without the dialogue. Which is probably fine - it's faster, and I'd rarely need to save a document I hadn't viewed yet, or open it in Acrobat instead (I can just save it in Reader if that comes up). Can't tell whether it removed the Foxit designation.

It did disable the X to close the browsing history sidebar, and turned the menubar history button into a toggle instead. That's a bit annoying.