Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

FF won't enable Java when I try to bank online.

  • 2 replies
  • 11 have this problem
  • 2223 views
  • Last reply by aaclarke7

more options

I've been using Firefox to deposit checks online for about a year. My bank uses Java and Active X to upload scanned checks, and normally Firefox prompts me to activate them when I'm in the process of banking. This month, at the moment I'm normally prompted to activate Java, an error message comes up instead. It says:

"Unable to update files in cache.

Name: FlatBedScan

SecurityException: com.sun.deploy/net.JARSigningException: Found unsigned entry in resource: https://sso.fistservsco.com/WebCaptureWeb/jai_core.jar"

Is this become FF has blocked Java because of its security vulnerabilities? I can't figure out a way to unblock it. I've re-installed Java, run diagnostics on my scanner, and nothing works. Any help would be greatly appreciated!

Chosen solution

That is a message from the Java plugin itself about the JAR file from the site.

The only end-user workaround I saw mentioned in a web search was to "disable Java cache on endpoint machine." As a first step, though, it probably makes sense to clear the Java cache to ensure that you are running the latest version of the JAR from the site. This Oracle support article has the steps for that:

How do I clear the Java cache?

Any improvement?

Read this answer in context 👍 4

All Replies (2)

more options

Chosen Solution

That is a message from the Java plugin itself about the JAR file from the site.

The only end-user workaround I saw mentioned in a web search was to "disable Java cache on endpoint machine." As a first step, though, it probably makes sense to clear the Java cache to ensure that you are running the latest version of the JAR from the site. This Oracle support article has the steps for that:

How do I clear the Java cache?

Any improvement?

more options

I had tried clearing the cache before, to no avail. But disabling the cash totally fixed the problem! You're amazing! Thanks!