X
Tap here to go to the mobile version of the site.

Support Forum

cannot activate javascript after trying all fixes listed for version 25

Posted

After auto upgrade from ver 24 to ver 25, javascript stopped working in firefox and will not enable. Have tried every fix I could find in the forum plus deleting java and reloading it, removing all plugins except java, cleaning registry of all references to firefox and reloading it and several others. None work. My Internet Explorer and Chrome work fine on all sites and gmail where firefox will not. Any more suggestions. Thanks in advance. I running Windows Ultimate on AMD dual core with 4Gb memory. Worked fine with firefox version 24 prior to update.

After auto upgrade from ver 24 to ver 25, javascript stopped working in firefox and will not enable. Have tried every fix I could find in the forum plus deleting java and reloading it, removing all plugins except java, cleaning registry of all references to firefox and reloading it and several others. None work. My Internet Explorer and Chrome work fine on all sites and gmail where firefox will not. Any more suggestions. Thanks in advance. I running Windows Ultimate on AMD dual core with 4Gb memory. Worked fine with firefox version 24 prior to update.

Chosen solution

To avoid confusion:


JavaScript is built-in in Firefox, so if it isn't working properly then something is blocking JavaScript.
This can be an extension or your security software.


You can check the javascript.enabled pref on the about:config page.


Start Firefox in Safe Mode to check if one of the extensions (Firefox/Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window.
Read this answer in context 1

Additional System Details

Application

  • User Agent:

More Information

cor-el
  • Top 10 Contributor
  • Moderator
12902 solutions 118344 answers

Chosen Solution

To avoid confusion:


JavaScript is built-in in Firefox, so if it isn't working properly then something is blocking JavaScript.
This can be an extension or your security software.


You can check the javascript.enabled pref on the about:config page.


Start Firefox in Safe Mode to check if one of the extensions (Firefox/Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window.
To avoid confusion: *http://kb.mozillazine.org/JavaScript_is_not_Java *http://kb.mozillazine.org/JavaScript ---- JavaScript is built-in in Firefox, so if it isn't working properly then something is blocking JavaScript.<br /> This can be an extension or your security software. ---- You can check the javascript.enabled pref on the <b>about:config</b> page. *http://kb.mozillazine.org/about:config ---- Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Firefox/Tools > Add-ons > Appearance). *Do NOT click the Reset button on the Safe Mode start window. *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes

Modified by cor-el

Question owner

Did all the above, and in safe mode, extensions were disabled but still no Java enabled. Did troubleshooting and unchecked hardware acceleration, still no java enabled. Had already done this prior to my help request but did it again to no avail. Thanks for he help.

Did all the above, and in safe mode, extensions were disabled but still no Java enabled. Did troubleshooting and unchecked hardware acceleration, still no java enabled. Had already done this prior to my help request but did it again to no avail. Thanks for he help.
wytcld 1 solutions 3 answers

about:config showed that javascript.enabled was off in my case. Thing is, I never turned it off. Did a bit flip on its own? Or are other processes capable of messing in the configuration settings? From a user perspective, Javascript just suddenly stopped being there.

about:config showed that javascript.enabled was off in my case. Thing is, I never turned it off. Did a bit flip on its own? Or are other processes capable of messing in the configuration settings? From a user perspective, Javascript just suddenly stopped being there.