Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Web site opens in a new window but has no scroll bars

more options

Hi I am a new user, so am not yet fully aware of Firefox usage.

I use http://www.bbc.co.uk/news/ site many times every day. The site in general is mostly perfectly OK, but one of the links I use all the time doesn't behave in a usable way. The link on the main page is:

http://www.bbc.co.uk/news/business/market_data/ticker/markets/default.stm, which does open, but in a new window without scroll bars. I can re size the window, but not enough to view all the contents.

If I use the link address in a new tab, everything works fine and the scroll bars are present.

I am migrating from the Opera browser and in Opera, when I use the embedded link it does open a new window but does have the scroll bars present.

Is this a Firefox issue, or maybe the site is the source of this problem - I couldn't guess which.

BTW the BBC web site is region based, and for non UK users, it may serve totally different pages.

I have looked through a bunch of FF options, but so far haven't found anything that could be relevant to the problem.

Chosen solution

IMO, that website is setting the size of that popup windows too small, not leaving enough room for the page content when the viewer zooms the page in.

You can disable that feature using this preference in about:config.
dom.disable_window_move_resize
Double-click that preference to toggle it to true.

http://kb.mozillazine.org/About:config

Changing dom.disable_window_open_feature.scrollbars to true will override the website from hiding the scrollbars.

Read this answer in context 👍 2

All Replies (14)

more options

Hello,

The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information.
Note: This will cause you to lose any Extensions and some Preferences.

  • Open websites will not be saved in Firefox versions lower than 25.

To Reset Firefox do the following:

  1. Go to Firefox > Help > Troubleshooting Information.
  2. Click the "Reset Firefox" button.
  3. Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish.
  4. Firefox will open with all factory defaults applied.

Further information can be found in the Refresh Firefox - reset add-ons and settings article.

Did this fix your problems? Please report back to us!

Thank you.

more options

Hi Thanks for reply. I would be surprised if a reset does fix it, as I have only been using Firefox for 2 days. In any case, I will give it a go.

Well this Reset procedure lose my Secure Login extension data?

more options

Try in "safemode" i think the problem because of your extension " Stylish 1.3.3".

Profile RESET, delete everything but it backup all the data's into a folder, the folder created in Desktop in the name of "OLD PROFILE DATA"

more options

Hi I have tried disabling ALL of the extensions but the above problem was not effected in any way by that. Do you still feel the Reset is the way to go?

more options

Before reset, backup your profile datas

more options

Hi OK, have performed Reset operation. No difference to my problem.

Just to add something. As well as no scroll bars, I should also have said that scroll wheel doesn't scroll the content either.

I tried the problematic link after the Reset but before restoring any data - problem remains.

I have contacted the BBC technical department and reported the issue but I don't hold my breath waiting for an answer.

Modified by leshay

more options

How large is this pop-up window?

Can you attach a screenshot?

Use a compressed image type like PNG or JPG to save the screenshot.


Reset the page zoom on pages that cause problems.

  • View > Zoom > Reset (Ctrl+0 (zero); Command+0 on Mac)

If you have made changes to Advanced font settings like increasing the minimum/default font size then try the default minimum setting "none" and the default font size 16 in case the current setting is causing problems.

  • Tools > Options > Content : Fonts & Colors > Advanced > Minimum Font Size (none)

Make sure that you allow pages to choose their own fonts.

  • Tools > Options > Content : Fonts & Colors > Advanced: [X] "Allow pages to choose their own fonts, instead of my selections above"

It is better not to increase the minimum font size, but to use an extension to set the default page zoom to prevent issues with text not being displayed properly.

more options

Hi Attached image.

I do use various zooming/font changes, BUT, as I mentioned above, I have the same issue after performing a Reset to Firefox, before restoring any data, and with default zoom/fonts etc.

With the faulty window, the zoom still works, but of course, is of no use to see all of the page in a readable way.

more options

Chosen Solution

IMO, that website is setting the size of that popup windows too small, not leaving enough room for the page content when the viewer zooms the page in.

You can disable that feature using this preference in about:config.
dom.disable_window_move_resize
Double-click that preference to toggle it to true.

http://kb.mozillazine.org/About:config

Changing dom.disable_window_open_feature.scrollbars to true will override the website from hiding the scrollbars.

more options

Hi

Thanks for that.

dom.disable_window_open_feature.scroll bars to true

solved it. I didn't need the first one you listed.

Hopefully, this change won't rear any ugly heads in other web sites :)

Just to mention. I notice that the pop-up is in fact a second instance of Firefox as opposed to an embedded window in the first instance. Does that have any bearing on things?

Modified by leshay

more options

That's a "popup" window.

Firefox runs only one "instance" for all windows and tabs that are open -
i.e., one firefox.exe, unlike IE which opens another IEXPLORE.EXE for each ew window or Google Chrome which opens another new executable for each new tab

more options

Hi OK, its a pop-up, but when I shut down Firefox main window (the one with the main BBC page), then the pop-up remains open. That's why I thought it was a new instance.

more options

Make sure to use File > Exit or Firefox > Exit to close Firefox with all open windows at once, especially if you want to reopen tabs and windows from the previous session.

more options

Easy to misunderstand the relationship between"instances" and windows.

If you would use File > Exit or Exit from the orange Firefox button, all the windows would close, including popup windows and any "dialog" windows like Options or Downloads, that might be open with the "main window".