X
Tap here to go to the mobile version of the site.

Support Forum

I'm finding a way to use config to re-configure firefox so that it shows %-encoding (escaped) URLs instead of unicode characters

Posted

When I load a URL into the address bar, anything escaped is converted to unicode.

I found the "feature" auto-decoding of URLs very annoying. IMPORTANT: If I edit the URL, which firefox converts to unicode, THE LINK GETS BROKEN!!!

You can't even type out some of those characters onto the keyboard. Also, Note "THE LINK GETS BROKEN." This explains that there are many people out there who DON'T like the decoding of escaped URLs in the address bar. Is there a way that I can make the address bar show escaped (With %-encoding) URLs instead of those with unicode?

When I load a URL into the address bar, anything escaped is converted to unicode. I found the "feature" auto-decoding of URLs very annoying. IMPORTANT: If I edit the URL, which firefox converts to unicode, THE LINK GETS BROKEN!!! You can't even type out some of those characters onto the keyboard. Also, Note "THE LINK GETS BROKEN." This explains that there are many people out there who DON'T like the decoding of escaped URLs in the address bar. Is there a way that I can make the address bar show escaped (With %-encoding) URLs instead of those with unicode?

Modified by MBisanz

Additional System Details

Installed Plug-ins

  • Google Update
  • Next Generation Java Plug-in 10.45.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.05
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • Firefox 25.0
  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:25.0) Gecko/20100101 Firefox/25.0
  • Support URL: https://support.mozilla.org/1/firefox/25.0/WINNT/en-US/

Extensions

  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • URL Escape and Unescape initial.rev7.1 (jid0-097M95XGurA3cxHEMeBVBRCOGCU@jetpack)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce 210
  • adapterDescription2:
  • adapterDeviceID: 0x0a65
  • adapterDeviceID2:
  • adapterDrivers: nvd3dum nvwgf2um,nvwgf2um
  • adapterDrivers2:
  • adapterRAM: 512
  • adapterRAM2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • clearTypeParameters: Gamma: 1800 Pixel Structure: RGB ClearType Level: 50 Enhanced Contrast: 0
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16571
  • driverDate: 6-21-2013
  • driverDate2:
  • driverVersion: 9.18.13.2049
  • driverVersion2:
  • info: {u'AzureContentBackend': u'direct2d', u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce 210 Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.sessionstore.upgradeBackup.latestBuildID: 20131025151332
  • browser.startup.homepage_override.buildID: 20131025151332
  • browser.startup.homepage_override.mstone: 25.0
  • browser.tabs.warnOnClose: False
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 25.0
  • gfx.direct3d.last_used_feature_level_idx: 0
  • network.cookie.prefsMigrated: True
  • network.IDN_show_punycode: True
  • places.database.lastMaintenance: 1383529511
  • places.history.enabled: False
  • places.history.expiration.transient_current_max_pages: 79627
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 0
  • storage.vacuum.last.index: 0
  • storage.vacuum.last.places.sqlite: 1383529511

Misc

  • User JS: No
  • Accessibility: Yes
gnittala 25 solutions 307 answers

Hello,

Can you please confirm that you are looking to ensure that the URL location bar in Firefox displays the Unicode characters of the URL instead of escaping them ( with % and the corresponding Unicode value).

If there is a URL where this is happening that you can provide, it will help in the investigation of the issue and suggesting possible solutions.

Thank you

Hello, Can you please confirm that you are looking to ensure that the URL location bar in Firefox displays the Unicode characters of the URL instead of escaping them ( with % and the corresponding Unicode value). If there is a URL where this is happening that you can provide, it will help in the investigation of the issue and suggesting possible solutions. Thank you
cor-el
  • Top 10 Contributor
  • Moderator
17474 solutions 157940 answers

The OP wants the opposite: to see the escaped characters when they were entered that way and not the unescaped Unicode representation.
It is hard to see which web page is meant when you would have escaped characters visible as you wouldn't notice a slight typo, but you would see it easier when you get the actual characters.
So this is done for security reasons the prevent phishing issues and redirecting to malicious websites.

There is a difference between using unescape() and using decodeUri() or decodeURIComponent()

The OP wants the opposite: to see the escaped characters when they were entered that way and not the unescaped Unicode representation.<br /> It is hard to see which web page is meant when you would have escaped characters visible as you wouldn't notice a slight typo, but you would see it easier when you get the actual characters.<br /> So this is done for security reasons the prevent phishing issues and redirecting to malicious websites. There is a difference between using unescape() and using decodeUri() or decodeURIComponent() *https://developer.mozilla.org/en-US/docs/Web/JavaScript/Reference/Global_Objects/decodeURI

Question owner

I don't really care how hard the URL is to read. I just want the ESCAPED characters and NOT the unescaped Unicode version.

Instead of:

http://en.wikipedia.org/wiki/User:Æon

I'm trying to get firefox to display:

http://en.wikipedia.org/wiki/User:%C3%86on.

I don't really care how hard the URL is to read. I just want the ESCAPED characters and '''''NOT''''' the unescaped Unicode version. Instead of: http://en.wikipedia.org/wiki/User:Æon I'm trying to get firefox to display: http://en.wikipedia.org/wiki/User:%C3%86on.
cor-el
  • Top 10 Contributor
  • Moderator
17474 solutions 157940 answers

Firefox doesn't show the unescaped representation of URLs that have Unicode character in the location bar.
You would have to copy the URL to the clipboard and paste it elsewhere to see the escaped code.
Note that you can paste the URL in the location bar in place (Ctrl+A and Ctrl+V).

Firefox doesn't show the unescaped representation of URLs that have Unicode character in the location bar.<br /> You would have to copy the URL to the clipboard and paste it elsewhere to see the escaped code.<br /> Note that you can paste the URL in the location bar in place (Ctrl+A and Ctrl+V).

Question owner

I KNOW that Firefox doesn't show escapes in the address bar. I'm trying to MAKE it show escapes instead of the HARD-TO-TYPE decoded link. I personally like escapes better so that I can easily TYPE the address in to the bar. If you could give me a way to do this, it would be really helpful :-)

By the way, IE does (with a few exceptions) NOT show decoded Unicode characters, instead good old escapes.

Maybe on later versions of Firefox, you could add a toggle near the address bar that allows users to pick whether they want to see the escapes or the decoded Unicode URL rendering in the address bar. THAT would be a BIG help, because it suits my needs and others' too!

I KNOW that Firefox doesn't show escapes in the address bar. I'm trying to MAKE it show escapes instead of the HARD-TO-TYPE decoded link. I personally like escapes better so that I can easily TYPE the address in to the bar. If you could give me a way to do this, it would be really helpful :-) By the way, IE does (with a few exceptions) '''''NOT''''' show decoded Unicode characters, instead good old escapes. Maybe on later versions of Firefox, '''you could add a toggle near the address bar that allows users to pick''' whether they want to see the escapes or the decoded Unicode URL rendering in the address bar. THAT would be a BIG help, because it suits my needs and others' too!

Modified by MBisanz