Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I keep being redirected to the US version of a site rather than the original site!

  • 3 replies
  • 2 have this problem
  • 29595 views
  • Last reply by jvitez

more options

Recently I got hooked on reading articles from a UK site, but recently when I click on article links I'm automatically redirected to the American site and its content instead! I live in the US but hate the American site articles and much prefer the British ones. Initially my only solution was to stop the article while loading in order to remain on the desired article link but as of late that fails and I am automatically redirected to the American pages instead (ugh...).

I currently use Firefox 25.0 on Windows 7 Home Premium and have checked the "Warn me when websites try to redirect or reload the page" box under the Tools > Options > Advanced > General > Accessibility section but was still redirected. I have also installed the add-on Refresh Blocker v0.8 but was still redirected. The website is http://www.denofgeek.com but when I select an article on their main page or categories I'm redirected to the http://www.denofgeek.us "equivalent". As a precaution I have run a malware scan but came up clean and have deleted all cookies and temporary internet files, but once again it was all in vain.

Is there anything else I can do to avoid redirection? Or has this site officially lost a reader? Any help is well appreciated.

Chosen solution

I'm not sure why you are being redirected but here are some thoughts:

(1) In case your preference for .us is stored in a cookie -- rather than an account setting -- try clearing cookies for the site (this likely will terminate your session, so save any pending work first). While viewing a page on the site, try either:

  • click the globe or padlock in the address bar > More Information > Security > "View Cookies"
  • right-click the page > View Page Info > Security > "View Cookies"
  • Tools menu > Page Info > Security > "View Cookies"

In the dialog that opens, you can remove the site's cookies individually.

Any change when navigating from the home page?

(2) If you granted the site permission to access your location, turn that off. You can access site-specific permissions while viewing a page on the site using the Page Info dialog. Either:

  • click the globe or padlock in the address bar > More Information > Permissions
  • right-click the page > View Page Info > Permissions
  • Tools menu > Page Info > Permissions

(See screen shot regarding Location permission)

(3) If the site uses your preferred language to redirect, you could add en-GB and re-order your languages. However, this could lead to strange results on other sites. If you want to try it, access the Languages dialog from Content options here:

orange Firefox button (or Tools menu) > Options > Content > Choose button

Read this answer in context 👍 3

All Replies (3)

more options

Chosen Solution

I'm not sure why you are being redirected but here are some thoughts:

(1) In case your preference for .us is stored in a cookie -- rather than an account setting -- try clearing cookies for the site (this likely will terminate your session, so save any pending work first). While viewing a page on the site, try either:

  • click the globe or padlock in the address bar > More Information > Security > "View Cookies"
  • right-click the page > View Page Info > Security > "View Cookies"
  • Tools menu > Page Info > Security > "View Cookies"

In the dialog that opens, you can remove the site's cookies individually.

Any change when navigating from the home page?

(2) If you granted the site permission to access your location, turn that off. You can access site-specific permissions while viewing a page on the site using the Page Info dialog. Either:

  • click the globe or padlock in the address bar > More Information > Permissions
  • right-click the page > View Page Info > Permissions
  • Tools menu > Page Info > Permissions

(See screen shot regarding Location permission)

(3) If the site uses your preferred language to redirect, you could add en-GB and re-order your languages. However, this could lead to strange results on other sites. If you want to try it, access the Languages dialog from Content options here:

orange Firefox button (or Tools menu) > Options > Content > Choose button

more options

By the way, "Updated Ad Blocker for Firefox 11+" has not been updated for a very long time. The "Adblock Plus" extension now is much more current and may work better for you. (I don't use either one myself.)

more options

Thank you for your reply! Solution 1 worked like a charm, but to prevent this from happening I went with your advice #2 and blocked access to my location.

I appreciate the help :)