Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox always opens all tabs that were opened when last closed

  • 9 replies
  • 7 have this problem
  • 16662 views
  • Last reply by cor-el

more options

Firefox, out of the blue, started to always show my tabs from the last session when it is started. I checked that Firefox not listed in the task manager list after closing. So I tried the following:

- changing the option "when Firefox starts" to all three of the available choices - change the browser.startup.page setting to 0 manually via "About:config" - starting Firefox in safe mode.

None of these changed the behavior. It still opens the tabs that were last opened.

I am running V25.0. Any suggestions? This is a major annoyance.

Chosen solution

You can check if you have an user.js file in the Firefox profile folder that sets the browser.sessionstore.resume_session_once pref to true.


The user.js file is only present if you or other software has created it, so normally it wouldn't be there. you can check its content with a plain text editor if you didn't create this file yourself.

The user.js file is read each time you start Firefox and initializes preferences to the value specified in this file, so preferences set via user.js can only be changed temporarily for the current session.

Read this answer in context 👍 0

All Replies (9)

more options

Hello,

Please make sure that you have not activated Firefox's restore tabs feature. See the article here:

Configuring session restore

If it is enabled then you can disable it by following the instructions in that article.

I hope that helps. Let me know if not.

EDIT: sorry I linked to the wrong article. Fixed now.

Modified by Ed

more options

Thanks for responding. When I wrote that I tried "changing the option 'when Firefox starts' to all three of the available choices" that's what I had meant I had tried.

So that "configuring session restore" setting is definitely set to show my home page currently but Firefox still loads what ever windows were open when it was closed.

more options

Firefox will also automatically restore your previous session if it thinks it crashed (i.e., it did not shut down correctly). To see whether that is happening, you can change a setting so that instead of automatically restoring the session, Firefox display a list of windows and tabs. If you see that, it's a sure sign that Firefox did not shut down correctly and we can focus on figuring out why that's happening.

Here's how to make the change:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box in that tab, type or paste sessions and pause while the list is filtered

(3) Double-click browser.sessionstore.max_resumed_crashes and change the 1 to a 0 (a zero) and OK that.

(4) You can close this tab now.

Any difference at the next startup?

more options

Another user here had the same issue:

https://support.mozilla.org/en-US/questions/976043

It was solved by doing a Firefox Reset.

Refresh Firefox - reset add-ons and settings

Note that your bookmarks, history etc will be saved after the reset but you will need to reinstall your addons.

more options

Chosen Solution

You can check if you have an user.js file in the Firefox profile folder that sets the browser.sessionstore.resume_session_once pref to true.


The user.js file is only present if you or other software has created it, so normally it wouldn't be there. you can check its content with a plain text editor if you didn't create this file yourself.

The user.js file is read each time you start Firefox and initializes preferences to the value specified in this file, so preferences set via user.js can only be changed temporarily for the current session.

more options

Hi,

I finally got a chance to try browser.sessionstore.max_resumed_crashes. There was no difference upon reloading. It reloaded the tabs that were open when Firefox closed.

Modified by loondawg

more options

@cor-el - You nailed it. There was a user.js file which had the variable browser.sessionstore.resume_session_once pref to true.


Although I don't know when//how/why it was created, it also had a value from yahoo.ytff.general....


So I renamed user.js to user.old, restarted, and everything is back to normal.

Thank you very much for your help.

Modified by loondawg

more options

The mention of yahoo makes me think it might have been some kind of malware / junkware / unwanted toobar type software which was hijacking your browser settings.

I suggest running some scans to make sure you have got rid of anything nasty:

Also have a check through your windows installed programs and uninstall anything that looks suspicious or that you didn't install yourself.

Hopefully that will prevent the software that caused the original problem from hanging around and trying to make further changes.

Modified by Ed

more options

ytff is the Yahoo Toolbar for Firefox, so if you have or had this toolbar then it is likely that that added the entries to this file (there might be be a setting to disable this feature).