Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Google Cache Highlighting is gone AGAIN. Green Arrow is now disabled

  • 8 replies
  • 12 have this problem
  • 2591 views
  • Last reply by Andiamo53

more options

First Google took away preview panes. Now it took away green cache arrow. Re-starting Firefox with different profile doesn't help. Neither does "Google Cache Highlight Search Query Terms for HTTPS for Greasemonkey". In fact adding host line to disable HTTPS doesn't help either, so safe search is not the problem. Anybody got any other ideas?

Also, using default Google search engine, options button is disabled and advanced search link has disappeared. Is there a different Google search engine out there. I tried a few different ones from Mycroft but had no luck.

Chosen solution

Hi Andiamo53, are you the Andee Brwn who posted on the userscript discussions page?

If the triangles aren't working, but Greasemonkey is still running on Google, you could update the script. I just added a new option to replace the triangle with inline links. Maybe that will work around the problem you're having.

(I have to update the screen shots, but can't do that at the moment.)

Read this answer in context 👍 1

All Replies (8)

more options

This support forum is for Firefox issue only. For Google support, please contact them.

more options

Andi, I just checked and I still see the green arrows for cached pages.

Try clearing all your Firefox cookies and cache then do another Google search.

Many site issues can be caused by corrupt cookies or cache. In order to try to fix these problems, the first step is to clear both cookies and the cache.
Note: This will temporarily log you out of all sites you're logged in to.

To clear cache and cookies do the following:

  1. Go to Firefox > History > Clear recent history or (if no Firefox button is shown) go to Tools > Clear recent history.
  2. Under "Time range to clear", select "Everything".
  3. Now, click the arrow next to Details to open the Details list.
  4. From the details list, check Cache and Cookies and uncheck everything else.
  5. Now click the Clear now button.

More information can be found in the Clear your cache, history and other personal information in Firefox article.

Let me if it worked.

more options

Are you saying you don't see the green triangles, or when you click the green triangles, nothing happens?

If the triangles are nonresponsive, is it possible that you are blocking some scripts from running on Google? There are many extensions that might have this effect. You could try Firefox's Safe Mode as a quick test of whether interference by an extension is a possible explanation. More info: Diagnose Firefox issues using Troubleshoot Mode.

You can restart Firefox in Safe Mode using

Help > Restart with Add-ons Disabled

In the dialog, click "Start in Safe Mode" (not Reset)

Any difference?

more options

Already tried Safe Mode. No luck. FYI, Green triangle is there but not responsive. Same with Options Gear icon.

more options

This is IN FACT a Firefox issue. I am not having the same problem with Safari.

more options

Everybody--I appreciate your attempts to help but if I had to resort to modifying the hosts file (which didn't work) you can be certain I tried all the obvious stuff before that--safe mode, clearing cookies/caches, new profiles etc. Are there any power users out there with any ideas?

more options

Chosen Solution

Hi Andiamo53, are you the Andee Brwn who posted on the userscript discussions page?

If the triangles aren't working, but Greasemonkey is still running on Google, you could update the script. I just added a new option to replace the triangle with inline links. Maybe that will work around the problem you're having.

(I have to update the screen shots, but can't do that at the moment.)

more options

Oh Jefferson, you are a genius. Your fix worked splendidly! Thanks so much. Yes, I am that same person who posted in the discussion tab. I will post again to reflect my gratitude for your effort.